Export Gedcom File ~ (AGS) Ancestris Genealogy Software

Introduction

Ancestris is entirely free for Windows, Mac, and Linux. Visit https://www.ancestris.org/ for details.

It offers one of the most complete GEDCOM implementations for both Standard 5.5 and Draft 5.5.1.

See the Import Details for migrating the exported GEDCOM into any Ancestris version.

The Character Set Encoding option defaults to UTF-8 but works for UTF-16 & ANSI and all Unicode characters are supported.

Most Media conversion modes are supported.

See both the (AGS+) Full Data Export Details and (AGS-) Brief Data Export Details below.

(AGS+) Full Data Export Details

All the (Sdr) Standard Gedcom Draft 5.5.1 rules apply except as defined below.

Header Record (HEAD)

★ Named List Entry (_LIST, _FLAG, _NOTE, _IDS)

See Extra Options tab Named List Entry 1 _LIST:

The details of each Named List are placed in a synthesised Source Record whose TITLe starts with Ω Named List:, and each associated Individual/Family Record has a link to the Source Record.

★ File Root (_ROOT)

See Extra Options tab File Root 1 _ROOT:

The File Root details are placed in a synthesised Source Record whose TITLe starts with Ω File Root:, and the associated Individual Record is linked to this record.

The Individual Record itself is moved to just after the HEADer record to be treated as the root record.

★ Other Tags (FILE, _VAR, _UID, SUBM)

These tag lines are all removed.

★ Destination & Place Hierarchy (DEST, PLAC, FORM)

The header line 1 DEST ANY is inserted.

The header line 1 PLAC is inserted followed by 2 FORM jur1, jur2, jur3 etc, depending on the maximum Place part jurisdictions found.

(AGS-) Brief Data Export Details

All the (Sdr-) Standard Gedcom Draft 5.5.1 Brief Data Export Details apply together with the (AGS+) Full Data Export Details defined above, except that all the Header Record (HEAD) tags mentioned are removed, apart from the ★ Destination & Place Hierarchy tags.

Import Details

Installation Process

The download & installation of the Ancestris Daily Version is straightforward.

The How To Install… Ancestris Installation page has Java prerequisite advice. Follow the Installation on Windows step-by-step guide.

Import GEDCOM File

From the Welcome > My Ancestris tab, or File menu, or toolbar, use Open a genealogy and choose the fh Plugin Export folder and the Project…AGS UTF8.ged file to import.

In the Open GEDCOM dialogue choose Do not convert to import the file unchanged, but choose Convert to create an Ancestris copy in the same folder with any errors corrected.

Use Tools > Gedcom > Validation of data and Gedcom format to obtain a validation report.

Preferences & Views

The Tools > Preferences > Editing tab allows a Default editor to be chosen.
The Aries editor is most like the fh Property Box. The Gedcom editor is like the fh All tab.

The Tools > Preferences > Extensions > Validation tab Places not matching format in header are valid inhibits warnings about the number of jurisdictions comma separated place parts.

Use View > Entities table to obtain a display like the fh Records Window.

Use View > Dynamic tree to obtain a display like the fh Ancestor and Descendant Diagram.

Use View > Cygnus/Gedcom/Aries editor to display any record.

Use View > Table of places to obtain a display like the fh Tools > Work with Data > Places.

CC Attribution-Noncommercial-Share Alike 4.0 International
Runs using DokuWiki Recent changes RSS feed www.rjt.org.uk