Sharing Data using a USB Stick

Introduction

So now you have installed FH software and are itching to get started, but wait and spare a few moments to think about how you are going to use the software. FH is very powerful and there are various ways to record and store information, so it is worth planning for this to avoid finding out later that there are different and better ways to do this.

FH in its simplest form, records people. It then records information such as date of birth, death, census data, etc, which are called Facts. In turn any Fact can be linked (by a Citation) to a Source which might be a Birth Certificate, an image, or document, or a recording. These Sources give you some evidence of the Fact you are including against a person’s record and are very important. You will need to store these Source document Media files somewhere and still be able to link the persons Fact with that Source. You may also wish to have photographs to link to a person or a place that is associated with that person.

Using Two Computers

The FH program will be installed on your computer and by default any additional data files Images, documents etc, will also be stored on your computer. There is nothing wrong with this, however, many people will want to use their data on a second computer on which FH is installed, say a laptop. If you want to do this you will find that FH cannot find the data on the second computer, which you have input on your first computer.

There are a number of ways to ensure that the same data is used on both computers. If you have a Network drive you may wish to hold the data on that so that both computers can access that drive. A cheaper and some would say a better alternative is to use a USB pen drive memory stick.

If you go for this option choose a memory stick of a size to suit your purpose. As a guide a 32 Gbyte memory stick will hold the data for at least 16,000 records including all the images documents etc.

USB Drive Letters

One niggling little problem with this method is that each time you move the memory stick from one computer to another the drive letter may change. If this happens, when fh is opened you will need to browse for the project or GEDCOM file to open it. This can be overcome by following the steps below so that each time you change computer it will automatically open the right file.

The following applies to those who want the flexibility of using a memory stick, but set its drive letter so that multiple computers will find the right data and open your own Family History file. These steps work for Windows Vista and Windows 7, 8 & 10, other operating systems may be different.

If your memory stick is empty that is fine, but if you have already saved your fh Project file to the memory stick just make sure that fh is not running when you undertake these steps.

Click Start, click Control Panel, click System and Security or Search for Control Panel:

In System and Security click Administrative Tools:

In Administrative Tools click Computer Management. You may need to use right-click and Run as Administrator. If you have User Account Control you may get a message asking if you wish to continue; click Yes:

In Computer Management click Disk Management:

In Disk Management highlight the drive of your memory stick and right click. A pop up menu will appear and click Change drive letter and paths:

Click on the drive letter which opens a list for you to choose a new letter. In the example shown the drive letter has already been changed. Yours will probably show E or F. When you change the drive letter you will get a prompt asking you to confirm that you wish to proceed. It is perfectly safe to proceed if your memory stick is empty or contains only data files, including images. Preferably choose a letter high in the alphabet to avoid any fixed devices.

When you create your first Project or GEDCOM file and save it, the Project or GEDCOM file will be saved to your computer. You will need to locate the Project file (the whole Project folder including sub folders) and copy and paste it to the memory stick. Alternatively, use File > Project Window, select the Project, then clcik More Tasks > Copy Project and browse to the USB drive. If you use the GEDCOM method, the GEDCOM file and all the folders where you have linked media files should also be moved to the memory stick.

The first time you open fh after this exercise you will need to browse to the memory stick to find the Project or GEDCOM file. Then when the file is open in fh go to Tools > Preferences > Startup and make current file the Default Startup File. This will need to be done on both computers.

Alternatively, for Projects, change the File > Project Window > Location to refer to the folder on the USB drive.

This may sound complicated but it will only take about 10 minutes, which is time well spent as it will save a lot of hassle later.

Don’t worry if you are not confident to undertake this. It just means that you may have to browse to open the file when you change computers.

Other Storage Issues

Soon after becoming familiar with FH it is quite likely that you will want to explore the FHUG website and download some of the really useful add-ons which will enhance your experience.

It is not the purpose of this article to discuss the various downloads available, save to say that the main ones are Queries & Icons in FHUG Downloads, and Plugins. More information on these items can be obtained by clicking the links.

Files downloaded from the FHUG website will probably be saved to your computer C: drive, and if they are opened will be installed by FH and reside within the C: drive. This means that they will only be available to the computer on which it is installed. It is suggested that in order to ensure complete compatibility with another computer any items downloaded should be saved to your memory stick.

At the outset it is suggested you create some folders on your memory stick where these can be saved, so create new folders on the memory stick for Icons, Queries and Plugins.

In Windows Vista your are prompted as to where you wish to save a download, in this case browse to the relevant folder on your memory stick and save it there. When a Query is downloaded click on the downloaded file to install it into FH. That Query will be available on multiple computers.

Icons are installed from within FH so when you come to add an Icon browse to the relevant file on your memory stick. Once loaded that will also be available on multiple computers.

Plugins will need to be installed on each computer, however once saved to your memory stick it is easy to browse to the desired file to install it. Once installed it will be available on multiple computers.

In Windows 7 downloads are automatically saved to a download folder. Instead of opening the file from that folder right click on the download and click Open containing folder. The file will be located and then copy (right click copy) and paste (right click paste) it to your memory stick folder before clicking to open the file.

Section how_to:v4