Understanding the Scope of Features

Introduction

When starting to use Family Historian it quickly becomes clear it has many features and can be highly customised. What is not so clear is what impact those commands, features and customisations have on projects. Do they affect all projects or just the current project? When you add Flags or Facts or change the Options in Preferences, a Diagram, a Report, or a Query what do they affect.

Family Historian stores details of such changes in various places on your PC, and the scope of each is explained below.

Note that some features have restrictions. For example Expressions used in Diagrams, Reports, Queries, etc, are often restricted in their character length.

Windows Registry

The Windows Registry is where many applications on your PC store their settings, and Family Historian is one of them. The settings stored there either affect all Projects on the same PC, or all Projects owned by the User account. These settings cannot be reliably transferred to another PC, except as described later.

The features that store settings in the Windows Registry are:

  • File > Project Window > Location for Project root folder path affects whole PC (V4+)
  • File > Import/Export > Import > User Credentials for Internet Data Matches affects whole PC (V6+)
  • Tools > Work with Data > Places > Columns option affects whole PC
  • Tools > Work with Data > Addresses > Columns option affects whole PC (V5+)
  • Tools > Preferences > General tab all options affect whole PC
  • Tools > Preferences > Navigation/Display tab all options per User (V5/V6+)
  • Tools > Preferences > Startup tab Default Startup File & Register as Default for GEDCOM affect whole PC
  • Tools > Preferences > Startup tab Display the Records Window & Check for Updates are per User
  • Tools > Preferences > Focus Window tab all options per User (V4+)
  • Tools > Preferences > Internet Data Matches tab all options per User (V6+)
  • Tools > Preferences > Property Box tab all options per User, except that Captions affect whole PC
  • Tools > Preferences > Diagrams tab all options affect whole PC
  • Tools > Preferences > Records Window tab all options per User (V5+)
  • Tools > Preferences > Media tab all options per User (V6+)
  • Tools > Preferences > Map Window tab all options per User (V6+)
  • Tools > Preferences > Query Window tab all options per User
  • Tools > Preferences > File Load/Save tab options affect whole PC, except Automatic snapshot is per User (V6+)
  • Tools > Preferences > Workspaces tab all options per User (V6+)
  • Tools > Preferences > Estimates tab all options affect whole PC
  • Tools > Preferences > Named Lists tab all options affect whole PC
  • Tools > Preferences > Backup tab all options affect whole PC
  • Tools > Preferences > International tab option affects whole PC
  • Tools > Record Window Options tabs and options per User (V4)
  • Lists > Configure Record Window Columns for each Record Window tab per User
  • View > Standard Diagram Types > Ancestors / Descendants / Ancestors & Descendants / All Relatives / Everyone / Blank Diagram (V5+) > Diagram Options for the Core Standard Diagrams settings per User
  • Window/Pane/Column sizes & positions (for some windows) are saved per User

In order to Move Family Historian Settings and Projects to another PC, the Backup and Restore Family Historian Settings Plugin is capable of transferring these Registry settings, and there are methods of preserving most Registry settings in the Program Data Folder or Projects Folder.

If you have projects synchronised on different PC, then ensure that compatible settings are used on all the PC.

Note that File > Print Setup configuration only persists while Family Historian is open.

Program Data Folder

The Family Historian Program Data Folder is managed by Family Historian and stores most of the other settings not mentioned above. The settings stored there affect all Projects on the same PC, and any other PC that synchronises with the folder. The folder should be included in your regular file backup regime.

The features that store custom settings in the Program Data Folder are:

  • File > Import/Export > Import > Diagram Type down to Property Box Tab
  • File > Import/Export > Import > Accent Set and Save Accent Set button (V6+)
  • File > Import/Export > Import > Colour Scheme (V6+)
  • View > Standard/Custom Diagram Types > Diagram > Options except Core Standard Diagrams
  • View > Standard/Custom Diagram Types > Diagram > Save Diagram As > Custom Diagram Type
  • View > Standard/Custom Diagram Types > Diagram > Options > Text tab > Text Scheme > New/Clone/Edit
  • View > Standard/Custom Diagram Types > Diagram > Options > Boxes tab > Edit Features > Icons although Icons can also be stored anywhere else
  • View > Custom Queries > New/Save As Custom Query for Custom Queries only
  • View > Properties > Menu > Customize for Property Box Tab Customisations (V4+)
  • Reports > Standard/Custom Reports > Report Options and Save Report As > Custom Report Type (V4)
  • Publish > Standard/Custom Reports > Report Options and Report > Save Report As > Custom Report Type (V5+)
  • Tools > Work with Fact Sets/Fact Types for Standard and Custom Fact Sets customisation
  • Tools > Plugins and File > Import/Export > Import > Plugins scripts and data (V5+)
  • Edit > Record Flags and Tools > Work with Named Lists and Flags but only if the Flag Status Always include this record flag in flags lists is ticked
  • Internet > Search the Internet although these cannot be customised

Many (but not all) of the above Custom settings can also be saved in any Projects Folder by using the File > Import/Export commands.

Public Documents Folder

The C:\Users\Public\Documents\Calico Pie\Family Historian\Tutorial Files\ folder, or on earlier Windows versions the C:\Documents and Settings\Public\Documents\Calico Pie\Family Historian\Tutorial Files\ folder, holds the tutorial files associated with Chapters of the Getting the Most From Family Historian book prior to FH V6.

Initially it contains the contents of the C:\Program Files{ (x86)}\Family Historian\Samples\Tutorial Files\ folder.

Projects Folder

Each Projects Folder structure is managed jointly by you and Family Historian, and holds a few other settings not mentioned above. Their default location for each Project is C:\Users\{username}\Documents\Family Historian Projects\{projectname}\ or on earlier Windows versions C:\Documents and Settings\{username}\My Documents\Family Historian Projects\{projectname}\. The settings stored there only affect that Project and any synchronised copies on other PC. These folders should be included in your regular file backup regime.

The features that manage settings in the Projects Folder are:

  • File > Project Window > New Project / More Tasks except those that set the default Project Location (V4+)
  • View > Standard / Custom Diagram Types > Diagram > Save Diagram for Family Historian Charts
  • View > Standard / Custom Diagram Types > Diagram > Save Diagram As > Family Historian Chart
  • View > Saved Charts are saved in the …\{projectname}.fh_data\Charts\ folder
  • Internet Data Matches hint status is in the …\{projectname}.fh_data\Cache\ folder (V6+)
  • Publish > Books are saved in the …\{projectname}.fh_data\Books\ folder (V5+)
  • Window > Log Files are held in the …\{projectname}.fh_data\Log Files\ folder (V6+)
  • Tools > External File Links helps manage Multimedia files stored in the …\{projectname}.fh_data\Media\ folder, &/or elsewhere
  • Tools > Plugins sometimes save their settings in the …\{projectname}.fh_data\Plugin Data\ folder (V5+)
  • File > Backup/Restore > Revert to Snapshot held in the …\{projectname}.fh_data\Snapshot\ folder (V6+)
  • Tools > Make a Family Tree CD wizard settings are in the …\{projectname}.fh_data\Settings\ folder (V4)
  • Internet > Create a Website wizard settings are in the …\{projectname}.fh_data\Settings\ folder (V4)
  • Publish > Make a Family Tree CD/DVD wizard settings are in the …\{projectname}.fh_data\Settings\ folder (V5+)
  • Publish > Create a Website wizard settings are in the …\{projectname}.fh_data\Settings\ folder (V5+)

These last four features use the …\Public\FH CD\ folder, …\Public\FH Web Page\ folder, …\Public\FH CD-DVD\ folder, and …\Public\FH Website\ folder respectively to store their created web page files.

GEDCOM File

The GEDCOM file is managed by Family Historian and stores everything else not mentioned above. Its location within the Projects Folder for each Project is …\{projectname}.fh_data\{projectname}.ged and only affects that Project and any synchronised copies on other PC.

The features associated with the GEDCOM File are:

  • View > Records Window presents and manages the GEDCOM File Records via each Tab
  • View > Properties presents and manages the GEDCOM File Records via each Property Box
  • Tools > Work with Data manages data stored in GEDCOM File Records
  • Lists > Named Lists Pane details are saved in the GEDCOM File
  • Edit > File Root settings are saved in the GEDCOM File
  • Edit > Record Flags assigned to Individual Records are saved in the GEDCOM File

All other commands not mentioned so far, provide features for managing the GEDCOM File.