Report Content, Media, Format and Layout

Report Options

Several Family Historian options involve the creation of Reports either in isolation, or incorporated into Family Tree Website/CD/DVD, or added to Books in Version 5 or later.

  • To adjust the features in an isolated Report, use its Options button or Report > Report Options command to display the Report Options window.
  • To adjust the features in a Book via the Edit Book window, use either the Book Settings button, or select the Report in the Current Book Items and use the Settings button. Alternatively, adjust the Report in isolation before creating the Book.

The tabs listed below appear in different combinations in the various windows opened using the methods above.

Within these sections, popular features that are often overlooked, are marked with an exclamation mark :!:.

  • Main, or Contents tab for Names, main data items, and Event/Attribute Facts
  • Pictures tab for Individual, Family, and Fact linked Multimedia images
  • Sources tab for Source Citation details and linked Multimedia images
  • Index tab for optional cross-reference index
  • Format tab for the font, style, and text of headings
  • Page Layout tab for page orientation, margins, indents, tabs, headers & footers
  • Privacy tab for excluding Private and Living details

After satisfactorily customising a Standard Report it is advisable to use Save Report As > Custom Report Type in order to preserve the settings without disrupting the Standard Report style, which can be restored by using the Installation Settings button on each tab.

:!: Some Report Options, such as Picture Gaps, the Format Fonts & Styles, and Page Layout do NOT affect HTML Reports used in Family Tree Website/CD/DVD, so the Family Tree Tips ~ Alter CSS Default Styles technique must be used.

It is useful to have shortcuts from the Table of Contents or the Index to the associated item within a large multi-record Report. To create such shortcut hyperlinks in the electronic version of a Report use word-processor and PDF features as explained in Forum posting NARRATIVE REPORT FOR "ALL RELATIVES".

First use Save Report As > Word-Processor Document (RTF) and edit the .rtf file with a word-processor such as MS Office Word. A contents table can be inserted using References > Table of Contents and both the Contents and Index will be composed of hyperlinks. When finished, use Save As > PDF and the resulting .pdf file will retain the hyperlinks.

Book Free Page Content

See Index for related topics

Sometimes a Publish > Books page may need images and text that cannot be created using a standard Report. So try using View > Standard Diagram Types > Blank Diagram that offers some features like a word-processor to compose the page based on the following steps.

  • Use Diagram > Options > Background: One colour and in Options select white, OK.
  • Use Diagram > Insert into Diagram > Picture and choose any image file.
  • Adjust the size & position of this image similar to an image inserted into MS Word.
  • Use Diagram > Insert into Diagram > Text Box and draw a box where text is wanted.
  • Use Diagram > Format and enter the Text required on the page. It can combine plain text with Expressions to extract data from the Project.
  • Click Font button and choose a font, style, size, colour, etc.
  • Set Alignment as required to Left, Centred, Right, or Justified.
  • On Line and Fill tab set Fill and Line to None or as required.
  • Repeat any of above for more images & text, and drag them where wanted on page.
  • Use Diagram > Order & Grouping to put say text over images, or group images & text into single entities.
  • Finally use Diagram > Save Diagram As > Family Historian Chart with an appropriate name, which will appear in the Book table of Contents.

Now in Edit Book select Saved Chart, then click > and choose the Chart name saved above.

In Select Chart Pages click Position on Page, then use cursor to drag to middle of one page.

Book Free Page Example

Sharing Settings Across Projects

The Report Options for all Reports are shared by all Project via the Family Historian Program Data Folder.

The Wizard settings for Family Tree Website/CD/DVD are saved per Project in the …\{projectname}.fh_data\Settings\ folder. So to get another Project to inherit those settings, use Windows File Explorer to copy that Settings folder to the other Project folder.

The Book Settings are saved per Project in the …\{projectname}.fh_data\Books\ folder within a sub-folder with the same name as each Book. To migrate Book Settings to another Project perform the following steps:

  • Use Publish > Books, select a Book, and click Clone button to create a dummy Settings book
  • In that dummy Settings book, delete all but its Contents and Index sections
  • Use Windows File Explorer to copy that Books\Settings folder to the other Project folder
  • In other Project, use Publish > Books, select Settings book, and click Clone button to create a new book