Move Family Historian Settings and Projects

Introduction

Sooner or later everyone gets a new computer, or a second computer, and needs to migrate Family Historian (fh) on to it. Most of the information for your family history will be stored in your GEDCOM file and attached multimedia files, or in your Project Folder with V4 or later, but some items such as Text Schemes, Queries, Fact Sets, etc, are stored elsewhere.

Also your current computer may break down. In any case it is important that you have back-ups of all the necessary data. The following sections explain where fh keeps its data items and customisations that need to be backed-up or transferred in order to retain everything you use. See also the Backup and Recovery advice.

If you are using fh V5+ Projects then the Family Historian V5 & V6 Migration Guide replaces all the following sections and gives step by step instructions to migrate fh from one PC to another PC.

Export and Import Options

As of fh Version 3 there are options on the File menu to allow single items, such as a Query or Text Scheme to be exported to a folder of your choice and to import new items in. This works well when sharing single items with other users, but can be time consuming as a method of backing-up or moving things where you have many custom items.

Version 4 and Above - Projects

The simplest way to move these is to copy the entire folder to the new computer using Windows File Explorer (Windows key + E) via some intermediate storage such as a USB pen drive memory stick. This will move the GEDCOM file itself, all your linked Multimedia in the Media sub-folder, and any other project files, to the new computer.

If fh Version 5 or later is installed on both PC, then on the old PC you can use File > Backup/Restore > Full Backup (Entire Project Folder), copy the FH Project Backup - … .zip file to the new PC, and use File > Backup/Restore > Restore Backup on this file.

However, with either method above, if you keep your Multimedia outside the Project folder, then they will need to be copied separately, but will almost certainly result in 'broken links' on the new PC.

For the above to work satisfactorily, all Multimedia image file links must use Relative Paths and NOT Full Paths, otherwise they will all become 'broken links'. To check, use Tools > Work with External File Links and ensure all links are within Project Data Folder - Media, and drive letters such as C: are NOT mentioned. To convert Full Paths then use Re-map within Project Data Folder or run the V5+ Plugin Check and Repair Media Links.

If you have NOT customised any features listed below, you can simply copy your Project folder and not worry about anything else.

  • Any Diagrams, Icons, Fact Sets, Queries, Reports, Text Schemes, etc, including Standard ones.
  • Any Property Box Tabs or Records Window Columns or Plugins or Internet Search settings.
  • Any Tools > Preferences or Tools > Record Window Options (V4) or Tools > Work with Data > Places/Addresses > Columns.
  • Any Unicode Accent Sets (V6) or dialogue Colour Schemes (V6).
  • Any Tutorial Files for Chapters of Getting the Most From Family Historian.

If any of the above have been customised and you are using fh V5+ Projects then the Family Historian V5 & V6 Migration Guide should be all that is needed, otherwise read on

Version 5 and Above - Plugins

fh V5 introduced a new Plugin feature that allows virtually all the techniques described below to be automated.

Use Tools > Plugins and visit the Plugin Store to see what's available; search for "Backup" to find Plugins you need.

The Plugin specifically designed to migrate fh V5+ settings from one PC to another is Backup and Restore Family Historian Settings. See its Help & Advice pages for details, and in particular the Moving from PC to PC advice. All the techniques given below can be ignored.

Application Settings

The follow items are stored in a set of folders on the PC, in a different place to the fh application:

Items Family Historian Program Data Folder
Diagrams \Calico Pie\Family Historian\Diagrams\Standard & \Custom
Fact Types \Calico Pie\Family Historian\Fact Types\Standard & \Custom
Flags \Calico Pie\Family Historian\Flags
Fan Chart/Plugins \Calico Pie\Family Historian\General (V5+)
Map Geocoding \Calico Pie\Family Historian\Geocode (V6+)
Icons \Calico Pie\Family Historian\Icons
Accent Sets \Calico Pie\Family Historian\International (V6+)
Map Geocoding \Calico Pie\Family Historian\Map\Cache (V6+)
Plugins \Calico Pie\Family Historian\Plugin Data (V5+)
Plugins \Calico Pie\Family Historian\Plugins (V5+)
Property Box Tabs \Calico Pie\Family Historian\Property Box (V4+)
Queries \Calico Pie\Family Historian\Queries\Standard & \Custom
Reports \Calico Pie\Family Historian\Reports\Standard & \Custom
Website Family Tree \Calico Pie\Family Historian\Settings
Text Schemes \Calico Pie\Family Historian\Text Schemes\Standard & \Custom
Colour Schemes \Calico Pie\Family Historian\Themes (V6+)
Internet Search \Calico Pie\Family Historian\Web Search

The Family Historian Program Data Folder location of these folders depends on the operating system on your computer. This location is NOT in the Program Files or Program Files (x86) folder.

Transferring the Folders

The best way to move these items is to copy the Calico Pie folder over to the new machine after fh has been installed. You will need to be logged on to your PC as an Administrator otherwise the folder may not be visible. If you still cannot see the folder via Windows File Explorer (Windows key + E), follow the advice in the Family Historian Program Data Folder Notes. Remember that if you are moving from Windows XP to a later version of Windows you must copy the Calico Pie folder from C:\Documents and Settings\All Users\Application Data into C:\ProgramData. Do NOT use C:\Program Files or C:\Program Files (x86).

It is also important to include this Calico Pie folder in your regular file back-up regime.

When moving from PC to PC, if fh is also being upgraded from V3 or V4 to V5 or later, then special care must be taken with Diagram Type (.fhd) files. Three methods are suggested:

  • Install fh V5+ on the old PC so the .fhd files are converted to .fhdx files before copying the Calico Pie folder.
  • Copy the Calico Pie folder from PC to PC before installing fh V5+ on the new PC, which will convert the files.
  • Export the Diagram Type (.fhd) files on the old PC, and Import them into fh V5+ on the new PC.

Tools Preferences

Some preferences are stored in the Windows Registry, but for most users, it is easier to simply manually change these on the new computer rather than trying to extract and apply the changes using regedit.

It is worth making a note of your important Tools > Preferences and Tools > Record Window Options (V4) and Tools > Work with Data > Places/Addresses > Columns prior to moving to a new computer. One way of achieving this is to take a screen-shot of each settings window using the PrintScreen button, the Snipping Tool, the Problem Steps Recorder, or something similar, and save them in your Project Folder. If more than one user account uses fh, then this should be repeated for each account in case they use different settings.

Core Diagram Settings

The Core Standard Diagrams for Ancestors, Descendants, Ancestors & Descendants, All Relatives, Everyone, and V5 Blank Diagram need special attention to move their settings.

The settings for these Diagrams (displayed via the View > Standard Diagram Types menu or via buttons on the fh toolbar) are stored in the Windows Registry, rather than in the Family Historian Program Data Folder described above for all other Diagrams. The settings can be copied to a new machine as follows:

  1. View one of the Standard Diagrams and use Diagram > Save Diagram As > Custom Diagram Type to create a new Custom Diagram Type containing your current settings.
  2. Transfer this Custom Diagram Type settings file over to your new PC - either by using File > Export/Import, or by copying it between the appropriate folders (as explained above) on each PC.
  3. Once you have copied the Custom Diagram Type file onto the PC, you can make those settings the default for these Windows Registry based 'button-driven' Standard Diagrams too. On the PC, select someone at random, and use View > Custom Diagram Types to open your new Custom Diagram Type, and then choose Diagram > Settings > Save As Default Settings.

Only one Custom Diagram Type settings file is needed because all Default Settings apply to all five Standard Diagrams, with the exception of the Generations Up/Down options, which can easily be adjusted per Diagram Type.

If more than one user account uses fh, then this should be repeated for each account in case they use different Diagram defaults, taking care to use a different Custom Diagram Type name for each account.

Diagram Icons

If you have used your own Custom Icons in Diagrams, then they could be located anywhere on your PC.

View the Diagram and use Diagram > Options > Boxes, select the Condition and Edit Features button. In the Icon section, click the <<Select button, and the Select Icon window will identify the folder and Icon filename. Repeat this for each Condition that has an Icon. Now you know what Icon files to move to the new PC.

It might be advisable to move these Icon files either into your Family Historian Projects folder in a folder called Icons, or into the \Calico Pie\Family Historian\Icons folder mentioned above. The Diagram Icons will then need to be reselected.

Record Window Columns

If you have Custom Record Window Columns save these as Custom Queries from the Configure Columns editing dialogue so you can restore them from the Custom Query on the new PC.

If more than one user account uses fh, then this should be repeated for each account in case they use different Custom Columns, taking care to use a different Custom Query name for each account.

Tutorial Files

If you have used any of the tutorials associated with Chapters of the Getting the Most From Family Historian book prior to fh V6, and you wish to retain where you have got to, then these tutorial files also need to be transferred.

The C:\Users\Public\Documents\Calico Pie\Family Historian\Tutorial Files\ folder, or on earlier Windows versions the C:\Documents and Settings\Public\Documents\Calico Pie\Family Historian\Tutorial Files\ folder, holds the tutorial files that need to be copied.

Using Non-Default Locations

By default all the Family Historian Projects, installation Program Files (x86), and Family Historian Program Data Folder are stored on the C: drive.

With the advent of SSD and multi-drive PC it is becoming increasingly common to want to relocate those folders onto a different drive.

Some of the folders are easy to move, but others are technically challenging and should only be tackled with the appropriate expertise. The advice below starts with the easy options and gets progressively more complex.

If you apply any of these settings, then next time fh is installed, check the settings are still correct.

Family Historian Projects

This is an easy and fairly safe move.

First use Windows File Explorer (Windows key + E) and Copy the Family Historian Projects folder from My Documents to its new location, say F:\Family Historian Projects.

In fh use File > Project Window and click the Location: link My Documents\Family Historian Projects, select Choose Location… and browse to its new location, say F:\Family Historian Projects, and click OK.

Your Projects should be listed as before, but in the new location. Remember to select your Default Project in this new location. When satisfied, Delete the original Family Historian Projects folder from My Documents.

Program Files Folder

This affects the C:\Program Files (x86)\… folder on 64-bit PC, or the C:\Program Files\… folder on 32-bit PC.

fh installs two products: Family Historian itself, and the Nova PDF Printer.

C:\Program Files (x86)\Family Historian\ is ~27MB with sub-folders Books, Diagrams, Fact Types, Flags, Program, etc. It can easily be relocated by reinstalling fh and choosing a different installation folder during the dialogue. Then if necessary the original folder can be deleted.

C:\Program Files (x86)\Calico Pie\Family Historian PDF\ is ~4MB with sub-folders AMD64 and i386. This can only be relocated by using Utility ~ Link Shell Extension or Utility ~ Windows Directory Junctions. Create a Family Historian PDF folder in its new location, then move the contents of the original folder to this new folder using Windows File Explorer. Use one of the utilities to establish a symbolic link/directory junction between the two folders.

Program Data Folder

The location of the Family Historian Program Data Folder depends on the Windows version and may be hidden.

Since Windows Vista it is at C:\ProgramData\Calico Pie\Family Historian\ is initially ~14MB with sub-folders Diagrams, Fact Types, Flags, General, etc. This can only be relocated by using Utility ~ Link Shell Extension or Utility ~ Windows Directory Junctions. Create a Family Historian folder in its new location, then move the contents of the original folder to this new folder using Windows File Explorer. Use one of the utilities to establish a symbolic link/directory junction between the two folders.