Import from MyHeritage (MYH)

Introduction

MyHeritage is normally a straight forward import to Family Historian. However, if Media need to be transferred then use the Windows companion program Family Tree Builder synchronised with the MyHeritage online tree.

Export GEDCOM from MyHeritage Online Family Tree

Use the Family tree > Manage trees > Export to GEDCOM option and save the GEDCOM file in a memorable location.

Include photos in the export. However, this only provides URL links to the online images that fh cannot handle, so use Family Tree Builder to download image files.

Export GEDCOM from MyHeritage Family Tree Builder

Use the File > Export GEDCOM command and save the GEDCOM file in a memorable location.

Take care to choose appropriate options in the export dialogue. Include all people, save notes, sources & photo information, but do not omit living people or private data.

Accept the offer to copy exported photos into a subfolder.

Create New Project

Check for word-wrapping errors

First use File > Project Window and the New Project button, and select Import a GEDCOM file. Browse to the GEDCOM file saved by MyHeritage. The dialogue is uncomplicated, but in the Check for word-wrapping errors window, select Each row contains 1 word with a hyphen in the middle.

See Understanding Projects for more information on creating a Project from GEDCOM & media files, and using the Project Window.

Once the Project is fully functional the original exported GEDCOM file and photos subfolder can be deleted.

Correct Problems

The import process will create two log files found via Window > Log Files that report problems that must be corrected, and the most common cases are listed below. They will differ depending on whether the Online Family Tree or Family Tree Builder was used to create the GEDCOM file.

  • There will be many Automated Record Id (RIN) fields holding values such as MH:I8 that will be visible on the All tab of the Property Box of many types of record.
    They can be removed by using the Search and Replace Plugin. Choose LUA Pattern Mode with the Search box set to ^MH:.+ and on the Extra Filters tab only tick Permanent & Automated Record Number fields.

As other problems are discovered their suggested correction will be added here.