Family Historian V6 & Ancestral Sources V5 on Crossover, PlayOnLinux/Mac & Wine

Introduction

This advice has been obtained from FHUG members who have succeeded in installing Family Historian (FH) and Ancestral Sources (AS) into Windows emulators such as CodeWeavers CrossOver and PlayOnLinux & PlayOnMac that are reliant on WineHQ.

The advice below applies to these or later stable versions, but also see Reported Problems.

FIXME ~ need to confirm some versions.

FIXME ~ The following sections need updating for PlayOnLinux & PlayOnMac.

Program Installation

The Crossover Bottler, Wine Bottler, and native Wine installation processes should be similar for Mac and Linux platforms.

Install the programs below into a Windows 7 or Windows 8 configuration. Do NOT use Windows XP.

In Crossover (as of Dec'15) select install a Windows Application as normal. Create a new Win 7/8 Bottle for Family Historian V6 as an unsupported other application.

In Wine run winecfg, and with Default Settings selected under Applications, set Windows Version to Windows 7, and ensure that Drives are set appropriately. Install programs using the wine command to specify their installation .exe file. (It is not certain whether WINEARCH is required to set a win32 wineprefix for FH which is a 32-bit application.) See Wine User's Guide part 3 Using Wine.

When installing FH, disable Create a desktop icon and disable Launch Family Historian. Ignore messages saying FH is incompatible with Windows 7/8 or that the installation was incomplete.

Install these applications:

In Crossover use Crossover CrossTie to download Windows Script 5.7 or tick option (needed by some Plugins)

A Crossover CrossTie for FH and AS is being considered.

Installing Ancestral Sources in PlayOnMac

  1. Create a new non-listed application bottle
  2. Select Install a program in a new virtual drive
  3. Select Install some libraries
  4. Scroll down the list and select POL_Install_dotnet35sp1
  5. Allow Microsoft fonts to be installed
  6. Select I Agree
  7. DotNet 2.0, 3.0 and 3.5 then download automatically and install. This can take some time. If this install fails due to timeouts then cancel it and start again using the overwrite option when choosing the same bottle. It will usually complete installation on the second attempt but may need a third
  8. Once this has completed successfully then select and install the 32bit version of Ancestral Sources
  9. Finally select Ancestralsources.exe as the programme to run

When running Ancestral Sources and adding an image you may get an error message. The continue option can be chosen and the image will be added correctly.

Program Configuration

To ensure FH Reports display text correctly, set Tools > Preferences > General > Advanced > Emulator Compatibility Mode.

Ensure the Crossover window remains on the Mac screen on which it is opened, and does not follow the cursor when swiped to another screen. To achieve this, locate the Dock and right-click (control-click) the Crossover icon, go to Options, and ensure it is set to This Desktop. Repeat this with the FH and AS icons.

All the FH and AS settings below should specify similar folder paths, usually involving the Documents folder, and all the named folders and files must actually exist.

  • FH File > Project Window in the Location field
  • FH Tools > Preferences > Startup in the Default Startup File field
  • FH Tools > Preferences > Backup in the Default Backup Folder field
  • AS Tools > Options > General settings > Folders in all three fields

If necessary, it is advisable to create new folders using Crossover or Wine rather than within FH or AS windows.

The default Location for projects is My Documents\Family Historian Projects that is physically on the Mac at Documents/Family Historian Projects.

The C:\Program Files\Family Historian installation folder is physically at <username>/Library/Application Support/Crossover/Bottles/Family Historian V6/drive_c/Program Files/Family Historian where Family Historian V6 is the name if your bottle.

Configuration changes are needed as described below to allow some Plugins to work.

Program Updates

The simplest way to update both FH and AS is to use their own Help > Check for Updates commands and follow the automated download and install process, although this may not succeed in Wine.

Otherwise in Crossover, if the FH update has been downloaded, preferably using Firefox, and the program association has been made, then double-click the update exe file to apply the update in the existing bottle.

Otherwise in Wine, after the FH update has been downloaded, preferably using Firefox, it may be necessary to copy the update file to the virtual C drive and run the update exe file from there and apply it to the existing bottle. - FIXME See thread Upgrading FH to 6.2.3 on a MAC with wine for further advice.

Similar strategies probably apply to AS program updates. - FIXME

Plugins

Plugins downloaded from the Plugin Store sometimes will not import using the browser Open With option, although Save followed by an explicit Import command works OK. A workaround in Firefox is to use its Firefox > Preferences settings to associate .fh_lua Plugin files with Family Historian then Open With works OK too.

Plugin Configuration

The following COMPUTERNAME Environment Variable change is needed to allow many Plugins to work.

With Crossover V14.0.3/Version 15.0.0 the location of the bottles is slightly different from earlier versions, as is accessing them.

CrossOver All Bottles

Click on the 3 blue bottles underneath the screen sizing icons, select the Family Historian V6 bottle, and click the gear menu and choose Open C:drive. Finder will now open, so go up one level in Finder and select the cxbottle.conf file, and open it in a plain text editor such as TextEdit. Scroll to the bottom of the file to the [EnvironmentVariables] section, and at the bottom of this section add a new line, ensuring that the quotes are normal ones and NOT smart quotes:

"COMPUTERNAME" = "NAME"

Make this "NAME" unique across your computers, but do not use your Mac computer name in System Preferences. Choose an alternative name such as your first name all in capitals.

Finally Save the cxbottle.conf file.

If you are using Text Edit smart quotes are turned on by default. Turn them off by selecting Edit > Substitutions and untick Smart Quotes.

FIXME ~ A similar change is probably NOT needed in Wine (To be confirmed).

Plugin Library Modules

Some plugins require extra library modules that may not exist in your installation. The plugin will try to download the module, but will usually fail in both Crossover and PlayOnMac. The location of the module folder should be under C:\Users\Public\Application Data\Calico Pie\Family Historian\Plugins\ in Crossover and PlayOnMac.

The module folder can be downloaded as a zip file from the list below. Unzip the folder and copy or move it to the Plugins folder above.

  • md5.zip md5 MD5: Cryptographic Library
  • pl.zip pl Penlight Lua Library
  • socket.zip socket LuaSocket: Network Support

Problems With Plugins

The Plugins listed below may have limitations. Ensure that COMPUTERNAME is set as advised above.

Backup and Restore Family Historian Settings

Version 2.5 or later is almost fully operational in Crossover but fails in Wine. Even in Crossover it only detects the primary Family Historian installation, and NOT any subsidiary installations such as Family Historian Demo 3.0 or Family Historian 6.0 Beta, and it will omit the settings of any custom Named List not mentioned in the current Project.

Check Installed Plugins Against the Store

This says all Plugins are Not In Store because Crossover (& Wine?) does not support the WinHttpRequest service needed to check the Plugin Store. See Forum thread Check Installed Plugins Against the Store - Crossover issue.

Some Plugins also check the Plugin Store for a later version, but cannot do so for the same reason as above.

Therefore, it is necessary to occasionally check the Plugin Store manually to ensure you have the latest versions.

This problem appears to be partially fixed in Crossover 18.5.0 although automatic Plugin Store downloads still fail, so must be updated manually.

Printing and PDF

All FH Print Setup and Print options work with any Mac (or Linux?) printer, even when a Report is displayed incorrectly on screen (see Reported Problems below).

The free PDFWriter for Mac offers a way of creating PDF output via the FH Print commands rather than the FH Save Diagram/Report As > PDF File (.pdf) commands.

The free CUPS-PDF for Linux offers similar PDF features.

FIXME ~ The detailed capabilities of these PDF tools need further investigation.

Reported Problems

Avoid using Internet Explorer as it can lead to download issues. Instead use Firefox or Chrome in the native Mac or Linux environment.

Although the Family Historian PDF (novaPDF printer) installs, Crossover and Wine do not support Windows printer drivers, so the novaPDF printer does not work. In Crossover it can be removed via the Installed Applications dialogue Repair or Remove button, or in Wine use the wine uninstaller or wine control. Having done so, the Save Diagram/Report As > PDF File (.pdf) commands say PDF file output is not enabled.

Some FH Reports may display text incorrectly, but this is usually cured by using Tools > Preferences > General > Advanced > Emulator Compatibility Mode.

Use Tools > Preferences > Internet Data Matches > Location to Display Matches: External Web Browser to avoid problems with the internal window.

The Map Window has display rendering problems. Also there are currently issues with its events sub-window not displaying the events. The individual events are shown on the map, they just cannot be filtered. Better in Crossover 15.0.0 or later.

The FH command Tools > Preferences > Backup > <<Select > Make New Folder, and similar commands in Plugins, produce a hieroglyphic error message. The workaround is to create the folder beforehand using Crossover or Wine, and select the pre-existing folder in FH or Plugins.

AS often would not work at all prior to Crossover 15.0.0.

If FH &/or AS &/or another program are running at the same time, and one program changes the shared GEDCOM file, then the other program(s) correctly report the file has changed, but then may freeze and Force Quit must be used. This problem appears to be fixed in Crossover 18.5.0.

Users have reported FH freezes if Edit command is chosen when installed in Crossover 15.0.0. Revert to Crossover 14.1.11 to fix.

FHUG Forum Topics

These are most of the related Forum threads discussing this topic.