Family Historian V5 & V6 Migration Guide

Introduction

If you are using fh V5+ Projects then these steps should migrate everything from the old PC to the new PC.

The Licence Agreement allows fh to be installed on both PC at the same time. If the installation media or licence details have been mislaid then see Family Historian Licence Problems for advice.

Version 6 Migration Steps

These few steps define how to migrate fh V6 from an old PC to a new PC.

  • A) On the old PC ensure that V6 is installed using the Full V6 or Upgrade V4/V5 to V6 program.
  • B) Install the Full V6 or Upgrade V4/V5 to V6 program on the new PC using the current Licence details of V6 (and also V4/V5 in the Upgrade case). There is no need to install any earlier versions.
  • D) Check the new PC 4-digit version is identical to the old PC by holding down the Shft key while using Help > About Family Historian on both PC.

Continue with the Standard Migration Steps below…

Version 5 Migration Steps

These few steps define how to migrate fh V5 from an old PC to a new PC.

  • A) On the old PC ensure that V5 is installed using the Full V5 or Upgrade V4 to V5 program.
  • B) Install the Full V5 or Upgrade V4 to V5 program on the new PC using the current Licence details of V5 (and also V4 in the Upgrade case). There is no need to install any earlier versions.
  • D) Check the new PC 4-digit version is identical to the old PC by holding down the Shft key while using Help > About Family Historian on both PC.

Continue with the Standard Migration Steps below…

Standard Migration Steps

The usual objective here is to mimic the old PC configuration on the new PC, so use the old PC as a model to be replicated on the new PC. Some experts may have different objectives.

If 100% certain that ALL preferences & customisations use only Installation Settings then the three Plugin steps 2), 3) & 7) below can be omitted, but if in any doubt perform steps 2) & 3) as a precaution to create a BACKUP.

In the following steps the Family Historian Projects folder refers to whatever folder the File > Project Window > Location: specifies.

  • 1) On the old PC use Tools > (Work with) External File Links in each Project and check File Links pane to:
    • Ensure ALL File Links are listed in Project Data Folder - Media.
    • Ensure NO files or folders have any X marks.
    • Ensure drive letters such as C: are NOT listed in File Links.
      If any of those tests fail, then stop and ask for help in the Forums.
  • 3) Run this Plugin on the old PC and on its Options tab Choose Backup Folder …\Documents\Family Historian Projects\Backup or similar within the …\Family Historian Projects\ folder. Then use its Backup tab to save preference settings and customisations of Diagrams, Reports, Queries, Plugins, Fact Sets, etc. Those will be saved within a sub-folder named Family Historian within the chosen Backup Data folder.
  • 4) Copy the entire …\Family Historian Projects\ folder from old PC to new PC using Windows File Explorer (Windows key + E) via intermediate storage such as a USB pen drive memory stick, or using synchronised cloud storage. Usually this should replicate the same folders from the old PC on the new PC apart from possibly different Windows usernames, or disk drive letters, or a change in your storage strategy.
  • 5) On the new PC ensure the File > Project Window > Location: and Tools > Preferences > Startup > Default Startup File and Tools > Preferences > Backup > Default Backup Folder are specified correctly as these settings are NOT included in the migration data, because they may be unique to the new PC. However, these settings will often mimic those on the old PC so ensure both are similar.
    • Location: will usually be the …\Documents\Family Historian Projects folder.
    • Default Startup File is set by Select > Make Current File the Default assuming the main Project is open.
    • Default Backup Folder usually is …\Documents\Family Historian Projects\Backup folder.
  • 6) On the new PC check the File > Projects Window opens all your Projects OK, and in each one use Tools > (Work with) External File Links to repeat the same checks as in 1) above.
  • 7) Run the Plugin Backup and Restore Family Historian Settings on the new PC and on its Options tab tick Allow Restore Registry Data and ensure Choose Backup Folder …\Documents\Family Historian Projects\Backup or similar matches 3) above. Then use its Restore tab to migrate Tutorial Files (if any), Program Data Files, and Registry Data Keys, taking care to close fh and follow the final steps as instructed.
  • 8) To ensure Internet Data Matches are synchronised in fh V6 or later, then either use the Plugin above to Restore Registry Data Keys, or use File > Import/Export > Export > User Credentials on the old PC and File > Import/Export > Import > User Credentials on the new PC to transfer the FH User Credentials.fhcrd file.

Further Advice

See also the Ancestral Sources Migration Guide.

Once all working OK, you may want to synchronise the two PC so their data remains in step. See Downloads and Links ~ Synchronise and Backup Tools for advice on how to achieve that using Dropbox, OneDrive, or Google Drive.

An alternative technique relocates the File > Project Window > Location: to an external USB memory stick that is configured to use the same drive letter on both PC. See Sharing Data using a USB Stick. Just make sure to take regular backups, as that one USB memory stick is very vulnerable and can fail at any time.

Whenever the preferences or customisations are changed, remember to use the Plugin to repeat the above BACKUP and RESTORE process to migrate the new settings from PC to PC.

Use the above migration advice, but with the steps in a different order, to migrate from an old Windows version to a new Windows version both on the same PC, or when the old PC and new PC cannot be run simultaneously.

  • Ensure all necessary fh installation media & licence details are available for the new Windows/PC.
  • On the old Windows/PC, perform all the steps above for the old PC and both PC.
  • Replace the old Windows/PC with the new Windows/PC installation.
  • On the new Windows/PC, perform all the steps above for the new PC and both PC.