Exporting a Family Tree with/without Media

Introduction

The main purposes for exporting a Family Tree GEDCOM file with or without Media are:

  • To create a subset Project using Project Window > New Project.
  • To create a set of records for use with Merge/Compare File.
  • To transfer a set of records to another person or genealogy product or website.
  • To upload records to a website such as Ancestry or FindMyPast with sensitive private data removed.

They have some common pitfalls. The set of records may include everything, or just a partial family branch. A number of tools and plugins are available to help with the task. Also see how to Delete Data For Living People.

Export GEDCOM File Command

Whether exporting a GEDCOM file to create a New Project, Merge into another Project, or to transfer elsewhere, the initial process is the same.

Details

Use File > Import/Export > Export > GEDCOM File, and to include all Individual records click Add All.

Otherwise, click Select to invoke the Select Records dialogue and choose a subset of Individual records:

  • Manually select any records from left-hand pane and click > Add to Selection button.
  • Click Add using Query button and choose any Query, such as All Relatives, Ancestors, or Descendants.
  • Click Named Lists tab to choose any member records that must have been populated in advance, such as in how to Create an export Gedcom based on a diagram.

Review the Exclude records and notes options, that usually should all be unticked, except perhaps Unconnected Records.

For the Media Records option select Use Full File Paths for External File Links such that the Media folder & file paths are retained. Otherwise, select Exclude to eliminate all the Media records & files.

The subsequent steps depend upon the purpose of the export as explained below.

Note that the Split Tree Helper has options to delete Notes, Facts, and Flags, etc, not provided by the Export > GEDCOM File command, but involves a rather more complicated process. See Export to Website Without Sensitive Data below.

There is an All Pool Relatives Except Partner Ancestors Plugin to populate a Named List of specific ancestral branches as discussed in this thread:

Export to Create/Merge Projects

When exporting a GEDCOM file with associated Media files to create or merge into another Project, it is desirable if the Media folder & file paths are retained.

When the File > Project Window > New Project > Import a GEDCOM file or the File > Merge/Compare File command is used, the GEDCOM file to select will be the one saved as described below.

See Importing to Family Historian and Merge/Compare File for details of those processes.

Details

Use the Export GEDCOM File Command options as described above to choose the records, and leave the other options at default values. After clicking OK, do NOT use the Public folder offered by default. Instead Save the GEDCOM file in the ….fh_data folder adjacent to that Public folder, so that the exported file sits next to the Project master GEDCOM file.

When this exported GEDCOM file is used to create or merge into another Project, its linked Media folders & files should get copied across automatically and retain the original folder hierarchy.

If the above technique is NOT employed, then the linked files will all get copied directly into the target Project Media folder, losing the original folder structure.

In other words the rules are the same as for creating a V4/V5 Project from a V2/V3 Standalone GEDCOM. The GEDCOM file MUST be in the same folder as the Media folder containing the media folders & files.

Links

The discussion thread below led to the solution given above.

Export to Another Person or Product

When exporting to another person or genealogy product, there are several pitfalls due to the various dialects of GEDCOM in use.

Record Selection

Use the Export GEDCOM File Command options as described above to choose the records, but set the other options as described below.

Many online products such as Ancestry, FindMyPast, MyHeritage, and ZoomPast do not automatically upload Media files, so there is usually little point in retaining them, and this section can be skipped. However, there are some Special Media Cases described below.

When exporting a GEDCOM file with associated Media files it is important that the file path links are retained.

Strangely, GEDCOM 5.5 specifies a FILE path link for Local Media files, but NOT for Media Records, so to remain compliant Family Historian uses a custom _FILE path link in Media Records. However, several genealogy programs use the GEDCOM 5.5.1 Draft FILE path link in Media Records as a de facto standard, and do NOT recognise custom _FILE path links.

One workaround would be to post-edit the exported GEDCOM file and replace every _FILE with FILE.

Since fh V5 the File > Import/Export > Export > GEDCOM File command offers a solution. For Destination: choose Family Tree Maker and not only are useful default settings suggested, but also FILE path links are used in Media Records although this is not mentioned in the Help. In fh V6.2 a Destination: of Default similarly uses FILE path links. The Export Gedcom File Plugin has similar options.

Links

As an alternative workaround, a user was trying to use Local Media instead of Media Records, but found Merge/Compare File insisted on converting one to the other. The discussions below explained how to thwart that behaviour and revealed the solution given above.

Gedcom Formats

With the advent of fh V6, its GEDCOM file uses Unicode UTF-16 encoding, which makes it unrecognisable to many other genealogy products, and it includes Place (_PLAC) records and Witness (_SHAR) links that are not even recognised by fh V5 or earlier.

There is a Tools > Preferences > File Load/Save option to Save in UTF-8 file format, or the File > Import/Export > Export > GEDCOM File command Format also offers UTF-8, but neither solve the problem of fh GEDCOM Extension List custom tags (such as _PLAC and _SHAR) being unrecognised by most other products.

In fh V6 or later the File > Import/Export > Export > GEDCOM File command does allow Place records to be excluded along with all their Media, Lat/Longitude, etc.

The solution is to use the Export Gedcom File Plugin. That can be preceded by the Export GEDCOM File Command if a subset of records is required, and when it asks Do you wish to open another instance of Family Historian to view the exported file? answer Yes and run the Plugin on the exported file.

Export to Website Without Sensitive Data

This process involves more steps & tools with different options than those above in order to remove all private or sensitive data especially for living people. If it is known in advance that this will be an objective, then it is beneficial to use the [[private]] text notation in Note and other text fields, and set the Living record Flag appropriately by using the Flag Living Query.

Export > GEDCOM File Command

Follow the Export GEDCOM File Command advice given above, but choose to Exclude all unwanted records, and when it asks Do you wish to open another instance of Family Historian to view the exported file? answer Yes and run the steps below on the exported standalone GEDCOM file.

Clean Unwanted Fields Plugin

This step is only needed if there are particular unwanted data fields.

Use the Clean Unwanted Fields Plugin to globally remove any fields. It is easily edited for any required Data References, but defaults to a useful set for Ancestry.

Alternatively, create Custom Queries to show the unwanted fields in a Result Set. Then for each field, sort their Column, select all the cells, and hit the Delete key. It may be necessary to create Individual, Family, Fact, and Source type Queries to handle all the fields.

Clean Unwanted Fields Plugin  Clean Living Persons Plugin

Clean Living Persons Plugin

Use the Clean Living Persons Plugin to privatise the Name of all Living people, and remove their Fact, Note, Media, Source, or other details. See the Clean Living Persons Plugin Help & Advice.

Trim Date and Text Fields Plugin

Use the Trim Date and Text Fields Plugin to reduce the details in Date, Note, Address & Place fields so that visitors to the online tree are encouraged to contact the owner to confirm matches and obtain the details. See the Trim Date And Text Fields Plugin Help & Advice.

File > Split Tree Helper Command

Optionally use the Split Tree Helper to delete Note, Media, Source & Repository records with no links to them, delete all Submitter & Submission records, delete all Note fields or [[private]] text within records, delete all record Flags, delete all Named Lists, and delete any specified Facts.

In some cases, such as using delete all Note fields, not all records with no links are deleted, so the command should be used twice with the same settings.

Export Gedcom File Plugin

Use the Export Gedcom File Plugin for the chosen target website such as (ANC) Ancestry Family Tree, (FMP) FindMyPast Family Tree, (MYH) MyHeritage Family Tree, (ZPG) ZoomPast Genealogy, etc.

This offers another opportunity to remove Multimedia and exclude [[private]] text.

On the Extra Options tab the following settings may be beneficial, especially for Ancestry, and are mostly selected by choosing the (-) Brief Data mode on the Basic Options tab:

  • Name List Entry 1 _LIST: Remove entirely ~ (unnecessary if Named Lists deleted in Split Tree Helper)
  • File Root 1 _ROOT: Remove entirely
  • Given Name 2 _USED: Remove entirely
  • Record Flags 1 _FLGS: Remove entirely ~ (unnecessary if record Flags deleted in Split Tree Helper)
  • Marriage Status 1 _STAT: Remove entirely
  • Witness Role 2 _SHA%u: Remove entirely
  • Place Record 0 @P%d+@: Remove entirely
  • To/From Place 2 _PLAC: Remove entirely
  • Source Type 1 _TYPE: Remove entirely
  • Fact Address %d ADDR: experiment with different settings

Many of those are unnecessary if removed by the Clean Unwanted Fields Plugin above.

Finally click the Export GEDCOM… button and upload the resultant GEDCOM file from the Export folder to the website as advised by the Export Gedcom File ~ Output Formats for the chosen target product Import Details.

Special Media Cases

There are some techniques that allow Multimedia to be uploaded to online websites in bulk. Please ask in the Importing and Exporting Forum if you need more detailed advice on these techniques.

FindMyPast Zipped Folder

The Export Gedcom File ~ (FMP) FindMyPast Family Tree advice explains how it may be possible to bulk upload Multimedia using a Compressed (zippped) folder technique.

Ancestry via RootsMagic

A Project with Media can be exported to RootsMagic and use its TreeShare for Ancestry capability to upload the Project with Media images to Ancestry. Note that the RootsMagic Essentials version is free.

ZoomPast via Online Trees

Once a Project with Media exists online in such as Ancestry or FindMyPast, then a GEDCOM can be exported and imported to ZoomPast and any URL links to Media will be honoured.

Links