Diagram Tips and Tricks

Introduction

This summarises some little known tips and tricks with Diagrams. Remember that with a Diagram open pressing the F1 key, or clicking the Help button in sub-windows, gives detailed advice. Also work through the tutorials on Diagrams in the Family Historian Documentation.

Note Options settings for all Diagrams are shared by all Project via the Family Historian Program Data Folder.

Zoom In & Out

Instead of clicking on the + Zoom In and - Zoom Out buttons, you can use the keyboard number pad + and - keys, or Ctrl+L and Ctrl+K, or hold the Ctrl key whilst rolling the mouse wheel.

See Help > Search Help > Keyboard Shortcuts > List Topics for other shortcuts.

DPI

If you use the Diagram | Save As menu item to save an image of your diagram, it is likely to be saved with the dpi of your computer screen. This is most commonly 96 dpi. Even if you have a high-resolution screen, you may have set Family Historian to use a Compatibility mode because the menus and icons are too small. In this case Family Historian also thinks it is on a 96 dpi screen.

On the other hand, common advice is that you should use 300 dpi for printing.

The dpi is equal to the number of pixels in the either dimension divided by the corresponding printed width or height in inches. Normally the dpi is the same for both dimensions, but it can be different. So if your screen is 96 dpi, and the diagram is actual size, the saved image will be 96 dpi. You can get more resolution by zooming in.

If you want a resolution of 300 dpi in the saved image, set the Zoom Level to 313% (= 100 * 300 / 96), etc.

You can check the resolution by getting the pixel dimensions of the image after it is saved. Divide the pixels in either dimension by the corresponding Width or Height given in the Dialog Statistics (or by what you would like it to be).

Text Boxes

These can display much more than just plain text. Use Diagram > Insert into Diagram > Text Box, draw the box, and check the Help on each tab. The Text tab supports Expressions comprising Data Refs and Functions to create complex context dependent text. The Data tab can condition the context for %INDI% on the Text tab.

The February 2016 Forum posting Customising diagram end of branch siblings gives an example.

If no text is shown by a Text Box then drag its handles to make it bigger!

Blank Diagram

Use View > Standard Diagram Types > Blank Diagram, then Diagram > Insert into Diagram > Text Box &/or Picture offers many of the basic features of a word-processor for composing free format pages for a Book as explained in Book Free Page Content.

All Relatives Diagram

Despite its name, this does NOT always display all relatives of the root person. It only displays all blood relatives and their immediate spouses. That includes all direct ancestors, and direct descendants of those ancestors, such as cousins of the root person.

However, considering the spouses of blood relatives, the parents, siblings, or other spouses of those spouses are not included, even though they are members of the same family Pool.

There is Wish List Ref 501 Entire Pool Diagram that you can vote for.

Save Diagram As Menu Item

There is a Diagram | Save Diagram As menu option. Using this you can save as a PDF or a variety of image formats.

Saving as a PDF is covered in detail at Single Page PDF of a Diagram. Problems may arise if the diagram is too large, and how to handle this case is discussed in detail there.

Problems may also arise when saving as an image if the diagram is too large or the scale is too large. You may get this dialog:

Unable to Save Diagram Dialog

If so, you can follow the directions in the dialog. EMF files are discussed below. There are other, perhaps better, ways to get around this, described in Saving Medium or Large Diagrams.

Black and White Output

If saved or printed Diagrams have unexpected black-and-white or coloured parts then review these settings:

  • Diagram > Copy Diagram > Text and Lines in Black-and-White
  • Diagram > Save Diagram As > {any format} > Text and Lines in Black-and-White
  • Diagram > Options > Print > Print text, lines and boxes in black-and-white only

Only the Box Fill and Text Colour of Individual boxes are actually rendered in black-and-white.

All Box Line and Box Shadow colours, all Inserted Text Box/Shape/Line colours, and any Diagram Background are always coloured.

Enhanced/Placeable Metafile

These file types are associated with the following commands:

  • Diagram > Copy Diagram > Enhanced Metafile
  • Diagram > Save Diagram As > Enhanced Metafile (.emf)
  • Diagram > Save Diagram As > Placeable Metafile (.wmf)

When an Enhanced/Placeable Metafile is pasted or inserted into a Word document it is OK, but for other products such as OpenOffice Writer or LibreOffice Writer some features may be grey or completely blank. This affects boxes with Box Shape set to Rectangle or Rounded Corners and .wmf files.

A workaround for Box Shape: Rectangle is Bevelled Corners with Corner Size: 0".

If the .emf or .wmf file is opened in IrfanView and saved without change as an Enhanced Metafile (.emf) then that file inserts into those other products OK.