Delete Any Number of Records

Introduction

There are actually numerous techniques for doing this. Before trying any of them though, make sure you have a current backup of your GEDCOM file - even if you plan to delete records in a copy of your Project. You might get confused and accidentally delete records from the wrong Project.

Details

To delete just a few records of any type, then on the appropriate tab of the Records Window, select them one at a time, and hit the Delete key, or use Edit > Delete.

To delete just a few Individual records, then in the Focus Window bring them into focus one at a time, right-click on their box, and choose Delete Record.

When Individual records are deleted, any redundant Family records are automatically deleted, but other unused record types with 0 Links or 0 Citations will remain.

WARNING: Deleting records is risky where the Links or Citations or Sources column value is greater than 0, so first try finding where Records are used to determine the impact of deletion, and consider using Edit > Merge/Compare Records to merge duplicated records.

Media Records

Deleting Media Records does NOT delete any linked image files, so consider using the Check for Unlinked Media Plugin.

Records Window

You can delete from the Records Window. Simply copy all the records you want to delete to a Named List (create a new one if necessary). When you have put together a list of the exact people or other records you want to delete, click Delete Named List Records on the Lists menu, and select that list. This will delete all records in that list. Use with care obviously! If you regularly want to be able to delete multiple records, you might consider creating a list called "Delete Pending" that is used solely for this purpose.

Incidentally, if you haven't used Named Lists before, click on Lists > Named Lists Pane to view them in the Records Window, and read about them in the fh book "Getting the Most from Family Historian".

To select records with similar characteristics try sorting on one of the columns. For example to find unused records with no links, click the Links or Citations or Sources column heading to sort into numerical order and all the 0 entries will be last. To get them first, press-&-hold Alt key while clicking column heading to perform a reverse sort.

Remember that the Records Window supports multiple selection using the usual techniques (i.e. press-and-hold Ctrl key while clicking records, or press-and-hold Shft key while clicking first and last of a range). Press F4 (or click Add to Current List button or use Edit > Add to Named List) to add records selected in the Records Window to the Named List selected in the Named Lists pane.

Split Tree Helper

The Split Tree Helper feature, accessible from the File menu, is specifically designed for deleting large numbers of records from a file. Have a look at that and the help that comes with it (press its Help button). You can use Queries to select the Individual records to delete or Named Lists (because a Query can return all Named List Members).

Even if not deleting any Individual records it offers a convenient way of deleting other record types with no links to them.

Diagrams

You can select boxes (even all boxes) in a chart and delete all the Individual records that they represent. If you don't want spouses to be deleted, select the hide spouse option. If you don't want other relatives to be deleted, select a chart which doesn't show them, or hide them yourself (or don't select them). To select multiple boxes click-and-drag on the background of the box to draw a stretchy box to 'lasso' them with. Alternatively, press-and-hold the Ctrl key while clicking on a box to add or remove it from a selection. Then press the Delete key to delete and take the option to Delete data records for selected boxes.

Queries

Once you have mastered Queries (especially in combination with Named Lists) all power is in your hands. You can use Queries to select from, or add to, Named Lists and then use the Lists > Delete Named List Records command. Or you can delete directly from the Query Result Set window. Simply select the cells that represent records (the ones that have an icon on the left side) that you wish to delete and click on the Delete key.