Family Historian Version 2.3.5

Version 2.3.5 Features

1. Support for Narrative Reports

A major new report has been added. This is a narrative report: Descendants by Generation. This has numerous options, and like other reports, can be saved in HTML, RTF or text format. The report allows you to show all events and attributes about a person's descendants and their spouses; and also (optionally) event/attribute notes, event/attribute addresses, record notes, marriage notes, shared notes, private notes, and more. You can also include pictures and sources. See also the discussion of the new Sentence field in Changes to the Property Dialog below, and the discussion of the new Narrative Report Options button in Changes to Preferences.

2. Enhancements to Existing Reports

  • The Descendant Outline Report now has an improved layout (and the HTML version is also much improved). The report has been extended to include the following additional fields (optionally):
    • Event/Attribute notes
    • Event/Attribute addresses
    • Record Notes
    • Marriage Notes
    • Shared Notes
    • Plus there is an option to include private notes if you wish
    • You can now also specify sources for all information in the Descendant Outline Report (and the Report Options dialog for that report now has a Source tab).
  • In the past, reports did not correctly handle tabs and line-breaks (e.g. in long notes). These are now handled correctly.
  • The Reports menu has been re-organised to break reports down into categories, and make it easier to find the report you want.
  • There is a new Add Relatives button on the Select Records Dialog (when selecting records for a report) to make it easy to add ancestors, descendants or spouses. Some queries have been enhanced to make them more useful for selecting records for reports also (using the Add Using Query button on the same dialog) - see New and Changed Queries below.
  • There is now a Print Preview option for the Reports Window. This is rarely useful because the Reports Window itself shows you what you will get when the report is printed. But there are occasionally some circumstances in which it is useful.
  • There is also another new report: Data - Source Types. See Enhancements to Sources below.

There have been several improvements with respect to the display of Source information in Reports - again, see Enhancements to Sources below.

  • See also Mouse Wheel and Zooming below.

3. Support for Copy and Paste

  • You can now copy and paste any branch of any record in the Records Window or in the All tab of the Property Dialog. For example, you could click on Birth in a person's record and copy that field and all 'sub-fields' (Date, Place, Source etc) at the same time. When you paste, the entire branch is pasted. You can now select multiple fields as long as they are all 'child' fields of the same 'parent. Press Ctrl or Shift while clicking on a field to add to the selection. You can copy multiple fields. To copy, click on Copy on the Edit menu or press Ctrl-C.
  • To paste a branch, select the record or field you wish to paste them into and click Edit > Paste (or press Ctrl-V). You can only paste data that would be valid in that context. You can't paste a date as a sub-field of another date for example.
  • If you right-click on any tag in the Records Window, the context menu will have 'Copy' and 'Paste' on it (paste will be greyed if not appropriate).
  • You can also copy and paste in the Events tab of the Property Dialog. The events/attributes list also now supports multiple selection. To copy all selected events or attributes, press Ctrl-C, or click on the toolbar menu button (below the events/attributes list) and choose Copy Events/Attributes. To paste into the Events tab of the Property Dialog, press Ctrl-V or click on Paste Events/Attributes on the toolbar menu button.
  • As well as copying fields and pasting them within Family Historian, you can also copy any field (branch) and paste it as text into any text editor (e.g. Notepad). You can copy entire records if you wish to, but they cannot be pasted as new records within Family Historian. Unlike fields, records can only be pasted as text - e.g. into a text editor. To make this clear, if you select a record 'Copy' will be renamed 'Copy as Text' on both the Edit menu, and on the right-click context menu.
  • In the past, if you had copied a source citation, you would have seen Paste Citation on the menu that appears when you right-clicked on a field in the Records Window (or All tab of the Property Dialog). There is no longer a special menu command for it - just use Paste (as with any other copied data).

4. Enhancements to Sources

  • There is now a new Type field for sources, which allows you to specify, for each source record, what kind of source it is. The choice of values for this field is up to the user (e.g. you might prefer to use general terms like 'certificate', or more detailed terms like 'birth certificate'). The field supports auto-completion, and there is a new Work with Data dialog for Source types which is accessible either by double-clicking on any source type field (or pressing the button with 3 dots next to it); or by clicking on Tools > Work with Data > Source Types. The dialog allows you to edit, view and merge source types as you can with other auto-completion fields. You can also view records that use a given source type and jump to them.
  • There is also a new report for source types: Data - Source Types.
  • On the Source tab of the Report Options dialog (for reports that support Sources) there are 2 new options: (a) Combine Identical Citations for Same Source and (b) Use 'Ibid' for repeated citations to same source. The first can significantly reduce the number of citations for a report. The second can reduce the length of citations. These options are quite independent of each other. You can have either, neither or both.
  • You can now include Text from Source and Notes for source records. You had previously only been able to include Text from Source and Notes for citations only - the assumption being that you would not normally want this kind of information to be repeated for each citation to the same source. However, as you can now combine citations to the same source (even if you wish combining all citations to the same source) it is more likely that you might also want to be able to include Text from Source and Notes from Source records to be included too.
  • You can now disable quotes around Source Titles if you don't want them. The option is set on the Source tab of the Report Options dialog - just to the right of the check box for including Source Titles.
  • See also New and Changed Queries below for more enhancements relating to Sources.

5. Changes to the Property Dialog

Already mentioned: new support for multiple selection in the Events tab, and in the All tab of the Property Dialog. Support for copy-and-paste and new copy/paste menu commands in the Events tab toolbar Menu button's dropdown menu. Plus:

  • A new field 'Sentence' shows how the event or attribute will appear, given the current data, when displayed as a sentence in a narrative report (see above).
  • You can now specify the contents of the caption of the Property Dialog for each record type. When you do this, you can include any data taken from the record itself - such as Custom Id - so you can configure these captions to show exactly what you want. This is done on the new Property Dialog tab of the Preferences dialog (click on Property Dialog Captions).
  • The Events tab has a slightly improved layout. Events and attributes are now displayed more consistently.

For Residence, you now specify the place of residence in the usual place field, rather than opposite the label as previously. Again, this gives greater consistency.

  • The Age field is no longer hidden for the Birth event. The label is greyed, but the field itself is editable. This may seem anomalous, and of course the field should normally be left blank. But if a child is stillborn, this is specified using the Age field (if you double-click on the field you will see that 'Stillborn' is a possible value for this field).
  • You can now re-order local notes and shared notes (i.e. links to note records) relative to each other in the Notes tab of the Property Dialog. Previously these were kept entirely separate.
  • The Online Help for the Events tab of the Property Dialog has been rewritten and considerably extended.

6. New and Changed Queries

  • There is a new query Sources for Given Record. This allows you to select a record (any type of record) and it shows you all the sources cited within that record. In the case of Individual records, it will show you not just sources cited for the Individual record, but also any sources cited for spouse family records associated with that Individual record.
  • The standard query Links to Sources has been removed, and replaced with the more general Source Records - All which includes not just the number of citations, but all the basic information about each source.
  • The queries Ancestors, Descendants, and All Relatives have all been enhanced to provide more useful information, and to make them more useful for selecting records for reports (the records found now appear in a sensible order). A new query Immediate Family has been added, to make it easy to select a person's immediate family for reports (using Add Using Query in the "Select Records" dialog box, when opening a report).

7. Enhancements to Diagrams

  • The Diagram menu now has a new Save Diagram As submenu, which allows you to save diagrams as image files in 9 different formats, including JPEG, Enhanced Metafile, Windows Metafile and TIFF.
  • Diagram Statistics, available from the Diagram menu, now provides more useful information, including the size that the Diagram would be if printed.
  • You can now set the selection colour (the colour of the little boxes that appear round something when you click on it). This colour can be set in the usual way (in the diagram colours listing it is listed as 'Selection'). The default selection colour is now dark blue, irrespective of the current system selection colour. You can either override this to set a specific colour if you want, or you can choose 'System' if you want the system colour to be used. This feature is particularly useful if you use one of XP's silver colour schemes, as otherwise the selection colour can get lost against the default background colours which are very similar.
  • If you use diagram-based editing, to add relatives by clicking-and-dragging, the procedure has been slightly simplified. When you release the button to add a relative, in the past, the menu that appeared would prompt you to add a parent or child. Now it prompts you to add either a father or mother, or a son or daughter. This means that the sex is automatically filled in when the new record is added, making one less field to enter. If you wish to add a child without specifying their sex, add them as either a son or daughter, and then clear the sex in the Property Dialog, after the record has been created.
  • See also Mouse Wheel and Zooming below.

In the past, there has sometimes been a problem with viewing and printing very wide diagrams if your version of Windows was Windows 95, 98 or ME, owing to limitations of these versions of Windows. There has been no equivalent problem with Windows XP, 2000 or NT4. Various enhancements have been made to make it easier for users of Windows 95, 98 and ME to overcome some of these problems. These include:

  • A new Large Chart Settings button has been added to the Dimensions tab of the Diagram Options dialog. Clicking on this button causes settings to be changed to make them suitable for displaying and viewing very wide diagrams. Users are warned that they should not use these settings unless they have to. They will know if they need to use the settings or not, when they come to display a very wide diagram, because, if the diagram is too wide (for Windows 95, 98 or ME - remember that none of this applies to users of Windows XP, 2000 or NT4) a message will warn them that the diagram is too wide and suggest that they use Large Chart Settings for this diagram. There is also advice and information in the Online Help about viewing and printing very wide diagrams (click on the Large Chart Settings button in the Dimensions tab of the Diagram Options dialog, and then click on the Help button of the dialog box that appears).
  • A new option Use printer default line thickness has been added to the Print tab of the Diagram Options dialog. This option can be used at any time and will usually have the effect of making printed lines thinner than normal. The option is primarily useful, however, when Large Chart Settings have been enabled, as without it, all lines in printed diagrams would be much too thick.
  • A new text scheme "Name, Birth, Marr, Death & Places (Abbr.)" has been added to the standard list of text schemes. This is also designed to help with large chart printing. Some diagrams can be very wide because the place information displayed in each box is itself very wide. This text scheme uses the MEDIUM qualifier for each place name, to ensure that it is not too long.

8. Mouse Wheel and Zooming

  • The Diagram Window, Multimedia Window and Report Window now all support the mouse wheel for scrolling up and down.
  • All 3 windows now also support the mouse wheel for zooming in and out (you have to press the Ctrl key while turning the mouse wheel). You can also now zoom in and out by pressing Num+, Num-, Ctrl+K, Ctrl+L in the Report and Multimedia Windows, as you have always been able to do in the Diagram Window. In the Report and Multimedia Window you must make sure that the focus is on the report/picture when you do this. Click on the report or picture to give it the focus if zooming doesn't appear to be working.
  • In the Report Window, the affect of mouse wheel scrolling depends on the location of the mouse when you turn the wheel. There are 3 areas of significance. If the mouse is over the report itself, you will scroll up and down within that report page. If the mouse is over the rightmost scrollbar, you will scroll up and down throughout the entire report (moving from page to page). If the mouse is over the spin control in the top right corner (opposite the page number), it will scroll you forwards and backwards between report pages, but keeping to the same position within the report page (as clicking on the spin control does). In other words, the mouse wheel can be made to emulate the actions of the inner scrollbar, the outer scrollbar, or the spin control, depending on where the mouse is when you turn the wheel.

9. Place Name Enhancements

  • Some users like to use a standard policy for separating out the various parts of a place name. For example, they might prefer to always make the country the 3rd item. If they only know the village and country they might choose to add extra commas to achieve the desired separation: e.g. "Hexham,, England". Family Historian now has various feature to support this: the existing SHORT and MEDIUM qualifiers for place names now ignore redundant commas (even redundant leading commas) and don't reproduce them when displaying the short or medium versions of the place (e.g. the MEDIUM qualifier would render the above as "Hexham, England" with only one comma. A new qualifier 'TIDY' shows the full place, with all parts, but removes redundant commas.

10. Changes to Preferences

The Preferences dialog has been re-organised to group items more logically, and make them easier to find. Also you have the following new preferences:

  • You can now completely customise the caption for the Property Dialog, for each record type. So, for example, you can get the Property Dialog to show a person's Custom Id instead of, or as well as, their Record Id.
  • You can opt for Backup file names to be generated using the date in year/month/day order. This means that if you sort by backup file name, they will all be in sensible order.
  • A new Narrative Report Options button on the General tab allows you to set a template to be used when generating sentences for custom events and attributes.

11. User Manual Changes

  • The User Manual now has an Index.
  • If you display the Bookmarks area for the User Manual, each chapter (and the Contents and Index) now has a bookmark
  • Clicking on any entry in the Contents listing of the User Manual jumps you to that section.
  • The User Manual has also been modified to reflect other changes, such as the changes with respect to the Tutorial Files.

12. Other Improvements

  • The User Manual makes reference to a number of 'pre-cooked' Tutorial files that you can use in conjunction with the tutorials in the User Manual. These files are now all accessible from the Help menu.
  • A new File Statistics menu item (on the File menu) shows the full path name of the current file and the number of records of each record type.
  • In the past, when you have wanted to know what a particular field (GEDCOM 'tag') was used for, you could find this out by opening the Query Window, selecting the Columns tab, and selecting each field (tag) in turn. A description for the field would appear in a box below the Fields list. The same description is now shown in the Data Reference Assistant dialog box. This is the dialog box that is displayed when you click on the Insert Data Reference button in the Text tab of the Diagram Options dialog. The same dialog box is also used if you create a custom column in the Records Window, or define a custom field in a report.
  • You can now Play any file in the Multimedia Window, and not just ones that Family Historian does not support natively. So, for example, you could use the Play button (on the Multimedia Window toolbar) to open your preferred editor for JPEGs. The menu command equivalent, on the Multimedia menu, has now been renamed Play/Open in Default Editor.
  • If you switch focus away from Family Historian and then switch back to it, it will warn you if the file has been changed by another application and ask if you wish to reload it.
  • There are 3 new relationship types: Step; Step (father); and Step (mother). The display of relationship information in the Records Window has been improved and simplified.
  • The default font for the Records Window is now Arial 10pt, where it used to be MS Sans Serif 8pt. The larger size is easier for most people to read.
  • The implementation of custom events and attributes has been reworked and improved.
  • There have been numerous minor enhancements to improve the look of the program. For example, the look of certain fields within the Query Window has been improved.

Version 2.2 Features

1. Basic Record Merging and Branch Merging

In the past Family Historian previously only supported one kind of merging/comparing: File Merge/Compare. It now supports 3 kinds:

  • File Merge/Compare
  • Basic Record Merge/Compare
  • Branch Merge/Compare

File Merge/Compare is when you compare and merge entire files. Basic Record Merge/Compare is when you select 2 records of the same type (e.g. 2 Individual records or 2 Source records) and compare them side-by-side, and optionally merge them. Branch Merge/Compare is, we believe, another first for Family Historian. It often happens that duplicate records somehow arise within a file for the same individuals. But frequently that is not the end of it. Not only are the Individuals themselves duplicated, but so too are their parents, grandparents, children, uncles and aunts, and so on. It is very easy for entire branches of individuals to become accidentally duplicated. Family Historian's support for Branch Merge/Compare makes it easy to locate all the duplicates (and they can be any arbitrary group of related individuals - they don't have to follow a 'straight line' branch). Having found all of the duplicates in the branch, with Family Historian you can make all the decisions about which duplicates to merge (usually all of them), decide exactly how to merge them (at the field level), and then do the merge in a single operation. Traditional genealogy programs force you to compare and merge records one-at-a-time. But this is a very unsatisfactory approach because so often in a branch merge, the decisions are all interrelated. Is A the same as B? Yes if A's son is the same as B's son. Otherwise not. You don't want to decide on one pair and then the next. You need to decide on both pairs at the same time. Only Family Historian's approach to branch merging gives you the viewpoint you need to compare all the records at the same time, and the ability to control the merge process completely, and then execute the merge in one step. As with File Merge/Compare, so too with Basic Record Merge/Compare and Branch Merge/Compare: Family Historian lets you see exactly what the outcome of the merge process will be before you start any of it. In fact, for all 3 kinds of merging, it has been made easier to see what the outcome of a merge will be. Where 2 values are to be merged, the data value that will be discarded is now displayed struck-out, and other user interface improvements have been added. The scoring algorithm used for determining which records are matched has been improved, to reduce the number of 'false-positives'.

2. Improved Support for Places, Occupations, Religions, etc

  • If you enter a place name for an event or attribute, it will auto-complete, and you press Tab to accept the auto-completion. Auto-completion can be switched off in Preferences.
  • Place name fields now have a grey button with 3 dots at the right end. If you click on this, or double-click on the place name field itself, a "Places List" dialog will appear and you can select a place from the list. If you click on the "More »" button, this dialog will switch to show buttons for working with Places. You can also view the Places List dialog in a very similar way by clicking on Tools > Work with Data > Places.
  • When working with places you can edit a place name, merge 2 or more place names, and view all records that use a place name (and go to any of them). Places are displayed with each comma-separated part that makes up the place shown in its own column so you can sort on any column (or Alt-click to reverse the sort). The same list also shows how often each place name has been used. If you click on the 'Columns' button you can specify how many columns you wish to allocate to place parts.
  • You can optionally choose to view places with the last part in the first column, 2nd last in the 2nd column and so on. This makes it easier to sort on the last part of a place name.
  • There is a new Places report. If you click on the 'Reports' button in the Place List dialog, it will jump you to this report.
  • There are 3 new qualifiers for Place fields: SHORT, MEDIUM and FULL. The last is the default (equivalent of no qualifier). SHORT just gives you the first part of the place, up to the first comma. MEDIUM gives you the place up to the 2nd comma.
  • Most of the facilities described above (i.e. except for the bits that are obviously place-specific) are also available for Occupations, Religions, Groups/Castes and National or Tribal Origins. Each other these has a new report dedicated to it - making 5 new reports in all.

3. Improved Data Entry and Data Validation

  • The autocomplete facilities described in the previous section will make data entry easier.
  • There is also now validation on data entry. When you enter data into a field, the field will be validated when you press the tab key (or the F5 key). Validating dates takes 2 forms: (a) you are warned if the date is simply invalid. (b) even if valid, you will still be warned if the looks unlikely for whatever reason - e.g. you will be warned if you enter a date of death for a person that is earlier than that person's date of birth.

Data validation works wherever you enter the data in the field - either the Property Dialog or the Records Window. You don't have to press either Tab or F5 when you enter data, but the data will only be validated if you do.

  • You can now enter 'Quarter Dates' (e.g. "Q4 1987") into any Date field. If you prefer Quarter Dates to be displayed in long form ("Between October 1987 to December 1987") there is an option on the Preferences Dialog that lets you do this.
  • Events and Attributes are now automatically kept in chronological order (unless you disable this in Preferences) if you add them or edit them in the Events tab of the Property Dialog.
  • There is also new "Re-order Events by Date" command on the Edit menu, that will check, for a given individual, that that person's events, attributes, spouses and children are all in chronological order, and re-order them if they aren't. You can run this command by selecting an Individual record and pressing F9.

4. Configurable Columns and 'Tags'

  • You can now configure the columns in the Records Window, and also in Named Lists. Each Named List can have its own column layout. In each case, you can have as many columns as you like. You can select from a long list of standard columns, or you can create your own custom columns to display whatever information you want.
  • You can save a column configuration as a Query, or reload a column configuration from a Query. All columns are configurable (including the direction of sort), except the first column.
  • Other genealogy applications allow you to 'tag' records by ticking in a checkbox when viewing lists of records. They vary in the number of tag columns they allow (typically simply numbered 1 to 3, say). Family Historian now effectively lets you have as many tags as you like, because any list can be treated as a tag. If you add a list-membership column for the Records Window (or a Named List) a check box will appear for that column which will be checked if the record belongs to the Named List, and unchecked if it doesn't. You can add or remove records from this Named List by checking or unchecking the check box. The same check boxes can be viewed from within Named Lists too. They are Read-Only by default in a Named List context, but you can make them editable here too if the Named List supports record editing (see "Changes to the Records Window" below for more on this).

5. GEDCOM Validation, Error Detection and Error Correction

Family Historian now supports 2 kinds if error-detection and error-correction with GEDCOM files: A. Load-time checking If you open a GEDCOM file that was not created by Family Historian, Family Historian will ask whether you would like it to check for, and correct, well-known errors. If you do so it will produce a detailed report at the end of the process detailing exactly what it has done. The errors checked for and fixed include:

  • Incorrectly-formatted event data (common error)
  • Notes stored using incorrect syntax (the "Note-within-a-note" error).
  • Incorrect word-splitting in long text fields causing gaps between words to be lost

The last is caused by some applications not following the GEDCOM spec for word-splitting with long text fields. In order to solve this problem, Family Historian has to determine which approach the application that created the GEDCOM file used. To do this, it shows you a list of words containing hyphens and asks you to choose between 2 sentences describing the words in the list. It uses your answer to determine whether, and if so what, action is needed to solve the word-splitting problem. When Family Historian has completed its load-time check, it will ask you whether you want to run additional Validation - see Validating Linkage and Other Errors next. B. Validating Linkage and Other Errors A new menu option called 'Validate…' on the File menu, does an additional series of checks over and above those covered in Load-time checking. These checks can be done on any file at any time. They check the file for serious GEDCOM linkage and other errors (Family Historian never produces such errors, but other programs sometimes do). Optionally, Family Historian will also correct any errors found. In any case, it will output a report at the end of the validation process describing what it has found, and what remedial action, if any, has been taken.

6. Numerous Enhancements to the Diagram Window

  • A new 'Copy Diagram' command on the Diagram menu provides options for copying all or part of a diagram to the clipboard in a choice of formats (bitmap or enhanced metafile).
  • The status bar used to show diagram unit values when Page Boundaries were being displayed in the Diagram Window. It no longer does this. Instead, now whenever the Diagram Window is visible, a status bar pane shows the font size of the text font. Another status bar pane shows the percentage zoom (defaults to 100% initially).
  • A new menu command on the diagram menu (Diagram > Zoom > Zoom to Actual Size) returns the diagram menu to 100% zoom.
  • When page boundaries are displayed for diagrams, only the printable parts of the grid are 'filled in'. The rest is left white, with faint grey grid lines, making it easier to see what will print and what won't.
  • The "Set Diagram Size When Printed" dialog has changed. You can now set either the row size or the font size (in points). If you specify the row size it shows you what font size this will give you. You can save these options as default (checked by default). There is also a "Position/Sizing Tips" button. It is also now easier to see what the current font is in the Text tab of the Diagram Options dialog (or reset it).
  • Diagrams are automatically centred within the printed page now much more sensibly than before. There is a "Position on Page When Printed" submenu off the Diagram menu that gives options for this, and a "Reposition Now" command that lets you get Family Historian to reposition again if you hide or expand branches or make other changes that might affect the optimal positioning.
  • Diagram size when printed is now consistently based around the point size of the font you choose or the number of rows per page. That means that if you change the printer size from, say, A4 to A3, instead of the printed size effectively doubling as would have happened before, the printed size remains unchanged - only the page gets bigger.
  • The Print tab of the Diagram Options dialog has been simplified, and now has an 'Installation Settings' button. You can no longer specify the height or width in dialog units. Also, the option to print background stripes has gone and been replaced with a simpler option that just lets you choose whether or not you wish to print the diagram background. The alternative print stripe colour has been removed from the list of diagram colour items.
  • The way you specify margins has changed. They are now specified in inches, millimetres or centimetres, depending on the Measurement Units Preferences option.
  • If you press the Space bar when viewing the Diagram Window, you will switch temporarily to 'grabber' mode. You can click anyway on the Diagram and drag to reposition it. Releasing the space bar switches back to the previous mode.
  • Arrow keys now work as an alternative (and rather good) way to move the selection and browse a diagram. Left and Right arrow keys move you along the current row. Up and Down arrow keys move you up or down the current tree. The selected node is scrolled into view if necessary. Also, clicking on a node to select it, now scrolls the node into view if not already visible (unless drag-adding). Pressing the Enter key expands or hides the node's branch (equivalent to clicking on the Node's expansion button).

7. Enhancements to the Multimedia Window

  • The Multimedia Window now lets you specify the zoom level on its toolbar.
  • There is also an Autosize button on the Toolbar. If checked, F.H. will display all windows at 100% zoom unless they are too big to fit into the current window, in which case it will reduce them to fit.
  • Improved support for right-clicking on pictures makes it easier to see how to view the Multimedia record associated with the current window, and also how to reposition or resize the framed areas within a picture.

8. Enhancements to the Records Window

  • The Record Window Options dialog has the following changes:

(a) You can now view and change the font used in the Record Window. (b) You can now specify whether a double-click on a record opens the Property Dialog or expands the record (the default). Either way, pressing the Alt key when doing a double-click does the alternative action.

  • In the Records Window, both attributes and events are now shown with dates and places in a consistent format, when not expanded. You have to expand an attribute before you can edit its value.
  • Individuals viewed within the Records Window (when viewing linked records) now have their dates shown next to them (e.g. John Smith [1958-]) and (optionally) their record ids.
  • You no longer have to type a space after the comma in the fast-find edit box at the top of the Records Window. It works without one.
  • If you have previously copied a source citation in the Source pane of the Property Dialog, you can now paste it using a "Paste Copied Citation" menu command that appears when you right-click on a field in the Records Window. This menu command will be greyed if the field already has the copied citation. The menu command won't be there at all if there is no copied source citation.
  • There is an exactly similar command that appears when you have enabled an automatic source citation, called "Paste Auto Citation". Again, this menu command will be greyed if the field already has the citation in question, and won't be there at all if there is no Automatic Source Citation enabled. The option to paste an auto citation is currently only available in the Records Window (in the context menu that appears when you right click).
  • Undeditable data is now shown greyed to make it clearer that the data is not editable.
  • These is now improved support for right-clicking on list names in the top pane of the Named List pane (and on the middle panel also). More options are available from a right-click 'context' menu.
  • Named Lists have the additional property of supporting Record Editing (optionally). If you specify that Record Editing is enabled for a Named List, it means that you can edit the record in the middle panel of the Named List pane, for that Named List. This is useful for users who like 'low-level' editing as it means you can create a list of any arbitrary group of records (e.g. the Individuals in a census record) and edit them all together.

9. Enhancements to the Queries Window

  • A new 'Options' command at foot of Query menu (Query toolbar) allows you to change the font for the Results tab of the Query Window, and also lets you specify 5 different fonts for used when printing Queries
  • Using column widths in the Results tab of the Query Window, to set the width of output when printing a query, used to result in inaccurate column sizing. This is now much improved.
  • When you run a query, you now get a proper record selection dialog, rather than the simple dropdown combo that you used to get. This makes it easier to quickly locate the person you want - e.g. by typing in a part of their name into a fast-find field.
  • Can now use the Wheel in a wheel mouse to scroll vertically in the Results pane of the Query Window.

10. Uncategorised Data Fields

  • Fields in Family Historian that were sometimes previously referred to by users as 'Starburst fields' have been given a new name: "Uncategorised Data Fields" (or UDFs for short). These are fields created by Family Historian to hold data where Family Historian doesn't actually know what kind of data is contained in the UDF. UDFs are usually created when Family Historian loads a GEDCOM file created by another application that contains serious errors. Family Historian generates UDFs to store the invalid data.
  • Exception reports now give more detailed information about UDFs where appropriate.
  • There is a new dialog for locating UDFs. Click on Tools > Find Uncategorised Data…. This creates a Named List of records that contain UDFs.

11. Marital Status Fields and Relationship Qualifier Fields

By default, where you have a family record, it is assumed that the 2 'spouses' in the record are married. There is now a new status field (visible on the Main tab of the Property Dialog) which allows you to specify where this is not the case. The allowed values are:

  • Divorced
  • Separated
  • Unmarried Couple
  • Never Married
  • Unknown

'Never Married' is a catch-all for a couple who may never even have been a couple - e.g. a one-night stand who managed to produce a child, which is why a family record is needed to record their shared parenthood. You have always been able to specify the relationship type (Birth, Adopted, Foster, Sealing (LDS)) to show how a child is related to their parents. Examples have shown that the existing GEDCOM relationship types are insufficient to cope with some of the complex cases (e.g. where a child is treated as the natural child of the father, but isn't really). New relationship type qualifiers have been added to cover all cases. The complete list now is:

  • Adopted
  • Adopted (father)
  • Adopted (mother)
  • Birth
  • Birth (father)
  • Birth (mother)
  • De Facto
  • De Facto (father)
  • De Facto (mother)
  • Foster
  • Sealing (LDS)

You can have one relationship qualifier for both parents, or one for each parent. De Facto is a new 'catch-all' qualifier that is very useful for more complex cases. You are recommended in these cases to provide a note or notes explaining the reason for the category. Both of these field types should be viewed as representing your interpretation of the data you have accumulated. You do not and cannot specify the source for these fields as such. They represent how you have decided that you wish the relationships in question to be viewed/represented in Family Historian. The justification if any for these decisions is based on the Event/Attribute data, and notes, that you may have supplied elsewhere in the record - all of which can have sources.

12. Other Improvements

  • Family Historian now remembers Window sizes and positions between sessions. It will remember the size and position of both the main window and the inner 'child' windows (e.g. the Records Window, Diagram Window, Multimedia Window, Query Window and Reports Window). It will remember whether any of these were full-screen or not. It will also remember in many cases the position of panes within windows (e.g. the Named List panes, and the 3 panels within it). It will remember the width and position of columns in most key windows that have columns - e.g. the Records Window. Within a session, it will also remember the position of most Dialog Boxes (e.g. Select Source Dialog and Property Dialog).
  • There is a new "Tip of the Day" window, which displays an optional tip at the start of each session.
  • There is a new DAY_OF_WEEK qualifier for all dates. This gives the day of the week for the specified date. Assumes either 1752 or or 1582 as the Changeover date for the Gregorian calendar. You can specify which in the Preferences Dialog.
  • Up to now, if you click on a column in most column-based lists, Family Historian will sort on that column. From 2.2, if you press the Alt key while doing this it will usually reverse the sort. Applies to the Records Window, Named Lists, Query Window etc.
  • In the Preferences Dialog you can now choose the measurement units you want to use in all contexts where measurement units are used (e.g. Report Options, Diagram margins etc). Choice is Millimetres, Centimetres or Inches.
  • You can now specify changeover date to the Gregorian calendar: 1752 or 1582. Is used for calculating days of the week for the DAY_OF_WEEK qualifier, and also for date validation on data entry.
  • There is a new SOUNDEX qualifier for names. You can also have it as a column in the Individuals tab of the Records Window, if you wish.
  • Most record selection dialogs now have a small menu button (typically in the bottom left-hand corner) which lets you save records from the dialog to a Named List.

13. Late Additions (Version 2.2.4)

  • You now have the option to exclude any picture (linked to an Individual, Family or Source record) from either diagrams or reports or both. This option can be set from either the Multimedia Window or from the Objects tab of the Property Dialog.
  • You can now override the caption for a picture in a report by using a note instead. The option to do this, and the note itself, can both be set from either the Multimedia Window or from the Objects tab of the Property Dialog.
  • You can include private notes in these note captions. An option in the Report Options dialog box (Picture tab) allows you to specify whether private notes should be included when notes are used as captions.
  • The option to get Family Historian to automatically keep events and attributes in chronological order now applies to all tabs of the Property Dialog, except the 'All' tab.
  • There is now a "Close Dialog After Add" check box on the "Add Event/Attribute" dialog - the one that comes up when you add an event or attribute in the Events tab of the Property Dialog. By unchecking this you can add multiple events/attributes much more quickly.
  • By default, a spouse's place of death is now shown in the Main tab of the Property Dialog instead of the first spouse note.
  • When showing family records as linked records in the Records Window, the default now is that record Ids are not shown for family records, unless the user has specifically opted to do this in Record Window Options.
  • When you see a link to a record in the All tab of the Properties Dialog you can now 'navigate' to that record (ie. display it in the Property Dialog) by simply double-clicking on the linked record.
  • If you type in a record name or record id in the Records Window, the found record is now displayed in the 3rd row within the window, rather than near the bottom of the window as before.
  • Family Historian no longer prompts you to do a backup if you haven't saved any changes to the current file.
  • Family Historian now remembers the 3 most recent sorts, so that when you click on a column it uses the previous 2 sorts as 'sub-sorts'. This applies not just to the Records Window, but to any records list where sorting is allowed.
  • The record Id is now displayed after the record name in the Property Dialog caption.
  • When you insert pictures, documents and other multimedia into your file, Family Historian will now automatically generate a title for the new Multimedia Object record(s), using the file name.
  • With Reports such as Individual Summary Report and Family Group Sheet, you now have the option (set by default) to show instance numbers for events/attributes that occur more than once. Make it easier to see which instance an item in the Additional Notes section refers to.
  • For the purposes of calculating relationships, Family Historian used to treat all blood relationships as closer than all non-blood relationships. Which meant that if you married your cousin, she would be listed as your cousin first and your spouse second. That did not accord with most people's intuitions. Family Historian now uses a more sophisticated approach giving more intuitive results.

Version 2.1 Features

1. A New Reports Menu, a New Reports Window and 17 New Reports

The new reports include

  • Individual Summary Report
  • Family Group Sheet
  • Ancestor Outline
  • Descendant Outline
  • Source Summary Report
  • Individual Census Report
  • List Report

…and many more, including record detail reports which include all the data in a given record. All reports can be saved in HTML (World Wide Web) format, RTF (Rich Text Format - supported by word-processors such as MS Word), or plain text. The reports are fully configurable. You can create custom reports, using any existing report as a template. The Reports Window allows you to preview any report and browse it online. While doing so, you can switch back to any other Family Historian window without having to close the Reports Window. You can even have multiple Report Windows open at the same time if you want to. You can change almost every aspect of report 'on the fly'. For example, you can change the style, format, page layout and the content (which fields are displayed, etc.) within the Report Options dialog, while viewing the report, and watch the report update immediately to reflect your changes when you click 'Apply'. You can change which records are selected for the report, and even change the actual data upon which the report is based (e.g. if you spot a mistake) - all without having to close the Reports Window. If the underlying data is changed, the window will update immediately to display the new changed data. You will be required to refresh the report by clicking on 'Rebuild Report' once, before you actually print it, however. Reports have very flexible support for pictures and sources. You can, for example, display a picture of a family at the top of a family report, and then print pictures of faces taken from the family picture down the side, next to each family member in the detailed sections below. You can also print pictures of sources, and even of source citations, alongside the source listings if you wish to. Most Family Historian reports can display information for multiple records. There is a new Record Selector Dialog to help you select records for reports. The Record Selector Dialog lets you select records from a normal records list or from Named Lists (see next section). It also lets you use queries to select the records you want ('queries' are stored instructions for retrieving data - you can create your own or use standard ones).

2. A New Facility for Creating Named Lists

It is frequently useful to be able to create lists of records for various purposes. For example, you might want a list of bookmarks, a list of work-in-progress records, a list of key people or famous people, a ToDo list - or even specifically, a ToDo list for a given planned trip to a particular record office. Family Historian now lets you create as many lists of records as you like. Support for Named Lists (so-called because you give each one a unique name), is integrated into the Records Window, which now supports multiple selection, making it very easy to add records to lists, or to find records from a Named List (you just double-click on the list item). You can add a note to every item in a Named List. For example, if the list was a ToDo list, you could add a note to say what you wanted to do with the record in question. All lists can hold records of any type - not just Individual records. You can keep lists in any order you like. A new List Report will print off lists, including the list note (if any) and list item notes (if any). Support for Named Lists is integrated into the program generally. For example, as mentioned in the previous section, you can access them when selecting records for reports in the Record Selector Dialog. You can also add to them from the same dialog. You can add any record to a Named List from anywhere within the program. Named Lists are designed to work well with queries. You can use Named Lists as filters within queries, or use the output of a query to modify a Named List.

3. A New Tools Menu Facility to allow you to Re-order out of Sequence Data

Using this facility you can re-order any out-of-sequence events/attributes, children, spouses, and LDS ordinances within your file. You can either let Family Historian do them all in one go, or ask for confirmation before each record is re-ordered. You can also manually re-order events/attributes in the Events tab of the Property Dialog (new button on toolbar to support this). Previous restrictions on the order in which events and attributes could be stored have been removed. You can request that updated records be added to a Named List.

4. New Backup/Restore Facility

Backups are stored in a standard Winzip format. You get prompted to backup at the end of every session (unless you choose not to be).

5. Fast-find Edit Controls for Name and/or Record Id in the Records Window

These controls are also available in most contexts where you need to select/find a record. To find an individual, "John Smith", in an Individual records list, for example, you type "Smith, John". If there are multiple John Smiths, press F3 to move forward through each of them.

6. A Number of New Preferences Options

  • An Auto-Save facility
  • You can specify a default file to open when Family Historian is started.
  • You can specify a default folder to look in when using File/Open to locate Family Historian/ GEDCOM files.
  • You can specify a default backup folder to save backups to.
  • Option to Auto-add Father's Surname when adding child (doesn't apply to 'low-level' editing in the Records Window, but works in the Property Dialog and the Diagram Window).
  • Option to store Family records ahead of Individual records in the GEDCOM file (default now is Individuals first). Some 3rd-party applications will not work if the records are not in the order they expect.
  • Option to say if you want surnames in capitals or not (if yes, you get them everywhere; if no, nowhere - much simpler than old system).
  • Ability to specify which Named Lists are 'auto-create' - ie. should be created in any file, even if not already there.
  • Option to stop Family Historian automatically registering itself as the default GEDCOM application.
  • Option to stop the Family Historian splash panel appearing. The 'Splash panel' is the box containing the product name that appears when the application starts up.

7. Improved Support for Dates

You now have a choice of 6 different formats in which dates can be displayed in diagrams, reports and queries. It has also been made easier to copy Family Historian date information into other programs. The problem before was that Family Historian supports more complex date information than spreadsheets or database programs can usually deal with. Family Historian now allows you to effectively split a Family Historian date into 3 separate items of information which you can output from a query and copy into, for example, 3 columns in a spreadsheet..

8. Sundry Other Enhancements

  • New 'Unlink' menu command on the Edit Menu
  • Mouse Wheel support with most record lists
  • Added Address field to the Events tab
  • Added Birth/Baptism/Christening/Death/Burial fields to Details tab, plus other fields
  • 'Email' and 'Web' fields now added to the Property Dialog for Repositories
  • New qualifiers make it easy to display different parts of names in Diagrams, Queries and Reports
  • Improvements to the Exception Report
  • The Records Window now shows dates for Individual records in an improved format
  • You can use Ctrl-K and Ctrl-L as alternative 'hot keys' to zoom diagrams in and out (alternatives that is to + and - on the numeric keypad). Useful for laptops which don't have numeric keypads.