Split Tree Helper

This is covered in the manual Getting the Most From Family Historian in either Chapter 14 - Merging, Comparing and Splitting Tree Files or in later editions Chapter 15 - Compare, Merge, Split, Copy and Export GEDCOM Files.

The How To Use Split Tree Helper animated tutorial is based on Family Historian Version 3. Some details are no longer correct for Versions 4 & 5, which do have a GEDCOM Export feature, and Projects should use File > Project Window > More Tasks > Copy Project instead of File > Save As.

A common requirement is to split a tree into smaller parts. For example, suppose a cousin of yours expresses interest in the research you have done on his side of the family, you might wish to send him a GEDCOM file containing only material that would be of interest to him. The way to do this is to make a copy of your original file, and then delete the unwanted records from the copy.

To copy a Family Historian file, you could use Windows Explorer. Alternatively, if you prefer, you can copy the GEDCOM file by using the Save As… facility via the File menu to save the file under a new name. If you have adopted Projects, then use File > Project Window > More Tasks > Copy Project to create a duplicate Project. If you have just been making any changes that you wish to keep in your normal file, make sure you save these, in the normal way, before using either of the above.

The way you delete the unwanted records is to use the Split Tree Helper: Delete Unwanted Data facility. Although designed to be used as part of the tree-splitting process, this facility can be used at any time, to delete unwanted records. However, it should be used with care, for obvious reasons.

In recent versions of Family Historian the File > Import/Export > Export > GEDCOM File feature has been added that offers an alternatively technique for creating subsets of your data, but with similar options for selecting records.

Individual Records

You can opt to delete all Individual records found by a given Query, all records not found by a given Query, or no Individual records.

An Individual Query is a Query where the Query Type is Individual. The Query Type is specified in the General tab of the Query Window. In an Individual Query, every Row in the Result Set corresponds to one Individual record. A given Individual record never has more than one Row in the Result Set. The Columns in a Query show data relating to the Individual record - usually, tags belonging to it. When used as a means of identifying records to delete, however, the Columns of a Query are immaterial. It is useful to have a Column which clearly identifies which Individual Record is in question; however, so that you can run the Query and check before hand exactly which records will be deleted.

When installed, a sample query Relations - Simple List is provided as an example of a Query you might want to use for deleting unwanted records. When run, it will prompt you for a Starting Person, and then find all the relatives of that root person. It only has one Column, to identify the Individuals found.

As this example shows, some queries prompt you to specify details when they are run. If you have selected a Query of this kind, the prompt dialogue will appear when you click the Delete button in the main dialogue. You will be able to Cancel at this point, if you wish.

Tip ~ Use the Has Flag query to select records with a given flag. Use the Named List Members query to select members of a named list.

Other Records

The Delete Unwanted Data facility will start with Individual records. Once it has done this, there may be other records, such as Source records or Multimedia records, that no longer have any links to them. Depending on why you are splitting the tree, you may wish to consider deleting records if they have no links to them. In some cases you may even consider deleting all records of a given type.

Note: You never have to worry about deleting Family records, as Family Historian takes care of removing unused Family records automatically.

Tip ~ If some of the record types are not familiar to you, you can view them in the Records Window, providing they are enabled via the Tools > Records Window Options dialogue, or the Tools > Preferences > Records Window ~ Record Type Display Options dialogue.