Merge/Compare File

Introduction

For Family Historian the files being merged are Gedcoms which have an extension of .ged e.g. myfile.ged

Merging in another Gedcom is an excellent way of bringing in numerous records without having to type them in manually.

You may have received this Gedcom from another researcher, or have downloaded it from somewhere like Worldconnect, or FamilySearch, etc.

However, merging without a prior comparison may bring unforeseen consequences to the point where you may end up with an unusable Project. For this reason, like many other processes and tasks, it is strongly recommended that you back up your main Project first.

You may wish to create a couple of small Projects and experiment with them. The procedure for this could be to make a small Project, either manually or through use of the Split Tree Helper, save it, and then copy it under a different name. Edit one of the Projects by adding, removing and amending people and data and then save it again.

Merge/Compare Procedure

Note below is a suggestion on how to work this process. You may find a way to go through the compare better suited to your needs.

  • Prior to a merge, backup your current master Project using File > Backup/Restore or File > Project Window > More Tasks > Copy Project.
  • Make a copy of the new GEDCOM file outside of Family Historian (e.g. using Windows Explorer).
  • Import the new file into a temporary new Project and validate it. This may occur automatically. Any import errors such as UDF may need to be fixed.
    • Tip: If you have standardised your place names on your Projects, you may like to take this opportunity to amend the place names on the new Project to fit in with your standard.
  • If this new Project contains branches on it you do not want, delete them now. This can be done manually, but the Split Tree Helper will be a better method as any unassociated data can be removed.
  • Open your current master Project.
  • Go to the File menu, and choose the Merge/Compare File function, then Open the new Project's GEDCOM file from within its .fh_data sub-folder.
  • You will see three related lists in the new window (you may wish to maximise this window):
    • An information pane which shows actions to be applied to either or both of the other lists.
    • A list showing details of the current file.
    • A list showing details of the new file.
  • This is the comparison and it occurs immediately prior to the actual merge. You are not forced to compare, you can go straight into the merge, but you will need to tidy up afterwards probably.
  • For now just concentrate on the Action, Match Score and Chk columns in the first list. The other columns give an indication where there is data that will either be retained or discarded which will be of help once the basics have been grasped.

  • Sort by Score by double clicking the column heading.
    • Tip: The higher the Score the more likely the match - more details are the same. However just because there is a score does not mean the records are right to be merged e.g. namesakes will match.
  • Open out the first record, through the + by the side of the name and see what the difference is between the records. Decide whether to Keep or Discard the contained pieces of information by using the appropriate button.
  • If you hit the wrong button do not worry, just hit the button you wanted and the Keep/Discard will change.
  • You may see unusual records in the new file. These are common in files created by other applications and can be identified and removed easily later (so don't bother now).
  • When you are happy that you have done all you can on that record, click on the name in both the Current and New Records list and then click on the the Check button at the bottom of the window. You will see a Y in the Chk column.
  • Continue through the file and don't be afraid to continually sort by different criteria. As you've checked the records you've already done, you won't lose them.
  • If you can see that two names ought to match click on the name in the current window, and with the control key pressed, click on the name in the new window and then use the Match button.
  • If you see that two names are matched that should not be, do the same but use the Unmatch button.
  • Do not be afraid to sort other columns. It is especially useful to sort the new names column to see where there are no matches and it becomes apparent to you where you have missed data.
  • There is no halfway house unfortunately so if you are going to merge a large file be prepared for a long task.
  • Having completed the Individuals tab, move on to the Families tab and repeat the process, then the Notes tab, and so on until all tabs have been merged. A VERY COMMON MISTAKE is to ignore most of the tabs.
  • When you are happy that you have done all you can press the Merge button.
  • If you have not checked all the records you will be prompted to confirm that it is ok to go ahead.
  • You will the be asked if you wish to create a new source for the merge. This is worthwhile and there are various options on how to link the records or to confirm records that, for example, you and your fellow researcher have independently found.
  • Eventually, when everything is satisfactory, you can delete the temporary new Project created originally.

Common Problems

  • Records that should not have been matched, have been.
  • Records that should have been matched, have not.
    • These will appear as duplicates on your file, and in Diagrams there will coloured ribbons connecting them. Identify the duplicate records and merge. A common cause is forgetting to merge all the tabs.
  • Data, such as names, have been kept, such as Alternate Names or dates.
    • These can be identified through running a Query.
  • Unrecognised data has appeared (UDF).
    • This may be Uncategorised Data. These are data items that Family Historian cannot recognise. See Handling Uncategorised Data Fields (UDF). These can be removed through putting them in a Named List using the Find Uncategorised Data option in the Tools menu and then removing, or converting the data to valid fields, or using the V5+ UDF List Plugin.
  • Names, especially from FamilySearch, are in upper case.
    • V4 or below: Nothing you can do bar editing the file record by record or by using a text editor,
    • V5 or above: Use Clean up Surname Capitalisation plugin.
  • The file you have been sent is not a Gedcom but is specific to another genealogy application.
    • Common file types are .paf Personal Ancestral File, .FTM or .FTW Family Tree Maker. These need to be converted to Gedcom prior to import, which will require the original program that created the file to perform the conversion. If you cannot find a method of doing this, the best thing is to politely request the info as a Gedcom. Ask the person who sent the data to look for an Export option on their program, or else beg on the FHUG forum or FH Rootsweb and hope someone has the creating software.
  • Warning message: "The file you have selected to merge/compare with the current file contains media, and has not been saved since it was moved or copied from its previous location." etc…
    • V3 or below: Heed the warning and perform the specified action.
    • V4 or above: Ignore the warning but ensure both Projects/Gedcom are fully backed up.

Section glossary