Running Family Historian on Crossover

Introduction

The advice below applies to the current version of Crossover the Windows emulator from CodeWeavers and is a a variant of Wine from WineHQ.

  • CrossOver Mac Version 19.0.1
  • CrossOver Linux Version 19.0.1

Also see Reported Problems.

Only the latest versions of ƒh and AS are supported as described below.

Program Installation

Crossover installation process is similar for Mac and Linux platforms. See How to install Crossover Mac or How to install Crossover Linux

Install the programs into a Windows 7 or Windows 8 configuration. Do NOT use Windows XP. For Mac OSX v10.15 (Catalina) and later a 64bit version of the Windows OS MUST be installed.

When installing ƒh, disable Create a desktop icon and disable Launch Family Historian part way through the install progress. Ignore messages saying ƒh is incompatible with Windows 7/8 or that the installation was incomplete.

Family Historian V7

Family Historian V7 has some significant issues running on Crossover. Only install ƒh V7 if you are aware of these limitations.

  • During the install process of V7 into a Crossover Bottle it will report errors and may hang whist installing the Nova PDF driver
  • Reports do not work. They display a black screen in preview mode, unlike V6 which prints the report content correctly, V7 will print a black report to the printer. Fixed in V7.0.3 of ƒh
  • Reports cannot be saved to the Mac pdf printer
  • Reports can be saved as RTF files and these will display and print correctly using an external program
  • If a notes field is selected and just a formatting change is made then no save button is displayed. To alter formatting additional text must be added to the note, formatting applied and then the additional text deleted, now a save button will be displayed.
  • Pasting text from a Mac window or browser must be pasted in as unformatted text otherwise it will not paste into the Note, Text from Source etc fields in ƒh
  • Carriage returns may be stripped from Note, Text from Source fields etc and similar on import into a new project.

Crossover

In Crossover (as of Dec’15) select install a Windows Application as normal. Create a new Win 7/8 Bottle for Family Historian V6 as an unsupported other application. Ignore the Family Historian version that is in the supported applications as this is the 30 day free trial version.

Install these applications into one bottle:

  • Family Historian V6 or V4/V5 to V6 Upgrade CD or download as per the Family Historian Installation Advice
  • Family Historian Version 6.2.7 Upgrade as advised in Program Updates below
  • Microsoft .NET Framework V3.5 SP1 only needed by AS: Tick Microsoft .NET Framework option
  • Utility ~ Ancestral Sources v5.2.0 32-bit latest download (64bit if on Mac OSX v10.15 (Catalina) or later)
  • Use Crossover CrossTie to download Windows Script 5.7 or tick option (needed by some Plugins)

Program Configuration

To ensure ƒh Reports display text correctly, set ƒh Tools > Preferences > General > Advanced > Emulator Compatibility Mode.

All the ƒh and AS settings below should specify similar folder paths, usually involving the Documents folder, and all the named folders and files must actually exist.

  • ƒh File > Project Window in the Location field
  • ƒh Tools > Preferences > Startup in the Default Startup File field
  • ƒh Tools > Preferences > Backup in the Default Backup Folder field
  • AS Tools > Options > General settings > Folders in all three fields

If necessary, it is advisable to create new folders using Crossover rather than within ƒh or AS applications.

Configuration changes are needed as described below in Plugins to allow some Plugins to work.

The default Location for projects is My Documents\Family Historian Projects that is physically on the Mac at Documents/Family Historian Projects.

The C:\Program Files\Family Historian installation folder is physically at <username>/Library/Application Support/Crossover/Bottles/Family Historian V6/drive_c/Program Files/Family Historian where Family Historian V6 is the name if your bottle.

Ensure the Crossover window remains on the Mac screen on which it is opened, and does not follow the cursor when swiped to another screen. To achieve this, locate the Dock and right-click (control-click) the Crossover icon, go to Options, and ensure it is set to This Desktop. Repeat this with the FH and AS icons.

Program Updates

The simplest way to update both ƒh and AS is to use their own Help > Check for Updates commands and follow the automated download and install process.

Otherwise use the following strategies for both ƒh and AS program updates.

After the update has been downloaded, preferably using Firefox, and the program association has been made, then double-click the update exe file to apply the update in the existing bottle.

Plugins

Plugins downloaded from the Plugin Store sometimes will not import using the browser Open With option, although Save followed by an explicit Import command works OK. A workaround in Firefox is to use its Firefox > Preferences settings to associate .fh_lua Plugin files with Family Historian then Open With works OK too.

Configuration

The following COMPUTERNAME Environment Variable change is needed to allow many Plugins to work.

Click on the 3 blue bottles underneath the screen sizing icons, select the Family Historian V6 bottle, and click the gear menu and choose Open C:drive. Finder will now open, so go up one level in Finder and select the cxbottle.conf file, and open it in a plain text editor such as TextEdit. Scroll to the bottom of the file to the [EnvironmentVariables] section, and at the bottom of this section add a new line, ensuring that the quotes are normal ones and NOT smart quotes:

“COMPUTERNAME” = “NAME”

Make this “NAME” unique across your computers, but do not use your Mac computer name in System Preferences. Choose an alternative name such as your first name all in capitals.

Finally Save the cxbottle.conf file.

If you are using Text Edit smart quotes are turned on by default. Turn them off by selecting Edit > Substitutions and untick Smart Quotes.

Plugin Library Modules

Some Plugins require extra library modules not included in the ƒh installation, but their download will fail or be very slow. So download and run the Install Library Modules Plugin shortcut to install these library modules in advance: luasql, md5, mime, pl, socket & zip.

Problems With Plugins

The Plugins listed below may have limitations. Ensure that COMPUTERNAME is set as advised above.

Backup and Restore Family Historian Settings

Version 2.5 or later is almost fully operational in Crossover, the limitation being, it only detects the primary Family Historian installation, and NOT any subsidiary installations such as Family Historian Demo 3.0 or Family Historian 6.0 Beta, and it will omit the settings of any custom Named List not mentioned in the current Project.

Check Installed Plugins Against the Store

This may say all Plugins are Not In Store because Crossover does not support the winhttp service needed to check the Plugin Store. See Forum thread Check Installed Plugins Against the Store – Crossover issue.

Some Plugins also check the Plugin Store for a later version, but cannot do so for the same reason as above.

Therefore, it is necessary to occasionally check the Plugin Store manually to ensure you have the latest versions.

This problem appears to be partially fixed in Crossover v18.5.0 onwards, although automatic Plugin Store downloads still fail, so must be updated manually.

Research Planner

This Plugin also relies on the winhttp service to download its help file so will fail in Crossover. A manual process to install the help file is detailed in the forum at here

Printing and PDF

All ƒh Print Setup and Print options work with any Mac or Linux printer, even when a Report is displayed incorrectly on screen (see Reported Problems below).

The free PDFWriter for Mac offers a way of creating PDF output via the ƒh Print commands rather than the ƒh Save Diagram/Report As > PDF File (.pdf) commands.

The free CUPS-PDF for Linux offers similar PDF features.

Reported Problems

Mac specific issues

With osX Catalina all applications must be 64Bit or they will not install / run. As a result Crossover v19.x or higher must be used as the version of Wine  used by Crossover in this version is 64bit compliant, however, ƒh is still a 32bit application and so you may still get a warning about 32bit apps not running but it does still work.

Mac and Linux issues

Avoid using Internet Explorer as it can lead to download issues. Instead use Firefox or Chrome in the native Mac or Linux environment.

Although the Family Historian PDF (novaPDF printer) installs, Wine based emulators do not support Windows printer drivers, so the novaPDF printer does not work.

It can be removed via the Installed Applications dialogue Repair or Remove button

Having done so, the ƒh Save Diagram/Report As > PDF File (.pdf) commands say PDF file output is not enabled.

Some ƒh Reports may display text incorrectly, but this is usually cured by using Tools > Preferences > General > Advanced > Emulator Compatibility Mode. See Index for related topics

Use Tools > Preferences > Internet Data Matches > Location to Display Matches: External Web Browser to avoid problems with the internal window.

The Map Window has display rendering problems. Also there are currently issues with its events sub-window not displaying the events. The individual events are shown on the map, they just cannot be filtered. Better in Crossover 15.0.0 or later.

The ƒh command Tools > Preferences > Backup > <<Select > Make New Folder, and similar commands in Plugins, produce a hieroglyphic error message. The workaround is to create the folder beforehand using Crossover and select the pre-existing folder in ƒh or Plugins.

When changing a Date field and the Invalid Date message opens saying Unknown date. Please enter a valid date. do not change focus to another application as ƒh will freeze and must be closed. This problem may affect other error messages.

AS often would not work at all prior to Crossover 15.0.0.

If ƒh &/or AS &/or another program are running at the same time, and one program changes the shared GEDCOM file, then the other program(s) correctly report the file has changed, but then may freeze and Force Quit must be used. This problem appears to be fixed in Crossover v18.5.0 and later.

There are assorted minor issues in Crossover v15 and earlier and so v18.5.0 is the minimum version recommended for ƒh

Last update: 26 Mar 2021