Importing to Family Historian

Introduction

Importing a GEDCOM into Family Historian (ƒh) may be as simple as opening the GEDCOM file in Family Historian.
Each of the sections below give advice for importing from various other genealogy products.

Suggested actions

  • The first time you open the file, ƒh will offer to check the file for errors and produce a report of fields it does not understand Uncategorised Data Fields. Always let the process run and on completion save the file to a new name using the File/Save As option.
  • Work through the Uncategorised Data Fields report to check for any rejected and “error” tags, these are normally caused by the program by the GEDCOM file came from. However you may be able to identify the errors and correct them either directly in ƒh or by using a text editor to do a search and replace for the GEDCOM tags.
  • Custom Facts imported from another product will have no Fact definitions and are not listed by default. To reveal them, tick the Show Hidden option, and click the Visible column heading to sort the <undefined> Custom Facts to the bottom. Select each one in turn and click the Edit button to create a definition.

Import from Family Tree Maker (FTM)

Introduction

Different versions of Family Tree Maker (FTM) have different database formats. Use the export to GEDCOM option, and from FTM 2012 image data is also exported, but prior to FTM 2012 scrapbook images are not exported. Note that any “source” images from Ancestry are not exported, so ensure all such images are saved to your PC while your Ancestry subscription is active. The FTM 2017 version by MacKiev is more GEDCOM compliant than previous versions, so follow any specific advice below for this version.

ƒh V6.2 has significantly enhanced features for FTM migrants, so be sure to upgrade if possible, as it is a free upgrade for V6 users. Click Check for Updates on the Help menu of ƒh if you want to confirm that you have the latest version. Users of the ƒh 30 Day Free Trial should be aware that it supports all features of ƒh except Family Historian Plugins.

Export GEDCOM from Family Tree Maker

File Export Dialogue

  1. In FTM open the file you wish to export to GEDCOM.
  2. Choose File > Export to open the Export dialogue.
  3. In the Output Format dropdown list select GEDCOM 5.5.
  4. Select items to include such as private facts, private notes, or media files.
  5. Press OK.

Versions prior to FTM 2012/2014 may have other options, so ensure Indent records is NOT ticked, and that Abbreviate tags is ticked.

Export to GEDCOM Dialogue

  1. The Export to GEDCOM dialogue should now be open.
  2. Select Destination as Other.
  3. Select Character set as ANSI.
  4. Press OK.
  5. Decide on a location to store your GEDCOM file so that you can easily retrieve it later. A reasonable place to store your file might be your Desktop or My Documents. You can access these by clicking on the box next to Save in and scrolling all the way to the top. You will find both the Desktop and My Documents in that list.
  6. Next to where it says File name type a file name such as MyData.ged.
  7. Press Save.

Export Status Dialogue

  1. The Export Status window should indicate the file exported successfully.
  2. Press OK.
  3. Your file has now been exported and is ready to be used to create a Project or opened directly in ƒh.

See Understanding Projects for more information on creating Projects from GEDCOM files using the File > Project Window.

Media Images

With ƒh V6.1 or later, any Media attached to Citations is easily found via the View Media dialogue.

For ƒh V6.0 or earlier, any Media attached to Citations may appear to vanish, but they are just being coy. They can be discovered on the All tab of the Individual’s Property Box, but can also be revealed by using the toolbar camera icon View Media for selected Individual, and choose just the Source and Citation Media option. If you cannot find them ask for help in the Forums.

If you are using ƒh V5.0.8 or earlier, and need to migrate your Media files, then the GEDCOM file must be changed using a plain text editor such as Windows Notepad to replace every occurrence of 1 FILE with 1 _FILE , whereas later ƒh versions do not require this edit.

General Advice

In ƒh V6.2 many of the problems below have been resolved without the need for Quick Fix Plugins. A special Fact Set named Extended Set has been added to support the extended FTM facts.

Prior to FTM 2017, the Cause of Death was appended to the DEAT event tag, and when imported to ƒh automatically moved to the Death event local Note, but any existing Note hidden, except on the All tab. Thereafter, the Note can be manually moved to the Death event Cause field, and deleted. A similar problem may affect other facts with an FTM Description. Alternatively, use the Quick Fix Plugins method below.

If a Source Citation has both an Entry Date and Text From Source then an extra 3 DATA tag is produced. ƒh may convert these to 3 _DATA Uncategorised Data Fields. To correct the problem, use a plain text editor such as Windows Notepad on the exported GEDCOM file to find and delete the redundant 3 DATA tag lines, or use the Quick Fix Plugins below.

Source and Repository record 1 RFN tags are treated as Uncategorised Data Fields and fixed by Quick Fix Plugins below.

Some fact tags might be treated as Uncategorised Data Fields and may include:

  • 1 ADDR Address
  • EMAIL Email
  • 1 PHON Phone
  • 1 _ELEC Elected
  • 1 _FUN Funeral
  • 1 _MDCL Medical
  • 1 _MILT Military

A fix for these in ƒh V6.2 is to use the Extended Set. Alternatively, use the Quick Fix Plugins below, then the Change Any Fact Tag Plugin if you wish to alter the facts chosen by default.

Quick Fix Plugins

The problems identified above, and several others, can be fixed as explained below:

  • Before importing the GEDCOM file, use File > Project Window to open say the Family Historian Sample Project and use the ƒh command Tools > Preferences > File Load/Save and untick Move invalid data into note fields where possible to allow Death Cause to be easily detected and multiple Notes merged.
  • With FTM 2017 the CONCatenated long line word-wrapping has been corrected, and is mishandled by ƒh wrongly inserting space characters, while also inhibiting the Check for word-wrapping errors dialogue. The workaround is to use a plain text editor such as Windows Notepad to change the GEDCOM second line from 1 SOUR FTM to 1 SOUR OTHER, which enables that inhibited dialogue as described below.
  • Import the GEDCOM file via the ƒh command File > Project Window > New Project > Import a GEDCOM file.. Ensure Copy any linked multimedia files into the new project folder is ticked. The dialogue is uncomplicated, but in the Check for word-wrapping errors window, select Each row contains 2 words separated by a hyphen, although it is reported that Each row contains 1 word with a hyphen in the middle works better especially for FTM 2017.
  • Use the ƒh command Window > Log Files to view a log of the problems mentioned above, but do NOT Delete the log file.
  • If running an ƒh version earlier than V6.2, install the Import From Ancestry or FTM Plugin into the Tools > Plugins window.Run this Plugin to produce a Result Set of changed Fields. Click any Field Value and choose Locate in Property Box or Locate in All Tab to open its Property Box for review. To cancel the Plugin changes, use Edit > Undo Plugin Updates before closing ƒh.If this Plugin hits problems, they may need resolving in FTM or by Handling Uncategorised Data Fields (UDF) for just the problem fields.
  • Follow the advice in Handling Uncategorised Data Fields (UDF) if necessary.
  • Follow the advice in Fixing Dates and Date Phrases to correct invalid Date formats.
  • When satisfied with the results, use the ƒh command Tools > Preferences > File Load/Save and tick Move invalid data into note fields where possible to restore default setting.
  • In Forum thread Note fields not transferring from FTM GED it was reported that Note Records are used instead of local Notes on Facts, and can be fixed using the Clean Up Notes Plugin.

Import from Ancestry website

Introduction

Importing from Ancestry can be awkward, especially if Media images are required, so if you have a synchronised FTM database, then an Import from Family Tree Maker (FTM) is usually a better option. Also check the Media Images section below for further advice.

ƒh V6.2 offers significantly enhanced features for FTM migrants, many of which also benefit Ancestry migrants, so be sure to upgrade to V6.2.x if you aren’t already using it. V6.2.x is a free upgrade for V6 users. Click Check for Updates on the Help menu of ƒh if you want to confirm that you have the latest version, but beware that the Upgrade Now auto-installation process may fail, and the Family Historian Version 6.2.7 Upgrade process is more reliable. Users of the ƒh 30 Day Free Trial should be aware that it supports all features of ƒh except Family Historian Plugins.

Exporting Your GEDCOM

There are alternative Ancestry commands to reach the export a GEDCOM option.

  • From most screens click TREES > Create & Manage Trees and then click Manage tree against the tree to be exported.
  • Otherwise, if the tree is already open, click the tree name top left and click View Tree Settings.

Either way, the Tree Settings ~ Tree Info page should be displayed for the chosen tree.

  • On the right side of the page there is a button to click labelled *↓ Export tree*.

  • Ancestry will now go ahead and process the tree, eventually presenting a button to click labelled *↓ Download your GEDCOM file*.
  • Choose Save File to download the GEDCOM file to your computer.
  • See Understanding Projects for more information on creating Projects from GEDCOM files using the File > Project Window.

Media Images

Downloading the GEDCOM file does NOT download any linked Media images, but does include Media records.

Family Tree Maker

If you have a synchronised FTM database with Media files, then an Import from Family Tree Maker (FTM) is usually a better option, and it includes Media images.

Roots Magic

RootsMagic offers a TreeShare for Ancestry capability that downloads most Media images. Those image files can be linked into the Ancestry project Media records after importing to ƒh, or the Import from RootsMagic (RM) process can migrate the entire project including Media. Note that the RootsMagic Essentials version is free.

General Advice

In ƒh V6.2 many of the problems below have been resolved without the need for Quick Fix Plugins. A special custom Fact Set named Extended Set has been added to support the extended FTM facts.

Prior to FTM 2017, the Cause of Death was appended to the DEAT event tag, and when imported to ƒh automatically moved to the Death event local Note, but any existing Note hidden, except on the All tab. Thereafter, the Note can be manually moved to the Death event Cause field, and deleted. A similar problem may affect other facts with an FTM Description. Alternatively, use the Quick Fix Plugins method below.

If a Source Citation has both an Entry Date and Text From Source then an extra 3 DATA tag is produced. ƒh may convert these to 3 _DATA Uncategorised Data Fields. To correct the problem, use a plain text editor such as Windows Notepad on the exported GEDCOM file to find and delete the redundant 3 DATA tag lines, or use the Quick Fix Plugins below.

Source and Repository record 1 RFN tags are treated as Uncategorised Data Fields and fixed by Quick Fix Plugins below.

Some fact tags might be treated as Uncategorised Data Fields and may include:

  • 1 ADDR Address
  • EMAIL Email
  • 1 PHON Phone
  • 1 _ELEC Elected
  • 1 _FUN Funeral
  • 1 _MDCL Medical
  • 1 _MILT Military

A fix for these in ƒh V6.2 is to use the Extended Set. Alternatively, use the Quick Fix Plugins below, then the Change Any Fact Tag Plugin if you wish to alter the facts chosen by default.

Quick Fix Plugins

The problems identified above, and several others, can be fixed as explained below:

  • Before importing the GEDCOM file, use File > Project Window to open say the Family Historian Sample Project and use the ƒh command Tools > Preferences > File Load/Save and untick Move invalid data into note fields where possible to allow Death Cause to be easily detected and multiple Notes merged.
  • With FTM 2017 the CONCatenated long line word-wrapping has been corrected, and is mishandled by ƒh wrongly inserting space characters, while also inhibiting the Check for word-wrapping errors dialogue. The workaround is to use a plain text editor such as Windows Notepad to change the GEDCOM second line from 1 SOUR FTM to 1 SOUR OTHER, which enables that inhibited dialogue as described below.
  • Import the GEDCOM file via the ƒh command File > Project Window > New Project > Import a GEDCOM file.. Ensure Copy any linked multimedia files into the new project folder is ticked. The dialogue is uncomplicated, but in the Check for word-wrapping errors window, select Each row contains 2 words separated by a hyphen, although it is reported that Each row contains 1 word with a hyphen in the middle works better especially for FTM 2017.
  • Use the ƒh command Window > Log Files to view a log of the problems mentioned above, but do NOT Delete the log file.
  • If running an ƒh version earlier than V6.2, install the Import From Ancestry or FTM Plugin (found by searching the forum) into the Tools > Plugins window.

Run this Plugin to produce a Result Set of changed Fields. Click any Field Value and choose Locate in Property Box or Locate in All Tab to open its Property Box for review. To cancel the Plugin changes, use Edit > Undo Plugin Updates before closing ƒh.

If this Plugin hits problems, they may need resolving in FTM or by Handling Uncategorised Data Fields (UDF) for just the problem fields.

  • Follow the advice in Handling Uncategorised Data Fields (UDF) if necessary.
  • Follow the advice in Fixing Dates and Date Phrases to correct invalid Date formats.
  • When satisfied with the results, use the ƒh command Tools > Preferences > File Load/Save and tick Move invalid data into note fields where possible to restore default setting.
  • In Forum thread Note fields not transferring from FTM GED it was reported that Note Records are used instead of local Notes on Facts, and can be fixed using the Clean Up Notes Plugin.

Import from Genbox

Introduction

Genbox database files (*.gdb) can be imported directly in version 5 or 6. For earlier Family Historian (ƒh) versions export from Genbox using gedcom.

Direct Import in V5/6

  1. Open the Project Window File>Open Project Window
  2. Select New Project
  3. Select Import From Other Family Tree Program
  4. Press Browse, and navigate to the folder containing your Genbox database and select it.
  5. Make sure the Import Media is ticked and press Next
  6. You will then be prompted to name the Project, you can use the existing title or change it and click Next
  7. Your new Project will then open.

Export Gedcom from Genbox

  1. Open the file you’d like to export to GEDCOM in Genbox.
  2. Click on the File menu and move your mouse cursor down to Export Data.
  3. Click on to GEDCOM File…
  4. Click the Defaults button.
  5. Click the Make Export File… button.
  6. Decide on a location to store your GEDCOM file so that you can easily retrieve it again. A reasonable place to store your file might be your Desktop or My Documents. You can access these by clicking on box next to Save in and scrolling all the way to the top. You will find both the Desktop and My Documents in that list.
  7. Type a file name next to where it says File name. An example file name would be MyData.ged
  8. Click Save.
  9. When the file is finished exporting, it will say Operation Completed.
  10. Click OK.
  11. Your file has now been exported and is ready to be used to create a Project or used directly in Family Historian.
  12. See Understanding Projects for more information on creating Projects from Gedcoms and using the Project window.

Some GenBox users have found that sometimes Gedbox does not correctly export Child links, and FH drops the links on validation. The plugin below uses the Validation report to re-create the dropped links.

Search the forum for the Fix Missing Child Links plugin.

To use simply open the Gedcom file and then run the plugin and select and open the Validation report when prompted, a result set will show the recovered individuals.

Import from Legacy Family Tree (LFT)

Introduction

Legacy is a Family History program. It’s GEDCOM file is a little “eccentric” and in order to import it there are several recommended steps. This article is based on the import of only a few GEDCOM files so improvements to the text are to be expected.

To export your database for import to Family Historian (ƒh) use the Export Gedcom option in Legacy.

Use the File tab Export > GEDCOM File command.

On the Options tab:

  • Select Produce file for: GEDCOM 5.5.1 Only or perhaps Legacy to include extra details explained later
  • Select Character Set: ANSI (UTF-8 is an option but only the ANSI character set is supported)
  • Set Break Note lines every 240 characters
  • If Keep embedded formatting codes within text is ticked, then tick Convert formatting codes to HTML style to change « and » into < and >

On the Other Options tab:

  • Tick Override Source options – include all source information
  • Maybe tick Export burial information marked as Cremated as a Cremation event

Click the Privacy Options button on the right:

  • Review the Override Private Settings options, then click Save or Cancel

Click the Customise button on the right:

  • Review Export Items dependent on GEDCOM 5.5.1 Only or Legacy chosen above:
    • Perhaps < Remove the _UID Unique Identifier items
    • Maybe click the Only 5.5 button
    • Maybe Include > the _PLAC_EFN Place Definition for location Lat/Longitude values
    • Use Save List and Load List to try various options to get different data exported
  • Do NOT tick Move Event Descriptions to the Event Notes field as that will also move Attribute descriptions for facts such as Occupation (ƒh will move the Event descriptions)
  • Do tick Don’t convert British Quarter dates to a date range to let the ƒh Fix Date Fields plugin convert them to Quarter Dates
  • Click OK

Finally click the large blue START EXPORT button top right.

From ƒh V5 onwards a selection of Family Historian Plugins can help you migrate your files once they are inside ƒh. The first step is to check all records which fail to import into ƒh as outlined below.

Details

Record Numbers

The way Legacy exports Notes, can mean that ƒh prior to Version 6.2.5 will renumber your Record IDs on all Record Types. If it is important to you to keep the existing numbers, there is a small Plugin that will allow you to make a saved copy of the record numbers and copy them back after the import is complete. See the advice on Handling Renumbered Record Id and the migrate from Legacy – keep ids Forums Topic.

Place Locations

Legacy keeps Place data in a slightly different format to ƒh, but there is a Convert Legacy Places plugin that lets you convert the location data BEFORE you open the file in ƒh. It depends on the _PLAC_DEFN Place Definition being included in the Export Items and may need Produce file for:Legacy to be chosen.

Simply download and double click to install, then in ƒh run the Plugin from the Tools > Plugins menu. When run it will prompt for the GEDCOM file and then create a new copy of the file in the same folder which you can open in ƒh.

Opening in Family Historian

Make a copy of the file to be imported. Make the original file read only to prevent accidental changes. (Right click on the file and choose Properties.)

Open the copied GEDCOM file in ƒh File > Gedcom File Tasks > Open Gedcom File, and in the Check for word-wrapping errors window, select Each row contains 1 word with a hyphen in the middle of it.

 

Report Issues

Say Yes to viewing the report. Ignore all the INFO ONLY messages: these can be dealt with later from inside ƒh. Use Edit » Find to look at all the EXCLUDED data. Some of these reports may be avoided by use of the Legacy export Customise button and alter the Export Items setting discussed above.

 

To understand these lines it may be necessary to understand the GEDCOM Standard Release 5.5. In this example it turns out that QUAY is an assessment of the certainty of the evidence to support the conclusion drawn from evidence. (p78) From page 38 it may have values of 0 to 3. Therefore I decided to change the value of 4 to 3 using a manual edit on a copy of the original GEDCOM file.

Another common excluded item in my file is this line:

 

This means sex unknown. This is not a valid parameter. These records can safely be ignored as ƒh will leave the sex field blank.

Another common excluded line is _PLAC_DEFN. The underscore at the start shows that it is a user defined field. (i.e. a field that is not in standard GEDCOM: probably better described as a field defined by the software vendor.) They appear to be a list of places used in the file, see above if you want to retain your geolocations and have a full ƒh licence. I ignored these records and the excluded branch lines.

You can also exclude these lines:

These rejections were made:

Close ƒh and make any manual edits required to the copy of the GEDCOM file. Then reopen the file in the manner suggested at the start of this article.

Click Yes to allow Validation:


Set Family Historian Preference for Descriptions

During import, any description on an Event (but not Attribute) will by default be moved to its local Note field, but if it already has a Note, then one of them becomes partially hidden, and will need merging later perhaps using a Plugin.

Alternatively, the description can be moved to a unique _UNCAT UDF field and subsequently corrected using a Plugin. To select this mode, before importing the GEDCOM file, use File > Project Window to open say the Family Historian Sample Project and use the ƒh command Tools > Preferences > File Load/Save and untick Move invalid data into note fields where possible.

Create New Project in Family Historian

Use File > Project Window and the New Project button, and select Import a GEDCOM file. Choose the final edited copy of the GEDCOM file from above. The dialogue is uncomplicated, but in the Check for word-wrapping errors window, select Each row contains 1 word with a hyphen in the middle of it as above.

See Understanding Projects for more information on creating a Project from GEDCOM & media files, and using the Project Window.

Once the Project is in Family Historian

In the Forum thread Importing Marriages from Legacy it was reported that Note Records were used instead of local Notes on some Facts, and can be fixed using the Clean Up Notes plugin.

Use the Fix Date Fields plugin to convert Quarter Dates and possibly other dates.

Use the Move Local Media to Media Records plugin to convert local Media invalidly attached to Address fields into Media records attached to the parent Facts.

Use the UDF List Plugin and check the advice on Handling Uncategorised Data Fields (UDF).

Here are some typical results:

Click on Item Tag to sort the data by Item Tag.

Looking at the data I found that there were some tags that were of no interest to me. _TAG,_TAG3, _TAG4, _TAG6. To delete these fields, I selected the UDF Item field of the first item in the list, and then scrolled down, pressed shift and selected the last item. I then pressed the delete key and said OK to the message.

The next field was _UID. This is a vendor defined tag which gives a unique identifier to each individual and so allows an easy merge between files imported from the same vendor. For more information try http://www.tamurajones.net/The_UIDTag.xhtml. As I am importing from Legacy to ƒh this is no use to me, so I deleted these tags.

EMAIL and _URL items. I am going to merge the file and so I do not want the sender’s email address or web site in my file so I also deleted these items.

I reran the UDF List Plugin and this had brought the number of UDFs down from 1593 to 471 (for 210 Individuals) A quick scroll through the file showed that there are problems with Source records. Looking at the Item Data Reference column, there are fields such as:

...SOUR.QUAY
...SOUR.PAGE.CONC
SOUR.DATE
SOUR.MEDI
From the GEDCOM standard page 34, SOUR refers to a Source and the only valid sub fields are:

  • After pointer to a source record: PAGE, EVEN, DATA, QUAY plus multimedia link and note structure.
  • After a source description: CONC, CONT, TEXT plus note structure.

A Plugin may be able to sort these problems. However the file can be merged with an existing ƒh project: any Uncategorised Data Fields will be moved across with their appropriate parents. They will still be visible in any new file using the UDF List Plugin.

Import from MyHeritage (MYH)

Introduction

MyHeritage is normally a straight forward import to Family Historian. However, if Media need to be transferred then use the Windows companion program Family Tree Builder synchronised with the MyHeritage online tree.

Export GEDCOM from MyHeritage Online Family Tree

Use the Family tree > Manage trees > Export to GEDCOM option and save the GEDCOM file in a memorable location.

Include photos in the export. However, this only provides URL links to the online images that ƒh cannot handle, so use Family Tree Builder to download image files.

Export GEDCOM from MyHeritage Family Tree Builder

Use the File > Export GEDCOM command and save the GEDCOM file in a memorable location.

Take care to choose appropriate options in the export dialogue. Include all people, save notes, sources & photo information, but do not omit living people or private data.

Accept the offer to copy exported photos into a subfolder.

Create New Project

First use File > Project Window and the New Project button, and select Import a GEDCOM file. Browse to the GEDCOM file saved by MyHeritage. The dialogue is uncomplicated, but in the Check for word-wrapping errors window, select Each row contains 1 word with a hyphen in the middle.

See Understanding Projects for more information on creating a Project from GEDCOM & media files, and using the Project Window.

Once the Project is fully functional the original exported GEDCOM file and photos subfolder can be deleted.

Correct Problems

The import process will create two log files found via Window > Log Files that report problems that must be corrected, and the most common cases are listed below. They will differ depending on whether the Online Family Tree or Family Tree Builder was used to create the GEDCOM file.

  • The many UDF can be reviewed via the UDF List Plugin as advised in Handling Uncategorised Data Fields (UDF). e.g.
    • UDF tags such as _UID can be deleted, or moved to Custom Id fields using a Plugin.
  • There will be many Automated Record Id (RIN) fields holding values such as MH:I8 that will be visible on the All tab of the Property Box of many types of record.
    They can be removed by using the Search and Replace Plugin. Choose LUA Pattern Mode with the Search box set to ^MH:.+ and on the Extra Filters tab only tick Permanent & Automated Record Number fields.

Import from Personal Ancestral File (PAF) / Relatively Yours

Introduction

PAF (5.2) is normally a straight forward import to Family Historian. If you have a very early version of PAF it is normally best to download the latest Version 5.2, then load in the data file, and export it to GEDCOM.

The Relatively Yours product also exports a PAF format GEDCOM via the Family or Group menu, so the following is also relevant.

Details

Create New Project

First use File > Project Window and the New Project button, and select Import a GEDCOM file. The dialogue is uncomplicated, but in the Check for word-wrapping errors window, select Each row contains 1 word with a hyphen in the middle.

See Understanding Projects for more information on creating a Project from GEDCOM & media files, and using the Project Window.

Correct Problems

There are some items to watch out for such as invalid dates becoming Date Phrases, custom _AKA and _UID UDF tags, and Individual Local Note Tags, but most are fixed by the Import From PAF Plugin.

  • PAF will allow invalid GEDCOM dates to be entered, which will become Date Phrases when loaded in to Family Historian. Most should be fixed by the Import From PAF Plugin, but see Fixing Dates and Date Phrases for other options.
  • The _AKA UDF tags are for “Also Know As names” and the Import From PAF Plugin allows them to be deleted, or moved to Alternate Name fields, or Title Attribute standard facts, or AKA Attribute custom facts.
  • The _UID UDF tags can be deleted or moved to Custom Id fields using the Import From PAF Plugin.
  • Both the above UDF can also be handled via the UDF List Plugin. Sort by tag and highlight all the _AKA and _UID values, and delete them by pressing the delete key.
  • Individual Local Note Tags hold text relating to Facts and are best handled by the Import From PAF Plugin. This allows each Tag to be identified, and a Fact related text field (such as Note or Text From Source) chosen for each Tag. The text against each Tag is then moved to the chosen text field.

Import from RootsMagic (RM)

Introduction

Different versions of RootsMagic have different Database formats. RootsMagic 1 to 3 database files have a .rmg extension that can be directly imported. However, later versions use a different format with a .rmgc extension, so will need to migrate via the GEDCOM route.

Direct Import in V5+ from RootsMagic 1 to 3

  1. In ƒh open the Project Window  File > Project Window.
  2. Select New Project.
  3. Select the Import from other family tree file option.
  4. Press Browse, and navigate to the folder containing your RootsMagic .rmg database and select it.
  5. Ensure the Copy any linked multimedia files… option is ticked and press Next.
  6. You will be prompted to enter the New Project Name, so use the existing title or change it, and click Finish.
  7. Your new Project will then open.

Export Gedcom from Roots Magic 4 to 7

  1. In RootsMagic open the project you’d like to export to GEDCOM.
  2. Select File > Export….
  3. Make sure that:
    1. People to export box has Everyone selected.
    2. Destination box has General selected (only in early versions).
    3. Privacy Options box has Privatize living people NOT checked.
    4. Data to export has all items checked EXCEPT the following:
      1. To-Do tasks
      2. Research logs
      3. Correspondence log
      4. Note formatting (bold, etc)
      5. Extra details (RM specific)
  4. Click the OK or Export button.
  5. Decide on a location to store your GEDCOM file so that you can easily retrieve it later. A reasonable place to store your file might be your Desktop or My Documents. You can access these by clicking on the box next to Save in and scrolling all the way to the top. You will find both the Desktop and My Documents in that list.
  6. Type a file name next to where it says File name. An example file name could be MyData.ged.
  7. Your file has now been exported and is ready to be used to create a Project or used directly in ƒh.

Create New Project in Family Historian

Use File > Project Window and the New Project button, and select Import a GEDCOM file. Browse to the saved copy of the GEDCOM file from above. Ensure Copy any linked multimedia files… is ticked and click Next. Enter the New Project Name and click Finish.

The dialogue is uncomplicated, but in the Check for word-wrapping errors window, select Each row contains 1 word with a hyphen in the middle of it.

See Understanding Projects for more information on creating a Project from GEDCOM and Media files, and using the Project Window.

Common Problems

Several types of Uncategorised Data Fields (UDF) may still get reported:

1 _UID tags are used by some apps as a “Universal Identifier”, but ƒh does not support them, and they can be deleted.
2 _TYPE DOCUMENT or 2 _TYPE PHOTO and subsequent 2 _SCBK Y and 2 _PRIM N lines are Media properties that mean nothing to ƒh and may be deleted.

Media

RootsMagic manages all of its media externally, so it is probably simpler to maintain that way of working in ƒh.  Do not select the Copy any linked multimedia files into the new project folder (recommended) option during GEDCOM import.  Versions of ƒh prior to 7.0.4 created multiple copies of media records, but this has now been fixed.  All versions of ƒh can lose folder organisation of media and copy all files into the root Media folder unless you follow the advice given here.

Importing the RootsMagic 7 To-Do List

The ƒh import does not include the RootsMagic To-Do list.  A plugin has been provided that extracts the list from the GEDCOM file, complete with all Individual, Family and Repository links, and coverts them to Research Note records (regular Note records in ƒh5/6).  This is available here.

It does not import the RootsMagic 7 Research Log or Tasks from RootsMagic 8.  These options may be provided at a future date if required.

Import from The Master Genealogist (TMG)

Introduction

Importing from The Master Genealogist (TMG) to Family Historian ƒh is often quite straight forward. The ƒh website Frequently Asked Questions – for TMG Users gives an overview.

The two methods for migrating from TMG to ƒh are Import TMG Project and Import GEDCOM File. However, Import TMG Project does not support TMG V7 or earlier, so install the TMG V9 for US or UK below. See also posting Import TMG V7 to FH V6 project failure.

tmg9setup.exe TMG Version 9.3.0.0 US
tmg905uksetup.exe TMG Version 9.5.0.0 UK

TMG Tips

Apply these tips to your TMG Project before migration to ƒh.

If details such as Memos are not imported to ƒh then in TMG run all File > Maintenance options and try again (e.g. Reindex, Optimise, Validate File Integrity).

If some Citations are not imported to ƒh (other than as noted below) then this technique may help. Create a blank TMG Project and merge it with your main TMG Project, then all expected Citations should be imported.

TMG backups have a SQZ extension and can’t be used directly, but if you copy the file to a name with a .zip extension you can use the Windows option to extract the files to a folder and then follow the instructions below to import the data to ƒh.

Add details about TMG data sets, projects, and merging, plus how to copy TMG Projects for Direct Import to ƒh on another PC. See Forum postings Merging 2 trees.

Import TMG Project

Ensure TMG is not running.

Use File > Project Window and the New Project button, select Import from other family tree file and browse to the TMG (.tmg or .pjc) Project file. In ƒh Version 6.0 click Next > and review the TMG Import Options using the Help button to obtain advice. Click Next > to complete the dialogue.

This works well with most TMG versions and includes Witness details, BUT please ensure you are using the Family Historian Version 5.0.11 Upgrade or Family Historian Version 6.2.7 Upgrade. You can check this by selecting Help > About Family Historian on the menu.

Calico Pie Limited recommend using the TMG direct import as this includes Witnesses. ƒh Version 6.0 imports them as Fact Witnesses. ƒh Version 5.0.11 imports them in a Note against the Fact, allowing them to be processed later using Plugins in ƒh Version 6.0 if required. They ask that any problems are reported to them directly via the support@family-historian.co.uk if possible including a small sample database showing the problem.

Import Guide

The TMG items are imported as the following ƒh items by the Family Historian Version 6.2.7 Upgrade. The import is similar using ƒh Version 5.0.11, but not so comprehensive as explained later.

  • Every Person becomes an Individual Record
  • Every Relationship Tag becomes a Family Record link between parent & child
  • Every Source becomes a Source Record with Title, Short Title & Type but other fields in labelled Notes
  • Every Repository becomes a Repository Record with Name, Address & Note fields (but not Name-Other)
  • Every Exhibit becomes a Media Record
  • Every Name Tag becomes an Individual Name instance
    Every Tag with 1 Principal Person becomes an Individual Fact (Event/Attribute) e.g. Birth & Death
  • Every Tag with 2 Principal Persons as spouses/partners becomes a Family Fact (Event/Attribute)
  • Every Tag with 2 Principal Persons not spouses/partners becomes an Individual Fact of 1st with 2nd as Witness
  • Every Witness becomes a Witness of the associated Fact
  • Every Citation on every item above becomes a Citation except :
    • Every Citation on a Relationship Tag is omitted
    • Every Citation linking a Source to a Source is omitted
    • The lowest of the five Surety values becomes just one Assessment value :
      • 3 → Primary evidence
      • 2 → Secondary evidence
      • 1 → Questionable
      • 0 → Unreliable
      • – → Unreliable (TMG Negative Surety)
    • The Reference field is omitted
  • Every Flag is handled according to whether Standard or Custom and its Value:
    • Standard Flags :
      • Sex becomes the Individual ~ Sex field
      • Multiple Birth with value > 1 imports as a Multibirth Flag
      • Ancestor/Descendant Interest with value > 0 import as a similarly named Flag
      • Living and Adopted import the same as a Custom Flag
    • Custom Flags :
      • For values N or ? or blank the Flag is NOT imported
      • For value Y a Flag with a similar Name is imported
      • For other values a Flag with a similar Name suffixed by its Value is imported
      • Generally the Name will be similar, but the underlying Tag will be all upper-case, with punctuation symbols discarded, each space replaced by underscore, and truncated to 13 characters after the leading double underscore
        e.g. Is Related-by with value C becomes Is Related-by_C and __IS_RELATEDBYC respectively
    • The Sort Date for every Fact is omitted, but see Import GEDCOM File below.
    • The Repository of the first Source Record is omitted
    • Every link from a Place, Citation, or Repository to its Media is omitted
    • All Bookmarks are omitted.
    • The sentence definitions associated with Tags are omitted.

Known FH V5+ Problems

It seems that the ƒh V5 TMG direct import may not be working on Windows XP and Vista. If no data is imported on these OS please ensure you are running with an Administrator level user, this is not needed for normal operation, but may be needed when importing the TMG Foxpro database. The ƒh V6 TMG direct import is believed to be OK.

All the following cases exist in the sample database of the TMG Trial V9 at least for the [Record Id] listed.

  • In ƒh V5, the Witnesses are in Notes, so Citations only exist for the Fact of the Principal Person(s), which is similar to TMG, and mostly just affects:
    • [Census ] ] Tag Types where [ (w); ] appears in Name/Place with the Principal Person. [I1]
    • [Witness ] Tag Types where [ Marriage: ] is in Name/Place with two Principal Persons. [I1] in [F23]
  • Any TMG Note Tag becomes a Record Note but its Date & Citations are omitted. [I32] & [I33]
  • Any TMG Tag with 2 Principal Persons who are not parents becomes a Fact for both Principal Persons, but any Citations are omitted for Principal Person 2. Occupation of [I10]
  • The Sort Date of every Fact is omitted, but see Import GEDCOM File below.
  • All Citations linking a Source to a Source are omitted. [S27] to [S11]
  • The Repository of the first Source Record is omitted. [S1] & [R1]
  • In ƒh V5, the E-mail Message and Electronic Web Site URL are omitted from Source Records.
  • All links from any Place or Citation or Repository to their Multimedia are omitted.

Thus there will often be a different set of Facts and far fewer Citations in ƒh than in TMG. The above Tag Types are listed in TMG Tools > Master Events List and Tools > Master Tag Type List.

The Import from TMG – Missing Some Citations Forum thread has prototype Plugins that fix some problems.

Import GEDCOM File

First use the TMG File > Export > Gedcom (*.ged) option to export its database in a GEDCOM file format.

In the Wizard dialogue at Step 5: Option screen 1 set Version: to GEDCOM 5.5 from drop-list.

TMG does NOT appear to export any Witness associations into the GEDCOM file.

TMG does NOT export any sentence definitions associated with fact Tags.

Use File > Project Window and the New Project button, and select Import a GEDCOM file. The dialogue is uncomplicated, but in the Check for word-wrapping errors window, select Each row contains 1 word with a hyphen in the middle.

Import Fact Sort Dates for FH V5 & V6

Perform this step immediately after the New Project was created by the direct Import TMG Project method above in order to migrate all TMG Sort Dates into the ƒh Project. This process assumes that when creating the New Project you Use Default TMG Import Options.

In TMG use Tools > Master Tag Type List and for certain facts click the View button, and on its Other tab ensure GEDCOM export as: has Tag: set to EVEN. This applies to tags such as Address, Misc, New Para, Note, Research Notes & Telephone, but the Order Facts by Sort Date plugin will identify those that need changing. This allows such TMG facts to be matched against ƒh facts.

Then in TMG use File > Export > Gedcom (*.ged) to export its database in a GEDCOM file format.

In the Wizard dialogue at Step 5: Option screen 1 set Version: to GEDCOM 5.5, tick the Enhanced GEDCOM tag export option, and untick Suppress details for living people to include everyone. Then at Step 7: Option screen 3 ensure Place Levels has every item ticked that your project uses, such as Addressee, Detail, Postal Code & Phone, but NOT Commas When Missing. It may be necessary to create a new customised Export. DO NOT IMPORT this GEDCOM into ƒh.

Run the Order Facts by Sort Date plugin and choose the exported GEDCOM File to import its _SDATE Sort Dates into LMO Sort Dates for each fact.

Correcting Problems

Many of these issues only apply to a GEDCOM import, but some also apply to a direct import.

If Uncategorised Data Fields are reported then follow the advice for Handling Uncategorised Data Fields (UDF).

Any Multimedia record file Format fields with trailing space characters are treated as Other Multimedia that prevents images being displayed. These fields can be globally changed using the Search and Replace plugin and its Multimedia Format & Linked File fields option.

If a married Individual has no link to their Family, then in TMG ensure that the Marriage tag is ticked as Primary.

The UK variant of TMG offers special event tags such as Census 1841, Census 1851, etc, which when exported become GEDCOM Custom Events. To change these in TMG use Tools > Master Tag Type List, select the event tag name, click Edit and on the Other tab set GEDCOM export as Tag: CENS or whatever standard GEDCOM tag is appropriate. Alternatively, the Change Any Fact Tag plugin can be used in ƒh.

TMG formatting codes within Template Sentences and Memos will appear in ƒh Notes as plain text such as [BOLD:], [:BOLD], [UND:], [:UND], [ITAL:], [:ITAL], etc. They may be removed using the Search and Replace plugin in LUA Pattern Mode with Search string %[.-%] on Note fields only.

In Citations the five TMG Surety values become just one Assessment value. In TMG the five values relate to Principal-1, Principal-2, Date, Place, and Memo fields. To get nearer to those TMG values for different fields, the same Citation can be added to Fact Witnesses, and the Place and Note field of each Fact, and each Assessment can take a different value.

Quick Fix Plugins

The following Plugins have been found beneficial by users importing from TMG. They usually produce a Result Set of changed items, and double-clicking any item should open its Property Box for review. To cancel the Plugin changes, use Edit > Undo Plugin Updates before closing ƒh.

Move Death Event local Note to Cause field

Copy Death Note to Cause Plugin used in Forum thread TMG Import – Cause of Death​ Feb 2015.
If any Death local Note has more than one paragraph, then only the first is copied, and the whole Note retained.

Move Lat,Long in Place Name to Lat/Long field

Copy LatLong in Name to LatLong used in Forum thread TMG import following 6.0.2​ Feb 2015.

If after moving the Lat,Long value to the Lat/Long field, the Place name clashes with another Place record, then the Plugin attempts to Merge them. If unsuccessful, the Lat,Long value is retained in the Place name as listed in the Result Set, and the two records must be Merged by hand.

Import Relationship Citations

The Import from TMG – Missing Some Citations Forum thread has prototype Plugins that help with parent-child relationship citations not imported to ƒh.

Give Witnesses Their Own Facts

The Witnesses when entering Census data Forum thread discusses techniques for recording Census Events that are summarised in Recording Census Records. TMG typically uses one Census Event or one Census (family) Event with multiple Witnesses, whereas ƒh offers better support for multiple Census Events with a common Source Citation.

The Give Witnesses Their Own Facts plugin offers to convert multiple Census Witnesses to multiple Census Events. Then it splits each Census (family) Event into two Census Events.

Ensure you have a recovery backup, just in case the results are not as expected!

Import from The Next Generation (TNG)

Introduction

Importing from The Next Generation (TNG) to Family Historian (FH) is often quite straight forward but there are ongoing investigations for this product. It is possible to include the Media with the export.

See the Forum threads:

From TNG > FH5 > TNG​ May-July 2014
Details
Use the Export > Gedcom (*.ged) option to export the TNG database to a GEDCOM file format.

To include Media see the Export TNG Media As advice, and for selected Media Types set the Export Media Links to match the desired FH Project Media file paths as shown here.

Create New Project

Use File > Project Window and the New Project button, and select Import a GEDCOM file. The dialogue is uncomplicated, but in the Check for word-wrapping errors window, select Each row contains 1 word with a hyphen in the middle.

See Understanding Projects for more information on creating a Project from GEDCOM & media files, and using the Project Window.
Exception Report
Some TNG features do not export satisfactorily to GEDCOM format, and produce an Exception Report. These are still being investigated and include:

EXCLUDED: invalid line: 0 _PLAC ~ Place Map Latitude/Longitude custom records not supported by FH
EXCLUDED: invalid line: 1 SEX U ~ Satisfactorily handled by FH
INFO ONLY: Detected & fixed field format error (data moved to Note Field): ~ Invalid values added to Facts such as Immigration (IMMI), Baptism (BAPM), Residence (RESI), Census (CENS)
INFO ONLY: Loaded uncategorised data (non-GEDCOM): ~ Some of these Uncategorised Data Fields are caused by invalid multi-line text CONTinuation & CONCatenation tags, and others are custom tags that can be fixed by Handling Unrecognised Data Fields.
Eventually, some of the above should be fixed within TNG, and others may be corrected using a Plugin in FH.

Import from Generations Family Tree

Introduction

Generations was a popular Family History program, which has been discontinued and will not run on Windows 7 and above.

It’s GEDCOM file is a little “eccentric” and in order to import it there are several recommended actions.

There are however for ƒh V5 & V6 a selection of Plugins which can help you migrate your files with minimal loss of data.

If it all looks too daunting, then My History and Jane Taubman offer paid for services to convert your data to ƒh format.

Before Exporting

Where possible before exporting your file, go through any custom tags and make sure any ones with standard GEDCOM tags are defined as such, for example, all Census Facts should have a tag of CENS. Don’t worry if you can’t do them all, as you can convert many of them later as required (see Keeping Required Custom Tags and Notes below).

Export your Gedcom File from Generations

  • Open the file you’d like to export to GEDCOM in Generations Family Tree.
  • Click on the File menu and move your mouse cursor down to Import/Export or Export, depending on which version of Generations you have.
  • Click on GEDCOM File…
  • Make sure that:
    • The Who box is set to All Individuals
    • Include sources is checked
    • Destination is set to Other if that option is available. Otherwise, set Destination to GEDCOM 5.5.
    • GEDCOM Character Set is set to Windows
    • Click the Export… button
  • Decide on a location to store your GEDCOM file so that you can easily retrieve it again.
  • Type a file name next to where it says File name. An example file name would be MyData.ged
  • Click Save.
  • Your file has now been exported.

Fixing the Source Notes

Generations exports source text incorrectly, and this needs to be fixed before loading the file into ƒh.

  1. Download and install Generations Pre-Load Source Clean Plugin
  2. Open ƒh with the Family Historian Sample Project and run the Plugin selecting the file you exported above.
  3. A new file will be created in the same folder as your original file, prefixed with updated.

Create New Project in Family Historian

Use File > Project Window and the New Project button, and select Import a GEDCOM file. Browse to the updated copy of the GEDCOM file from above. Ensure Copy any linked multimedia files… is ticked and click Next >. Enter the New Project Name and click Finish.

The dialogue is uncomplicated, but in the Check for word-wrapping errors window, select Each row contains 2 words separated by a hyphen or let ƒh choose.

See Understanding Projects for more information on creating a Project from GEDCOM and Media files, and using the Project Window.

On the completion of the import an exception report will be created in Window > Log Files > Gedcom Report > View. Use Windows Notepad to search the report using the Find option for EXCLUDED. If you have any excluded lines, please post a question to the Forums with details.

At this stage do not worry about all the Unrecognised Data lines.

Inline Sources for Notes

These are not supported for ƒh, but you can keep the sources to the complete note, by changing the level of the Note field to 1 rather than 2. Ask in the Forums if unsure how to achieve this.

Cleaning up the Data

To correct any additional problems with Notes and Sources linked to them

  1. Download and Install Generations Post Edit plugin
  2. Run this to fix a selection of errors to do with Notes and Sources

Keeping Required Custom Tags and Notes

To deal with custom tags that you wish to keep the best solution is to use the Change Any Fact Tag plugin; please read the detailed help for this item.

Removing Unwanted Custom Tags and Notes

Finally download and use the plugin UDF List to clean up any remaining problem tags. See Handling Uncategorised Data Fields (UDF) for advice.

Clean Up Notes

Generations creates all notes as note records. If you would prefer to only have note records where they link to more than one record, download and run the Clean Up Notes plugin.

Last update: 13 May 2021

Related Content

Useful External Links

Family Tree Maker website
Downloading a Gedcom from Ancestry.co.uk online Help page.
Genbox
Family Search ~ Personal Ancestral File (PAF) discontinued in 2013. Download: FamilySearch Personal Ancestral File (PAF)
Import From PAF Plugin to help convert PAF Notes to Facts in Family Historian, and fix _UID UDF, _AKA UDF, and Date Phrases.
Roots Magic Website

Related Forum Discussions

FTM Import forum threads

Ancestry Import forum threads

Legacy Family Tree Import forum threads

TMG Import forum threads