* Problem installing FH5 on a Mac under Crossover

Questions regarding use of any Version of Family Historian. Please ensure you have set your Version of Family Historian in your Profile
Post Reply
avatar
cbuckthorp
Gold
Posts: 21
Joined: 22 Jan 2007 11:22
Family Historian: V6
Location: East Sussex

Problem installing FH5 on a Mac under Crossover

Post by cbuckthorp » 04 Jan 2015 22:17

Have been been running FH v 5.9 on my 15" late 2008 Macbook Pro (OSX 10.7.5) using Parallels v7 with Windows XP Home. Have tried to install under Crossover. Followed the procedure on the FHUG. Downloaded 14 day trial Crossover version 14.0.3 and installed FH v5 into a new Win XP bottle using my original downloaded purchased copy adding my license number which was stored. The installed applications in the Family Historian bottle created are Crossover HTML engine, Family Historian v5, Family Historian pdf (have not yet deleted per FHUG recommendation), Microsoft Rich Edit 2, Microsoft Rich Edit 4.1 (Msftedit.dll), MicrosoftVisual C++ 2010, Microsoft Visual FoxPro OLE DB Provider, msls31, Uniscribe and Wine Gecko (32-bit).

All seems to have installed OK but when I try to run FH, the program attempts to launch (I see the opening FH screen initially) but get error message "Error: Access violation at 0x92CD0CC5 (tried to read from 0x01400000), program terminated"

I also downloaded Windows Script 5.7 although this has installed in a separate XP bottle but my understanding is this can affect plugins but should not affect base program launch? But should this have been installed in the Family Historian bottle?

The Mac is 64 bit machine although I believe the XP bottle is 32-bit only. Might this have a bearing? (It wasn't an issue running an XP Home virtual machine under Parallels).

Any help much appreciated. I'd like to ditch Parallels if at all possible.

Happy New Year to all
best regards
Colin Buckthorp
Colin Buckthorp
Researching Buckthorp(e), Buckthought, Tregaskis, Squires, Cosier

User avatar
tatewise
Megastar
Posts: 16459
Joined: 25 May 2010 11:00
Family Historian: V6.2
Location: Torbay, Devon, UK
Contact:

Re: Problem installing FH5 on a Mac under Crossover

Post by tatewise » 04 Jan 2015 22:40

I have moved this to General Usage for FH which is more appropriate.

When you installed FH exactly what version did you install?
I suspect it would be Upgrade V4 to V5.0.1 or Full V5.0.1.

Did you "When installing FH, disable Create a desktop icon & disable Launch Family Historian."

Then did you upgrade to the FH V5.0.9 free downoad?
Or perhaps another free download?

Hopefully, Colin Valkrider will see this and apply his expert eye.
Mike Tate ~ researching the Tate and Scott family history ~ tatewise ancestry

avatar
cbuckthorp
Gold
Posts: 21
Joined: 22 Jan 2007 11:22
Family Historian: V6
Location: East Sussex

Re: Problem installing FH5 on a Mac under Crossover

Post by cbuckthorp » 04 Jan 2015 23:10

Mike, it was a full version of 5.01. Initially I had also loaded the subsequent upgrade to 5.9 but I got the error message then so I deleted that bottle and reinstalled to a new bottle limiting the initial installation to the original purchased full version only but of course got same error message. Yes I had disabled desktop icon and launch family historian per the forum advice.
thanks Colin Buckthorp
Colin Buckthorp
Researching Buckthorp(e), Buckthought, Tregaskis, Squires, Cosier

User avatar
Valkrider
Megastar
Posts: 1064
Joined: 04 Jun 2012 19:03
Family Historian: V6.2
Location: Spain
Contact:

Re: Problem installing FH5 on a Mac under Crossover

Post by Valkrider » 05 Jan 2015 08:05

Colin

Crossover has changed slightly in this latest version.

I suggest you start again with a new XP bottle. Install FH don't upgrade it. Don't run the bottle. Right click on the bottle and select 'Install software into....' option. Then one at a time add the additional programmes mentioned in the Knowledgebase Windows Script 5.7 is in the Community Supported Applications list in the W's

Once you have the additional programmes installed you can then run the bottle. If everything is working OK then do the FH upgrade.

I found yesterday that it is often easier to delete a bottle and start again rather than to try and get it functioning if you don't have it right to start with.

avatar
cbuckthorp
Gold
Posts: 21
Joined: 22 Jan 2007 11:22
Family Historian: V6
Location: East Sussex

Re: Problem installing FH5 on a Mac under Crossover

Post by cbuckthorp » 05 Jan 2015 10:57

Hi Valkrider, thanks yr prompt response. What you suggest is actually what I did. Deleted the initial bottle with the upgrade that I first tried and just installed FH v5.0. Nothing else. The various crossover files listed above loaded automatically. Added nothing else.

Just to be sure I have done again. Deleted the FamilyHistorian bottle and started over. Selected to use my local copy of FH5.0, used FH's default path (C:Program Files/Family Historian) for installed location and unticked Desktop Icon and Run Family Historian. Nothing else is loaded. Files in the bottle are as my original post. Still get same error. Am I missing something?

Sorry but could you also clarify for me your Windows Script 5.7 comment. Not clear where this is/should be. Crossover has installed in a newly created Applications folder in Users. This folder contains the Crossover. app file and a Windows XP applications .app file as well as a Crossover sub-folder which has a subfolder Family Historian in which are the various app files seen in the bottle viz: Family Historian, Family Historian help, Readme, Uninstall FH and Getting Started with FH5.

Apologies if I'm missing something obvious.
Thanks again
Colin Buckthorp
Colin Buckthorp
Researching Buckthorp(e), Buckthought, Tregaskis, Squires, Cosier

User avatar
Valkrider
Megastar
Posts: 1064
Joined: 04 Jun 2012 19:03
Family Historian: V6.2
Location: Spain
Contact:

Re: Problem installing FH5 on a Mac under Crossover

Post by Valkrider » 05 Jan 2015 14:19

Colin

You have missed something I think. Have you read the Knowledgebase article? See http://www.fhug.org.uk/wiki/doku.php?id ... sover_wine.

You do need to install Windows Script 5.7. See the screenshot and then follow the instructions in my earlier post
Screen Shot 2015-01-05 at 3.17.18 PM.png
Screen Shot 2015-01-05 at 3.17.18 PM.png (155.23 KiB) Viewed 4077 times
I use the Crossover default paths and just accept the default options during the install.

User avatar
tatewise
Megastar
Posts: 16459
Joined: 25 May 2010 11:00
Family Historian: V6.2
Location: Torbay, Devon, UK
Contact:

Re: Problem installing FH5 on a Mac under Crossover

Post by tatewise » 05 Jan 2015 14:43

Colin, as we just confirmed in V6 and Crossover MAC (11920), Windows Script 5.7 is needed to run Plugins that use batch commands, but not needed to run FH (or AS).
Mike Tate ~ researching the Tate and Scott family history ~ tatewise ancestry

User avatar
Valkrider
Megastar
Posts: 1064
Joined: 04 Jun 2012 19:03
Family Historian: V6.2
Location: Spain
Contact:

Re: Problem installing FH5 on a Mac under Crossover

Post by Valkrider » 05 Jan 2015 15:08

Mike

My memory isn't great but I thought I had to add it to even get FH5 running but it was some time ago so I could well be wrong. I know I had to add something and thought it was that. It is a b....r getting old ;) I will have a root through the old FH5 bottle and see if I can find what it was.

User avatar
tatewise
Megastar
Posts: 16459
Joined: 25 May 2010 11:00
Family Historian: V6.2
Location: Torbay, Devon, UK
Contact:

Re: Problem installing FH5 on a Mac under Crossover

Post by tatewise » 05 Jan 2015 15:43

Is it worth starting from scratch with a new latest Crossover Win XP bottle, and following the KB instructions to see what happens?
Mike Tate ~ researching the Tate and Scott family history ~ tatewise ancestry

avatar
cbuckthorp
Gold
Posts: 21
Joined: 22 Jan 2007 11:22
Family Historian: V6
Location: East Sussex

Re: Problem installing FH5 on a Mac under Crossover

Post by cbuckthorp » 05 Jan 2015 19:19

Mike, appreciate the suggestion but I tried this also. In thought case the Parallels and Win XP installations might have interfered in some way I downloaded another trial of Crossover on my iMac (OSX v 10.7.5 same as the Macbook Pro) which has never run these softwares. The same Crossover version 14.0.3 installed. Followed the KB instructions selecting Family Historian from the unsupported applications list, selected my FH installation file (install_fh5.0.0_dl.exe) and a new XP bottle with the default name Family Historian. Added nothing else and for the install unticked Create Desktop Icon and unticked Run FH as before. The only difference I could see was that the Crossover app itself installed in my default Applications folder while the windows installations installed in a new Applications folder created in my Users directory. (On the Macbook both the app itself and the win installs installed in the same new Users/Applications/ folder). A host of windows related files install in a new folder Crossover in the my Users/Colin/Library/Applications Support directory. They appear much the same on both computers (a lot of files so haven't checked rigorously). When I tried to run FH was prompted for FH trial or license details as before and I added. My license information was verified and stored. FH tried to run. First time it just hung at the FH opening screen and I had to force quit. Second attempt gave the same error message as my Macbook and quit. In the dock you see the FH icon appear twice , one for FH app and one for the Wineloader. It seems the latter is failing to complete.

I also used the KB Crossover Tie link to get Windows Script 5.7 after I had installed FH. I clicked the Windows Script 5.7 available from the link. I got a screen advising Crossover is a 14 day trial. I clicked the only option to proceed (I think it was 'done') and was presented with the Crossover Windows Install screen. I selected to install into the Family Historian XP bottle rather than a new XP bottle. The install appeared to run but I can find nothing listed differently in the Family Historian bottle to show its there nor anywhere else for that matter. I haven't found an option to follow the procedure advised by Valkrider from the Crossover pull down menus.

I'm sorry this adds nothing positive other than to eliminate a particular computer setting. I'll double check my install download has not got corrupted in some way by running it on an old windows laptop. I can also try my FH 4 disc as an alternative install source.

thanks again
Colin
Colin Buckthorp
Researching Buckthorp(e), Buckthought, Tregaskis, Squires, Cosier

User avatar
tatewise
Megastar
Posts: 16459
Joined: 25 May 2010 11:00
Family Historian: V6.2
Location: Torbay, Devon, UK
Contact:

Re: Problem installing FH5 on a Mac under Crossover

Post by tatewise » 05 Jan 2015 20:06

With two Colin's it's tricky, but my suggestion to start from scratch was aimed at Colin Valkrider, because I don't think he has installed FH V5 in Crossover V14, although FH V6 has recently installed OK, albeit in a Win 7 bottle. But apparently the Win XP and Win 7 bottles differ by little more than their name.

It is simply that FH V5 didn't like Win 7 when last tried, and FH V6 won't install in Win XP. However, you could try FH V5 in a Win 7 bottle, and maybe with the later Crossover it will be OK.
Mike Tate ~ researching the Tate and Scott family history ~ tatewise ancestry

avatar
cbuckthorp
Gold
Posts: 21
Joined: 22 Jan 2007 11:22
Family Historian: V6
Location: East Sussex

Re: Problem installing FH5 on a Mac under Crossover

Post by cbuckthorp » 05 Jan 2015 20:19

Aaah - hadn't appreciated the two Colin's :-)

Actually my eventual objective is to run FH v6 anyway. I can't do this now on my Mac's without dumping XP and buying Win 7 or 8 software. I also want to upgrade my Mac OSX - at least to Mavericks - but that needs a new Parallels upgrade as well. Hence the driver to get FH working under Crossover. If I was sure FH6 would work with Crossover (and looks as though Valkrider's getting there) I don't need to persevere with this v5 option. I'll happily buy a new complete install of V6 if I know I can install it on my Mac's under Crossover.

best
Colin Buckthorp
Colin Buckthorp
Researching Buckthorp(e), Buckthought, Tregaskis, Squires, Cosier

User avatar
tatewise
Megastar
Posts: 16459
Joined: 25 May 2010 11:00
Family Historian: V6.2
Location: Torbay, Devon, UK
Contact:

Re: Problem installing FH5 on a Mac under Crossover

Post by tatewise » 05 Jan 2015 21:00

You could always try the FH V6 Free Trial in a Crossover Win 7 bottle!
Mike Tate ~ researching the Tate and Scott family history ~ tatewise ancestry

avatar
cbuckthorp
Gold
Posts: 21
Joined: 22 Jan 2007 11:22
Family Historian: V6
Location: East Sussex

Re: Problem installing FH5 on a Mac under Crossover

Post by cbuckthorp » 05 Jan 2015 22:35

Well Mike, that works! I haven't checked all functionality within FH of course but downloaded the v6.0.0 installer 30 day trial to my iMac and installed into a Win 7 bottle named Family Historian v6 deselecting desktop icon, internet matches (probably not necessary but I can enable later within FH) and Run FH. As reported elsewhere Crossover warns that the Win 7 bottle is not suitable for Family Historian (thinks its an XP program) and while running the install says there's an install problem but I selected Skip This Step and the installation completed OK.

Double clicking the app in my FH6 Win 7 bottle opened Family Historian immediately. I had to redirect FH Projects to the Projects folder on my iMac. My Buckthorp Family file looks OK. All the multimedia appear to be there. I'll have to reconfigure preferred column arrangements on the individuals page and no doubt other tinkering but the gedcom runs and the data appears complete.

I'll follow up reading the posts on Valkriders 'V6 and Crossover MAC' on the FHUG forum regarding the unresolved issues in progress but based on this initial success looks like the way to go.

Thanks a lot for your helpful suggestions
best regards
Colin Buckthorp
Colin Buckthorp
Researching Buckthorp(e), Buckthought, Tregaskis, Squires, Cosier

avatar
cbuckthorp
Gold
Posts: 21
Joined: 22 Jan 2007 11:22
Family Historian: V6
Location: East Sussex

Re: Problem installing FH5 on a Mac under Crossover

Post by cbuckthorp » 05 Jan 2015 22:57

Quick follow up. Installation has worked also on the Macbook Pro. Interestingly this installation found my Project File automatically.
Colin Buckthorp
Researching Buckthorp(e), Buckthought, Tregaskis, Squires, Cosier

User avatar
Valkrider
Megastar
Posts: 1064
Joined: 04 Jun 2012 19:03
Family Historian: V6.2
Location: Spain
Contact:

Re: Problem installing FH5 on a Mac under Crossover

Post by Valkrider » 06 Jan 2015 08:02

Mike

Reading this it looks as though the latest version of Crossover, 14.0.3, requires a Win7 bottle for FH5. My original Crossover install for FH5 was in Crossover v13. Once I am happy with FH6 under Crossover 14 I will try a new FH5 on Win7 bottle and see where we go from there.

avatar
cbuckthorp
Gold
Posts: 21
Joined: 22 Jan 2007 11:22
Family Historian: V6
Location: East Sussex

Re: Problem installing FH5 on a Mac under Crossover

Post by cbuckthorp » 06 Jan 2015 10:10

Hi Colin V,
I just tried to install v5.0 into a new win 7 bottle called Family Historian v5 following all the usual deselection options but I got the same old error message as with Win XP. I got the initial message that the Win 7 bottle is incompatible but unlike installing version 6 I did not get the second screen after hitting finish in the FH install that flagged a possible problem but allowed me to Skip the step and continue to a (successful) install.

best
Colin B
Colin Buckthorp
Researching Buckthorp(e), Buckthought, Tregaskis, Squires, Cosier

User avatar
tatewise
Megastar
Posts: 16459
Joined: 25 May 2010 11:00
Family Historian: V6.2
Location: Torbay, Devon, UK
Contact:

Re: Problem installing FH5 on a Mac under Crossover

Post by tatewise » 06 Jan 2015 11:21

Looks like Code Weavers have changed something in Crossover between V13 and V14 that inhibits FH V5 installation.
What is their support position in this situation?
Do they say that is just unfortunate for unsupported programs, or will they help resolve the problem?
Mike Tate ~ researching the Tate and Scott family history ~ tatewise ancestry

User avatar
Valkrider
Megastar
Posts: 1064
Joined: 04 Jun 2012 19:03
Family Historian: V6.2
Location: Spain
Contact:

Re: Problem installing FH5 on a Mac under Crossover

Post by Valkrider » 06 Jan 2015 11:34

Mike

Very limited as it is unsupported. I don't intend to do much more with FH5 as it isn't the current version of FH. Those people on a Mac already seem to be fine and any new ones will be buying FH6 anyway.

avatar
cbuckthorp
Gold
Posts: 21
Joined: 22 Jan 2007 11:22
Family Historian: V6
Location: East Sussex

Re: Problem installing FH5 on a Mac under Crossover

Post by cbuckthorp » 06 Jan 2015 12:59

I agree with Colin V. Given the new features of V6 (worth buying) and the need to buy Win 7 to replace XP if you are going to otherwise run V6 under the Parallels it seems a no brainer. Better to invest the effort in trying to fix the V6 issues. Otherwise stay with V5 or less under something like Parallels or VM Fusion.

BTW I did check my v5 install program was not the problem and loaded it on an old XP machine. It installed fine. I noted that the Crossover install fails early on in the Wineloader program as it's before the language option (US or UK English) appears but after the prompt for trial or key.

rgds
Colin B
Colin Buckthorp
Researching Buckthorp(e), Buckthought, Tregaskis, Squires, Cosier

Post Reply