* Linking Spouse Deletes Individual !

Homeless Posts from the old forum system
Locked
User avatar
tatewise
Megastar
Posts: 24181
Joined: 25 May 2010 11:00
Family Historian: V7
Location: Torbay, Devon, UK
Contact:

Linking Spouse Deletes Individual !

Post by tatewise » 29 Jun 2012 19:45

This is a problem associated with same sex partnerships/marriages.

Start with a Spouse Family couple who are both Female.
From a Male Individual Property Box on a blank Spouse tab, click Add Spouse/Partner link.
Select Link Existing Record and choose either Female Individual of the Spouse Family couple.
In the Specify Family for Spouse window, select the Female couple and click OK.

The previously chosen Female Individual record is DELETED without warning, along with the associated Family Record!!!
This deletion CANNOT be restored with Edit > Undo.

The same problem exists with a Spouse Family couple who are both Male, when a Female attempts to marry one of them.

ID:6348

User avatar
SimonOrde
Program Designer
Posts: 347
Joined: 18 Nov 2002 10:20
Family Historian: V7
Location: Calico Pie

Linking Spouse Deletes Individual !

Post by SimonOrde » 02 Jul 2012 10:27

Mike - thank you for pointing this out.  You're quite right.  We'll get a fix for it out shortly.

User avatar
tatewise
Megastar
Posts: 24181
Joined: 25 May 2010 11:00
Family Historian: V7
Location: Torbay, Devon, UK
Contact:

Linking Spouse Deletes Individual !

Post by tatewise » 14 Jul 2012 17:13

This problem is fixed in FH V5.0.7.

Locked