* Problem Installing AS v7 with Crossover

AS allows faster and more convenient creation of source records for Family Historian.
Post Reply
avatar
cbuckthorp
Gold
Posts: 25
Joined: 22 Jan 2007 11:22
Family Historian: V6
Location: East Sussex

Problem Installing AS v7 with Crossover

Post by cbuckthorp » 02 Aug 2021 17:20

It's been a long while since I've visited the forum. I'm reinstalling FH and AS on a new 24" iMac (Apple M1 chip) running Big Sur v11.5.1 . FH v6 appears to have installed OK into a Windows 7 bottle (Crossover's only selected compatible bottle - other incompatibles inc Win 8 showing) but having a problem installing AS. Started with AS v7 first adding MS .NET Framework 4.8 into the FH6 bottle. Says 'Setup may not run properly because the Windows Modules Installer Service not available...'. Continued with installation anyway and then proceeded with the AncestralSources 64bit_7_.2_7. The installation appeared to complete but there is no icon for AS appearing in the bottle and the plugin does not show in FH. Can anybody suggest a solution please? I assume the .Net Framework 4.8 did not install properly.

Meantime I tried installing the AS v5 download available within Crossover as this only needs MS .NET Framework 3.5 which I had already installed but this was rejected because it's a 32 bit version. Big Sur will only accept 64 bit apps. Does anybody know of a 64 bit option available for download anywhere? I couldn't find anything?

Grateful if anybody can offer any advice on how best to get AS installed.
thanks
Colin Buckthorp
Colin Buckthorp
Researching Buckthorp(e), Buckthought, Tregaskis, Squires, Cosier

User avatar
tatewise
Megastar
Posts: 24181
Joined: 25 May 2010 11:00
Family Historian: V7
Location: Torbay, Devon, UK
Contact:

Re: Problem Installing AS v7 with Crossover

Post by tatewise » 02 Aug 2021 17:50

I'm no Crossover expert but some things you said need a comment.
If Big Sur will only accept 64-bit apps, how did you install FH v6 which is only a 32-bit app?
You said "the plugin does not show in FH" but unless you have downloaded the 'Ancestral Sources Data Entry' plugin from the FH Plugin Store then it will not show in Tools > Plugins. The FH Plugin is quite distinct from the AS app.
I'm sure a Crossover expert will answer your other questions.

Check the KB Running Family Historian on Crossover advice.
There it says ensure the Win7 bottle is the 64-bit variant.
Mike Tate ~ researching the Tate and Scott family history ~ tatewise ancestry

User avatar
mjashby
Megastar
Posts: 661
Joined: 23 Oct 2004 10:45
Family Historian: V7
Location: Yorkshire

Re: Problem Installing AS v7 with Crossover

Post by mjashby » 02 Aug 2021 19:45

Colin,

You can install 32-bit Windows apps normally using Crossover providing you use a 32-bit Bottle. Installing FH is proof of that as it only comes as 32-bit. However, 32-bit FH will also install fine in a 64-bit Bottle if you choose to go that way; and you can then use the 64-bit Version of AS if you want keep both applications together (which saves a considerable amount of disk space). The non-technical explanation is that Crossover is programmed to 'hide' the fact that apps are 32-bit from MacOS to enable them to be run.

The most likely issue is that you missed the option to tell Crossover to create a Desktop Shortcut when you installed Ancestral Sources. To test this out, launch the 'Run Command' icon in the Bottle you created and use the pop-up GUI to navigate to and select the Ancestral Sources.exe file in the Bottle, select it to complete the Run command. Make sure "the "Save Command as Launcher" is also highlighted at the bottom of the Run Command screen. Then Choose 'Run'

I've run through the above procedure from memory, so if anything is unclear/doesn't seem to work, post back and I'll do another run-through/Screenshot(s).

Mervyn

avatar
cbuckthorp
Gold
Posts: 25
Joined: 22 Jan 2007 11:22
Family Historian: V6
Location: East Sussex

Re: Problem Installing AS v7 with Crossover

Post by cbuckthorp » 02 Aug 2021 20:52

Mike, thanks for this. I had mistakenly thought v6 was available in both 32 & 64 bit. My error which has led me up the garden path. Thanks for the correction. Regarding Big Sur my remark was also misleading. On an intel MacBook Pro I have 32 bit programs running with big sur. It's my understanding that it will only run 64 bit applications on the new Mac M1 chip. Perhaps the 64 bit Crossover v20 facilitates the operation. Apple include Rosetta to translate intel to the M1 Silicon.

I had been working off the KB article you advised but was confused when Crossover did not offer a compatible Window 7 64 bit. It now makes sense why Crossover only offered a single Windows 7 compatible Bottle if FH6 was only 32 bit in the first instance!

Getting back to AS. I have now imported the lua download into FH from the plugin screen. I then went to install a version of AS in the FH6 bottle. The plugin recommends I install AS v7 but I can't do this until I get the .NET Framework issue sorted.

There is an option in Crossover to download version 5 but the download fails with a Crossover message screen saying the download file '.. is of an unknown installer type for Ancestral Sources 5. Continuing with the install may produce unpredictable results.' However it gives no option to implement the install - I can cancel, skip the step (the download) or try again , the latter just repeating the process.

So finally, for the time being, I have fallen back to an earlier AS version 4.5. I have both 32 and 64 bit executables. I tried the 64 bit bit it didn't like that warning that it requires a 64 bit version of windows and it didn't install - of course because I installed just the 32 bit Windows bottle for FH 6. But it did install the 32 bit version with no difficulty and runs fine. The plugin prompts me to download V7 update which I'll do when I can install .NET Framework 4.8. Hopefully somebody may have some thoughts in that respect🤞.

Thanks your prompt helpful response that pointed me in the right direction.
best
Colin
Colin Buckthorp
Researching Buckthorp(e), Buckthought, Tregaskis, Squires, Cosier

avatar
cbuckthorp
Gold
Posts: 25
Joined: 22 Jan 2007 11:22
Family Historian: V6
Location: East Sussex

Re: Problem Installing AS v7 with Crossover

Post by cbuckthorp » 02 Aug 2021 21:11

Thanks Mervyn. You are right I recall I had not selected the desktop icon deliberately. Thought it should be as per FH. I will create a new 64 bit bottle and try the installation again. Maybe not the .NET Framework upgrade issue? It's late now. Will do tomorrow and let you know.
thanks again
Colin
Colin Buckthorp
Researching Buckthorp(e), Buckthought, Tregaskis, Squires, Cosier

avatar
cbuckthorp
Gold
Posts: 25
Joined: 22 Jan 2007 11:22
Family Historian: V6
Location: East Sussex

Re: Problem Installing AS v7 with Crossover

Post by cbuckthorp » 03 Aug 2021 20:16

Mervyn,
many thanks. Confirm your diagnosis correct. I created a new 64 bit Win 7 bottle, installed FH v6, MS .NET Framework 4.8 and latest AS v7 directly and all boots up fine. Still getting a Windows Script 5.7 task failed message saying installer has exited but Win Script 5.7 does not appear to have installed. I also got the same warning message I had previously installing .NET Framework 4.8 but again installation appears to have proceeded and AS v7 loads up ok from the tools/plugins menu.

Thanks again
Colin
Colin Buckthorp
Researching Buckthorp(e), Buckthought, Tregaskis, Squires, Cosier

Post Reply