* AS 7 installation on Parallels Win 10 VM

AS allows faster and more convenient creation of source records for Family Historian.
Post Reply
avatar
TotleyRover
Gold
Posts: 12
Joined: 30 May 2021 09:49
Family Historian: V7
Location: Dorset England

AS 7 installation on Parallels Win 10 VM

Post by TotleyRover » 07 Jul 2021 13:49

Hello,
My hardware is an Apple Mac Book Pro M1 laptop, running macOS Big Sur.

I have installed Parallels on this laptop and created a VM with a Windows 10 ARM beta release.

FH7 installs and runs on this Windows 10 installation.

But, attempting to install ASv7 on this same Windows 10 installation, resulting in an error dialogue.
Is this to be expected?

Perhaps I am expecting too much of ASv7; it is, as far as I am aware, a free app designed solely for use with FH7.

I await with interest any comments the developer(s) of ASv7 wish to make.

My thanks in advance.
Attachments
Screenshot 2021-07-07 at 14.44.25.png
Screenshot 2021-07-07 at 14.44.25.png (109.01 KiB) Viewed 2163 times

User avatar
Jane
Site Admin
Posts: 8340
Joined: 01 Nov 2002 15:00
Family Historian: V7
Location: Somerset, England
Contact:

Re: AS 7 installation on Parallels Win 10 VM

Post by Jane » 07 Jul 2021 13:58

According to the documentation I have found the current Beta does not support 64bit apps.

https://www.theverge.com/22383598/paral ... m1-macbook

Have you tried using the 32bit version of AS?
Jane
My Family History : My Photography "Knowledge is knowing that a tomato is a fruit. Wisdom is not putting it in a fruit salad."

avatar
TotleyRover
Gold
Posts: 12
Joined: 30 May 2021 09:49
Family Historian: V7
Location: Dorset England

Re: AS 7 installation on Parallels Win 10 VM

Post by TotleyRover » 07 Jul 2021 14:08

The development of the ARM version of Win 10 has moved on somewhat since that article was posted.

I've attempted to install ASv7 32bit.
The error dialogue is practically the same.
Attachments
Screenshot 2021-07-07 at 15.07.50.png
Screenshot 2021-07-07 at 15.07.50.png (193.69 KiB) Viewed 2158 times
Screenshot 2021-07-07 at 15.00.43.png
Screenshot 2021-07-07 at 15.00.43.png (64.73 KiB) Viewed 2158 times

User avatar
mjashby
Megastar
Posts: 664
Joined: 23 Oct 2004 10:45
Family Historian: V7
Location: Yorkshire

Re: AS 7 installation on Parallels Win 10 VM

Post by mjashby » 07 Jul 2021 16:27

The problem might possibly connected to the .Net Framework 4.8 requirement to install/run AS 7.x and so it might be worthwhile asking Parallels whether or not there are any known issues installing x32/x64 software with specific .Net Framework requirements, as it is in their financial interest to ensure as much Windows software as possible can install and work effectively.

I have no idea what the current status of Windows 10 ARM for Mac/Parallels is, especially as Parallels developers will have to make specific provisions for proprietary Mac M1 (and rumoured M1x and M2) processors and hardware.

Unfortunately, for now, what you are trying to do is install/run a 'stable' version of x32/x64 software (Ancestral Sources) on a beta version of Windows 10 ARM, running on a beta virtualisation product (Parallels for Apple M1), on a relatively new hardware platform whose developer (Apple) has openly stated it no longer has any direct interest in producing systems capable of supporting virtualisation products or other operating systems beyond MacOS/iOS.

Mervyn

User avatar
NickWalker
Megastar
Posts: 1705
Joined: 02 Jan 2004 17:39
Family Historian: V7
Location: Lancashire, UK
Contact:

Re: AS 7 installation on Parallels Win 10 VM

Post by NickWalker » 07 Jul 2021 18:20

I think this might be the setup application I use refusing to install it rather than AS itself. I've not had time to look at this and of course I have no way to test it anyway but this article I just found with responses from the inno setup developer looks relevant: https://groups.google.com/g/innosetup/c/_k3ddQ2CV8E
Nick Walker
Ancestral Sources Developer

http://www.ancestralsources.com

avatar
TotleyRover
Gold
Posts: 12
Joined: 30 May 2021 09:49
Family Historian: V7
Location: Dorset England

Re: AS 7 installation on Parallels Win 10 VM

Post by TotleyRover » 08 Jul 2021 10:49

Nick,
"I think this might be the setup application I use refusing to install it rather than AS itself. "

I had similar thoughts when the dialogue popped up.

As I am probably ahead of the curve with my choice of technology, I cannot expect a fix applied in the future.

AS is a Free/donation app.
It will have to run on a beta release of Windows 10.

IMO it would ask a lot of the developer(s) of AS putting in the work for a small number of users.



Can I leave it with you as to the way ahead on this issue?

Best regards
Gordon

User avatar
sgauntlett
Platinum
Posts: 38
Joined: 02 May 2006 09:23
Family Historian: V7

Re: AS 7 installation on Parallels Win 10 VM

Post by sgauntlett » 25 May 2022 15:00

Thanks for this thread. I have also just upgraded my iMac to an M1 based product. Using parallels and Windows 11 VM I was able to install FH 7 but I can't install AS due to the installation error.
Guess I'm adding sources manually for a while. ;)

User avatar
tatewise
Megastar
Posts: 24402
Joined: 25 May 2010 11:00
Family Historian: V7
Location: Torbay, Devon, UK
Contact:

Re: AS 7 installation on Parallels Win 10 VM

Post by tatewise » 25 May 2022 15:55

Have you tried both the 32-bit and 64-bit versions of AS?
Mike Tate ~ researching the Tate and Scott family history ~ tatewise ancestry

User avatar
NickWalker
Megastar
Posts: 1705
Joined: 02 Jan 2004 17:39
Family Historian: V7
Location: Lancashire, UK
Contact:

Re: AS 7 installation on Parallels Win 10 VM

Post by NickWalker » 25 May 2022 18:01

If you're trying to run AS under the Arm version of Windows (in VM or otherwise), would you mind trying this new version v7.4.2 to see if it installs?

64 bit version: Ancestral Sources v7.4.2 64 Bit
32 bit version: Ancestral Sources v7.4.2 32 Bit

For anyone interested, v7.4.2 just has a change to the installer that I've made to see if it will stop blocking installation on Windows on Arm and it also fixes a very very very minor issue reported here
Nick Walker
Ancestral Sources Developer

http://www.ancestralsources.com

User avatar
sgauntlett
Platinum
Posts: 38
Joined: 02 May 2006 09:23
Family Historian: V7

Re: AS 7 installation on Parallels Win 10 VM

Post by sgauntlett » 25 May 2022 20:44

Hi Nick,
Yes - to confirm, I am running the ARM developer version of Windows 11 Pro, using Parallels Desktop 17 on an M1 iMac.

I tried the new versions of the install files v7.4.2.

The 64 bit install ran but when it finished, and tried to run the application, it came up with an error message saying "Unable to execute file" CreateProcess failed; code 2

I then tried the 32 bit install and that ran and then the application launched successfully!

Odd, as I thought everything was 64-bit with Windows 11 but it seems to work. I've not tested many functions yet but the FH project loads successfully too.

Thank you

User avatar
NickWalker
Megastar
Posts: 1705
Joined: 02 Jan 2004 17:39
Family Historian: V7
Location: Lancashire, UK
Contact:

Re: AS 7 installation on Parallels Win 10 VM

Post by NickWalker » 25 May 2022 21:07

Thanks for the feedback. I've just updated the installer for the 64 bit version again to see if this fixes the 'unable to execute ' error. I've updated the link in my previous post too but this is it:

64 bit version: Ancestral Sources v7.4.2 64 Bit

I'd be grateful if you could try that for me and see if it now installs.

Cheers

Nick
Nick Walker
Ancestral Sources Developer

http://www.ancestralsources.com

User avatar
sgauntlett
Platinum
Posts: 38
Joined: 02 May 2006 09:23
Family Historian: V7

Re: AS 7 installation on Parallels Win 10 VM

Post by sgauntlett » 25 May 2022 21:45

Yes - I uninstalled the 32 bit version and ran the new 64-bit installer and it installed and ran the application correctly.

Thanks,
Simon

User avatar
NickWalker
Megastar
Posts: 1705
Joined: 02 Jan 2004 17:39
Family Historian: V7
Location: Lancashire, UK
Contact:

Re: AS 7 installation on Parallels Win 10 VM

Post by NickWalker » 26 May 2022 07:13

sgauntlett wrote:
25 May 2022 21:45
Yes - I uninstalled the 32 bit version and ran the new 64-bit installer and it installed and ran the application correctly.

Thanks,
Simon
That's great, thanks for the feedback.
Nick Walker
Ancestral Sources Developer

http://www.ancestralsources.com

Post Reply