* Image Thumbnail

AS allows faster and more convenient creation of source records for Family Historian.
Post Reply
avatar
andrewbraid
Famous
Posts: 122
Joined: 30 Jul 2005 09:18
Family Historian: V7
Location: Leeds, Yorkshire

Image Thumbnail

Post by andrewbraid » 25 May 2022 07:03

I have noticed, especially with the US 1950 census, that the thumbnail of the image does not always appear in the linked images after linking. (I used to check that it was there in FH after saving but it always was so I've stopped checking now.)
Is it just me or have others seen the same?
Andrew Braid

User avatar
NickWalker
Megastar
Posts: 1705
Joined: 02 Jan 2004 17:39
Family Historian: V7
Location: Lancashire, UK
Contact:

Re: Image Thumbnail

Post by NickWalker » 25 May 2022 07:44

Hi Andrew

Where exactly are they not appearing? Do you mean at the top of the image viewer form in Ancestral Sources?

Are you running the latest version of AS (7.4).

Nick
Nick Walker
Ancestral Sources Developer

http://www.ancestralsources.com

avatar
andrewbraid
Famous
Posts: 122
Joined: 30 Jul 2005 09:18
Family Historian: V7
Location: Leeds, Yorkshire

Re: Image Thumbnail

Post by andrewbraid » 25 May 2022 08:04

Nick

Yes I've updated to the latest version but I think it's done it ever since I started using the US 1950 census was that 7.2?

It's in the box where it there is a link to add images and the thumbnail always used to appear on the left hand side of it after adding.
Andrew Braid

User avatar
johnmorrisoniom
Megastar
Posts: 836
Joined: 18 Dec 2008 07:40
Family Historian: V7
Location: Isle of Man

Re: Image Thumbnail

Post by johnmorrisoniom » 25 May 2022 08:12

I have noticed this on the occasional UK census (usually 1911 but not certain). The thumbnail is there, but it is not visible.

It is not a problem with the latest version, it has happened for a long time, I have not been able to tie down what the cause is to report it.

John

User avatar
NickWalker
Megastar
Posts: 1705
Joined: 02 Jan 2004 17:39
Family Historian: V7
Location: Lancashire, UK
Contact:

Re: Image Thumbnail

Post by NickWalker » 25 May 2022 08:27

andrewbraid wrote:
25 May 2022 08:04
It's in the box where it there is a link to add images and the thumbnail always used to appear on the left hand side of it after adding.
Ah OK - I've never noticed this myself and I think this is the first time this has been reported. I'll do some investigating.

When you experience this problem on the main form. If you go into the image viewer, does the image thumbnail display correctly at the top left of the form?
Nick Walker
Ancestral Sources Developer

http://www.ancestralsources.com

avatar
ileat
Silver
Posts: 6
Joined: 11 May 2003 16:55
Family Historian: V6.2

Re: Image Thumbnail

Post by ileat » 25 May 2022 11:26

I too have had this issue. During lockdown I used Ancestral Sources to capture several thousand census returns and this issue occured about 5% of the time. For me it was most prevalent with the 1939 register. When I initially noticed it happening I tried deleting the census records in FH and the media files and downloading them again but the same issue would recur with that particular census return. As it didn't prevent the census record being created or the media file being copied to the correct folder I didn't worry about it.

User avatar
NickWalker
Megastar
Posts: 1705
Joined: 02 Jan 2004 17:39
Family Historian: V7
Location: Lancashire, UK
Contact:

Re: Image Thumbnail

Post by NickWalker » 25 May 2022 12:07

It is always helpful to let me know if you spot issues. If I don't know about it, I can't solve it!
Nick Walker
Ancestral Sources Developer

http://www.ancestralsources.com

User avatar
NickWalker
Megastar
Posts: 1705
Joined: 02 Jan 2004 17:39
Family Historian: V7
Location: Lancashire, UK
Contact:

Re: Image Thumbnail

Post by NickWalker » 25 May 2022 16:44

I'm working on the assumption that it may be particular image files that cause the thumbnail to not display. If you find an image that does this, would you mind emailing it to me? (nick at ancestralsources dot com).
Nick Walker
Ancestral Sources Developer

http://www.ancestralsources.com

avatar
andrewbraid
Famous
Posts: 122
Joined: 30 Jul 2005 09:18
Family Historian: V7
Location: Leeds, Yorkshire

Re: Image Thumbnail

Post by andrewbraid » 26 May 2022 06:53

Nick

In answer to your earlier question the thumbnail does not appear in the top left hand corner of the image viewer.
Andrew Braid

avatar
andrewbraid
Famous
Posts: 122
Joined: 30 Jul 2005 09:18
Family Historian: V7
Location: Leeds, Yorkshire

Re: Image Thumbnail

Post by andrewbraid » 26 May 2022 08:00

Nick

I have now slected about a dozen census entries at random over all years in the image viewer and none of them have a thumbnail in the top left.
Andrew Braid

User avatar
NickWalker
Megastar
Posts: 1705
Joined: 02 Jan 2004 17:39
Family Historian: V7
Location: Lancashire, UK
Contact:

Re: Image Thumbnail

Post by NickWalker » 26 May 2022 08:05

The thumbnail only appears when you've added them to the entry, not at the stage where you've just selected it initially.
Nick Walker
Ancestral Sources Developer

http://www.ancestralsources.com

avatar
andrewbraid
Famous
Posts: 122
Joined: 30 Jul 2005 09:18
Family Historian: V7
Location: Leeds, Yorkshire

Re: Image Thumbnail

Post by andrewbraid » 28 May 2022 07:01

Nick

I've just added entries for the US Census 1930, 1940 and 1950. The thumbnails appeared for 1930 and 1940 but not 1950.
Andrew Braid

User avatar
tatewise
Megastar
Posts: 24395
Joined: 25 May 2010 11:00
Family Historian: V7
Location: Torbay, Devon, UK
Contact:

Re: Image Thumbnail

Post by tatewise » 28 May 2022 09:31

Andrew, I suspect it would help Nick if you specified which 1950 Census page has the problem, or even better that you attached the actual image file to your posting so he can repeat the problem. Having a test case is often crucial to fixing a problem.
Mike Tate ~ researching the Tate and Scott family history ~ tatewise ancestry

User avatar
NickWalker
Megastar
Posts: 1705
Joined: 02 Jan 2004 17:39
Family Historian: V7
Location: Lancashire, UK
Contact:

Re: Image Thumbnail

Post by NickWalker » 28 May 2022 09:52

Andrew did email me a problematic image a couple of days ago but the thumbnail showed for me. This is a bit of a head scratcher currently but I will continue to investigate.
Nick Walker
Ancestral Sources Developer

http://www.ancestralsources.com

User avatar
LornaCraig
Megastar
Posts: 2503
Joined: 11 Jan 2005 17:36
Family Historian: V7
Location: Oxfordshire, UK

Re: Image Thumbnail

Post by LornaCraig » 28 May 2022 09:59

Nick, would it help if a lot of us tried exactly the same image? If it depends on the exact PC set up a pattern might emerge.
Lorna

User avatar
NickWalker
Megastar
Posts: 1705
Joined: 02 Jan 2004 17:39
Family Historian: V7
Location: Lancashire, UK
Contact:

Re: Image Thumbnail

Post by NickWalker » 28 May 2022 14:03

I believe I've now found a fix for this problem. Thanks to Andrew and also Richard Hyland for helping me to track down this bug by sending me problematic image files. Weirdly this was not a problem at all when I ran AS in my development environment (Visual Studio) but only happened in the fully compiled release version. I've changed the 'Interpolation Mode' used when creating the thumbnails to a higher setting and this seems to have done the trick. As Richard pointed out the problematic thumbnails were being displayed, they were just very very faint so you needed a combination of good eyesight and a decent monitor to see them!

I've released an update v7.4.3 for testing which I am hopeful will resolve this problem and a few others. See this post for details:
Ancestral Sources v7.4 available to test
Nick Walker
Ancestral Sources Developer

http://www.ancestralsources.com

avatar
andrewbraid
Famous
Posts: 122
Joined: 30 Jul 2005 09:18
Family Historian: V7
Location: Leeds, Yorkshire

Re: Image Thumbnail

Post by andrewbraid » 29 May 2022 07:55

Nick

I have added several US 1950 entries this morning, after updating to 7.4.3, and all the thumbnails have appeared.

Thank you.
Andrew Braid

User avatar
Richard_Hyland
Gold
Posts: 25
Joined: 06 Jun 2011 18:04
Family Historian: V7

Re: Image Thumbnail

Post by Richard_Hyland » 29 May 2022 08:50

Thank you, Nick

I have entered Baptisms, Burials & Marriages this morning and the thumbnail images are showing fully.

Richard

Post Reply