* Problems with Res Privata

Questions regarding use of any Version of Family Historian. Please ensure you have set your Version of Family Historian in your Profile
Post Reply
avatar
changeringer
Newbie
Posts: 3
Joined: 19 Feb 2019 16:58
Family Historian: V5

Problems with Res Privata

Post by changeringer » 19 Feb 2019 17:26

I have used Res Privata successfully for a number of years but recently it seems not to recognise the Gedcom file produced by Family Historian (V. 5). I have re-installed Res Privata but have had the same problem. I am running a 64-bit MS Windows 8.1 system. Could one of Microsoft's updates maybe have created this problem?

User avatar
tatewise
Megastar
Posts: 18612
Joined: 25 May 2010 11:00
Family Historian: V6.2
Location: Torbay, Devon, UK
Contact:

Re: Problems with Res Privata

Post by tatewise » 19 Feb 2019 20:08

Welcome to the FHUG.

If you had said you were using FH V6 then it probably would have been due to the default UTF-16 encoding as explained in Knowledge Base > Utility ~ Res Privata - Gedcom Privatisation, but you are using the 4 year old FH V5 that should not have any problems.

Is the GEDCOM file part of a long established Project or is it something recently acquired?

I have just tried Res Privata on Windows 10 and it seems Ok on ANSI encoded GEDCOM files, but not UTF-8 or UTF-16 encoded files.

BTW:
You might find some of the techniques in Knowledge Base > Export to Website Without Sensitive Data just as effective if not more so.
Mike Tate ~ researching the Tate and Scott family history ~ tatewise ancestry

avatar
AnneEast
Superstar
Posts: 301
Joined: 20 Jul 2005 23:39
Family Historian: V6.2
Location: Cumbria

Re: Problems with Res Privata

Post by AnneEast » 19 Feb 2019 23:44

Sorry to butt in but I just wanted to say 'Look to, changeringer!' Welcome to FHUG!
Anne

avatar
changeringer
Newbie
Posts: 3
Joined: 19 Feb 2019 16:58
Family Historian: V5

Re: Problems with Res Privata

Post by changeringer » 20 Feb 2019 07:49

AnneEast wrote:Sorry to butt in but I just wanted to say 'Look to, changeringer!' Welcome to FHUG!
Anne
Many thanks, Anne, but the treble's long "gone". Apologies for esoteric references to those outside the community of tower bell-ringers.

avatar
changeringer
Newbie
Posts: 3
Joined: 19 Feb 2019 16:58
Family Historian: V5

Re: Problems with Res Privata

Post by changeringer » 20 Feb 2019 08:01

Mike, many thanks for that pointer to the Knowledge Base. I'll check it out.
I have used Family Historian for many years (started with v3) without problems which is why I have never previously raised any issues in this Group. Res Privata has only been used at widely separated intervals and, until recently, caused no hiccups. I have been trying to identify whether any other changes to my system may have created significant differences since I last used Res Privata but can, so far, think of nothing. I have been using Family Tree Analyzer quite a lot over recent weeks but cannot imagine FTA actually changes the Gedcom file.

User avatar
PeterR
Megastar
Posts: 1071
Joined: 10 Jul 2006 16:55
Family Historian: V6.2
Location: Northumberland, UK

Re: Problems with Res Privata

Post by PeterR » 20 Feb 2019 09:53

From Knowledge Base From Knowledge Base > Utility ~ Res Privata - Gedcom Privatisation:—
This programme will not process Family Historian V6 native gedcom files as they are utf-16. Use the Export Gedcom File plugin to make a utf-8 gedcom file, this will be correctly processed by this programme.
Surely some mistake?
Peter Richmond (researching Richmond, Bulman, Martin, Driscoll, Baxter, Hall, Dales, Tyrer)

User avatar
tatewise
Megastar
Posts: 18612
Joined: 25 May 2010 11:00
Family Historian: V6.2
Location: Torbay, Devon, UK
Contact:

Re: Problems with Res Privata

Post by tatewise » 20 Feb 2019 12:01

Peter, the caveat about UTF-16 was added recently by Colin Valkrider, but I also have problems with UTF-8.
I was about to reword it to give clearer options.
What exactly is the "mistake" you have detected?
Mike Tate ~ researching the Tate and Scott family history ~ tatewise ancestry

User avatar
PeterR
Megastar
Posts: 1071
Joined: 10 Jul 2006 16:55
Family Historian: V6.2
Location: Northumberland, UK

Re: Problems with Res Privata

Post by PeterR » 20 Feb 2019 12:12

I (still on Windows 7) also have a problem with UTF-8 so I cannot see how “this will be correctly processed by this programme” can be true.
Peter Richmond (researching Richmond, Bulman, Martin, Driscoll, Baxter, Hall, Dales, Tyrer)

User avatar
tatewise
Megastar
Posts: 18612
Joined: 25 May 2010 11:00
Family Historian: V6.2
Location: Torbay, Devon, UK
Contact:

Re: Problems with Res Privata

Post by tatewise » 20 Feb 2019 12:35

I have updated the wording and hope it makes sense.

On re-reading the whole Description, I am not sure about the third paragraph, because Res Privata does not edit the chosen GED File, but creates a new Output File, so there is no need for a backup or to work on a copy :?

BTW:
The Help does NOT work in Windows 10 nor any recent versions of Windows without the fix given in Knowledge Base > V2/V3 Help Pages Refuse to Display. I've just updated that with a quick fix for Windows 10 if anyone would like to try it out.

HOWEVER, none of that solves changeringer's problem, so some software forensics may be necessary.
Exactly which Help > About Res Privata version are you running?
If it is V2.4.1 then it is later than the V2.2.1 FHUG download (so we would like that copy).
The cause could be a Windows 8.1 update, although unlikely.
Have you tried the Knowledge Base > Res Privata > Download ZIP file that needs no installation or Administrator privilege?
Have you tried using Res Privata on the Family Historian Sample Project or any other Project?
Have you an old Backup of the problematic Project GEDCOM that you could try?
If the latter work, then it is probably not a Windows 8.1 issue, but if all fail, then it probably is Windows 8.1.
If the forensics point to a recent change to just your main Project, then focus on what has changed.
Mike Tate ~ researching the Tate and Scott family history ~ tatewise ancestry

Post Reply